Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

warum geht dieser batch abschnitt nicht

Frage Microsoft

Mitglied: L4a-Thompson

L4a-Thompson (Level 1) - Jetzt verbinden

02.09.2005, aktualisiert 14:11 Uhr, 3948 Aufrufe, 8 Kommentare

:wiederherstellen
if not exist "C:\Dokumente und Einstellungen\Area Code\Anwendungsdaten\Mozilla" goto mz erstellen ELSE if exist "C:\Dokumente und Einstellungen\Area Code\Anwendungsdaten\Mozilla" goto mz weg

:mz weg
RD /S /Q "C:\Dokumente und Einstellungen\Area Code\Anwendungsdaten\Mozilla"
echo.
echo Datei erfolgreich geloescht!
echo.
pause
goto mz erstellen
goto menue 2
exit

:mz erstellen
MD "C:\Dokumente und Einstellungen\Area Code\Anwendungsdaten\Mozilla"
echo.
echo Mozilla Hauptordner erstellt.
echo.
pause
xcopy /e "E:\Stuff\Daten\Mozilla" "C:\Dokumente und Einstellungen\Area Code\Anwendungsdaten\Mozilla"
pause
goto menue2
exit

dieser abschnitt hat immer funktioniert jetzt habe ich formatiert und nun bricht er immer ab un schließt die batch datei woran liegt das die ordner existieren alle wie hier beschrieben
Mitglied: rootadmin
02.09.2005 um 11:49 Uhr
Ich würd die Pfadangaben am besten immer in " " setzen und außerdem ist dein goto mzerstellen nicht vorhanden...

Bei dir heist es :mz erstellen

Also kann dein Computer die Sprungmarke :mz erstellen gar nicht finden

das nur so auf die schnelle...
Bitte warten ..
Mitglied: 16640
02.09.2005 um 11:58 Uhr
ich bin mir jetzt auch nicht sicher, ob überhaupt Leerzeichen in den Labels sein dürfen ... dann gibt es Mehrdeutigkeiten
Bitte warten ..
Mitglied: L4a-Thompson
02.09.2005 um 12:11 Uhr
was für schussel fehler
wenn ich den "Pfad" so schreibe geht es und mit dem mz erstellen ist auch behoben es funtzt fast perfekt wieder

nur warum geht er wenn der ordner nicht existiert trotzdem erst zum löschen und nicht gleich zum erstellen?
Bitte warten ..
Mitglied: rootadmin
02.09.2005 um 12:29 Uhr
versuch das ganze mal ohne else

z.B.

:wiederherstellen
if not exist "C:\Dokumente und Einstellungen\Area Code\Anwendungsdaten\Mozilla" goto mzerstellen
if exist "C:\Dokumente und Einstellungen\Area Code\Anwendungsdaten\Mozilla" goto mzweg
Bitte warten ..
Mitglied: L4a-Thompson
02.09.2005 um 13:00 Uhr
geht trotzdem nicht
hab das else weggelassen und in zwei zeilen geteilt
aber ist trozdem erst am löschen
Bitte warten ..
Mitglied: Karo
02.09.2005 um 13:14 Uhr
Das zweite if exist kannst Du eh weglassen.
Das erste
goto mzerstellen
goto menue 2
exit
kann auch deleted werden. Wird eh als nächstes abgearbeitet.

Also alle Labels ohne Leerzeichen.
Entferne mal ALLE Leerzeichen am ende der zeilen, gerade bei den Labels!

bei mir geht es....

Karo
Bitte warten ..
Mitglied: ben-D-ix
02.09.2005 um 13:14 Uhr
Mahlzeit,
wurde oben bereits erwähnt. In 'Sprungmarken' werden keine Leerzeichen verwendet. Also arbeite mit dem Underline oder schreibe sie zusammen, ansonsten findet er die Sprungziele nicht und arbeitet sich von oben nach unten durch.

Good Look
Bitte warten ..
Mitglied: L4a-Thompson
02.09.2005 um 14:11 Uhr
jetzt geht es richtig danke aus mz erstellen ist jetzt mzerstellen geworden das war alles
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Batch & Shell
gelöst Batch: SET geht nicht?! (3)

Frage von SlainteMhath zum Thema Batch & Shell ...

Batch & Shell
gelöst Batch und Powershell (2)

Frage von michi-ffm zum Thema Batch & Shell ...

Batch & Shell
gelöst Mittels Batch eine Uhrzeit aus einer .txt auslesen und verabeiten (4)

Frage von Beatzler zum Thema Batch & Shell ...

Batch & Shell
gelöst Batch xls nach aktuellem Datum auslesen und email senden (14)

Frage von michi-ffm zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Hardware
Laptop ins Salzwasser gefallen (18)

Frage von Marcel94 zum Thema Hardware ...

Hardware
Lenovo Yoga 500 über angeschlossene USB Tastatur booten (13)

Frage von thomasreischer zum Thema Hardware ...

Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (13)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Viren und Trojaner
Wie werde ich den Mist "fanli90" wieder los? (12)

Frage von Taumel zum Thema Viren und Trojaner ...