Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

geplanter Task startet das Prog. nicht

Frage Microsoft

Mitglied: RobinC

RobinC (Level 1) - Jetzt verbinden

23.07.2005, aktualisiert 15.05.2006, 40473 Aufrufe, 7 Kommentare

geplanter Task startet das Prog. nicht

Hallo,

Ich wollte mittels eines geplanten Tasks eine Datei kopieren.
Hierzu habe ich also eine kleine Batch-Datei mit xcopy geschrieben.
Diese manuell aufgerufen funktioniert perfekt!
Nur diese, über einen Remote eingerichteten "geplanten Task" starten zu lassen, geht nicht?!
Der Task startet auch wie geplant regelmäßig, nur die Batch-Datei wird nicht ausgeführt.
Passwort und Berechtigungen sind OK, der Task mehrfach neu angelegt ?!?

Hat jemand eine Idee, woran es liegen könnte ???

Gruß
Mitglied: n.o.b.o.d.y
24.07.2005 um 09:34 Uhr
Endet Dein Batch auf .bat oder .cmd?
Wenn .bat, dann änder das auf .cmd, dann wir statt des 16-Bit-Systems das 32-Bits-System angesprochen. Dann sollte es gehen.

Hat der User der das Batch starten soll das Recht "Als Starpelverarbeitungsauftrag anmelden..."? Probier es mal mit dem Admin.
Bitte warten ..
Mitglied: Lofote
24.07.2005 um 23:40 Uhr
Falls die Tips oben nicht funktioniert haben, schau dir das Protokoll mal an. Du findest es im Windows-Verzeichnis unter dem Namen SchedLgU.Txt. Dort müsste genauer Fehlercode drinstehen, was passiert ist beim Versuch.

Noch was: Wenn du auf Netzwerkfreigaben anderer Rechner zugreifst, bedenke, dass die in der Session des Tasks keine Laufwerksbuchstaben verbunden haben. Entweder du musst die direkt über UNC-Pfade (also z.B. \\servername\freigabename\verzeichnis\datei.endung) ansprechen, oder du packst am Anfang der Batchdatei nen "net use x: \\servername\freigabename" Befehl rein, der die Verbindung für diese Session entsprechend herstellt.
Bitte warten ..
Mitglied: RobinC
25.07.2005 um 15:33 Uhr
Hallo, ich danke für eure Tip's,

jedoch haben die nicht den gewünschten Erfolg gebracht.

1. Die Änderung von . bat auf .cmd hat nichts bewirkt,
2. Der Task wird schon als Admin ausgeführt,
3. Die Ausführung über UNC-Name klapp auch nicht.
4. In der SchedLgU.txt steht folgendes:

"webcamcopy.job" (webcamcopy.bat)
Start: 25.07.2005 15:10:50
"webcamcopy.job" (webcamcopy.bat)
Ende: 25.07.2005 15:10:50
Ergebnis: Der Task wurde mit folgendem Ergebniswert abgeschlossen0).

Wie man sieht ist am Server ne Webcam angeschlossen, die auch brav alle paar Minuten ihr Bild macht. In der Batch Datei steht ein "xcopy Quelle Ziel Parameter" Befehl, der das Bildchen auf den Webserver kopieren soll. Der geplante Task sollte also nur regelmäßig die Batch Datei zwecks des Kopierens starten.

Das komische ist, daß die Batch-Datei einzel aufgerufen, oder über Start/Ausführen mit UNC-Namen oder LW:/Dateiname einwandfrei klappt. Also kein fehler in der Batch, auch ausführbar (Berechtigungen)
Der geplante Task wird ebenfalls regelmäßig, wie geplant, gestartet. Steht auch keine Fehlermeldung, "konnte nicht gestartet werden" o.ä. hinter, also Kennwort ist OK.

Das einzige, was ich anders mache, ist, daß ich das ganze remote über den Terminaldienstclient versuche, da ich nicht direkt am Server sitze, wo das ganze vorher schon mal funktionierte.

Gruß
Bitte warten ..
Mitglied: Lofote
25.07.2005 um 16:16 Uhr
Servus,

zu 2.: Ein Admin hat *nicht* alle Rechte, aber er darf sich alle Rechte holen. Daher musst du trotzdem prüfen, ob du das Recht "Als Starpelverarbeitungsauftrag anmelden" besitzt:
Start, Ausführen, "secpol.msc", dann "Lokale Richtlinien", "Zuweisen von Benutzerrechten". Dort siehst du, wer welches Recht hat und kannst es direkt ändern, es sei denn der Rechner ist Mitglied einer Win2000+-Domäne, dann muss es über Gruppenrichtlinien gemacht werden.

Ansonsten mach mal folgendes: Häng mal bei den XCOPY-Geschichten "1>C:\1.log 2>C:\2.log" hinten dran. Das produziert zwei Logdateien (die Pfade und Dateinamen kannste ja entsprechend ändern). Berichte, was da drinsteht.
Bitte warten ..
Mitglied: RobinC
25.07.2005 um 20:21 Uhr
Hallo,

habe ich gechecked, die Richtlinien in der Dom. hatte ich zuvor eingestellt,
die log-Datei hat ergeben: 0 Dateien kopiert
Also lag das Problem woanders. Der Task wurde ausgeführt, die Batch auch gestartet, aber xcopy durfte oder konnte nicht kopieren, da die Anmeldung auf dem Webserver fehlte.
Der steht nämlich in einer anderen Domäne, die nicht vertraut ist.
Also Anmeldung mit lokalem Account auf Webserver über Netzwerkumgebung notwendig.
Das funktioniert aber nicht über die Remote Session des Teminalclients, Anmeldung ja, aber kopieren nein (Gruppenrichtlinie des Webservers wahrscheinlich ?!?).
Also hat VNC ausgeholfen, damit bin ich direkt in der Session auf dem Remote und konnte den Task erneut einrichten, anmelden und es funkt. ))

Das mit den unterschiedlichen Sessions verstehe ich noch nicht so ganz, aber wahrscheinlich ist es einfach so ?!?

Vielliecht weißt Du mehr darüber ?

Trotzdem herzlichen Dank für's mitdenken !!!

Gruß
Bitte warten ..
Mitglied: Lofote
26.07.2005 um 09:30 Uhr
Hm, das ist in der Tat seltsam. Ich richte häufig Geplante Tasks via TS-Sessions ein und hatte noch nie Probleme. Keine Ahnung, was da passiert ist :/...

Ach ja, auf die Console kommste auch mit dem Terminalclient. Einfach "mstsc -v:<rechnername-oder-ip> -console" auf deinem Rechner eingeben. Brauchst da also net unbedingt ne zweite Fernsteuerungssoftware .
Bitte warten ..
Mitglied: schrippe77
15.05.2006 um 09:56 Uhr
Habe bei mir das Problem, das der Task gestertet wird, aber als SYSTEM USer. Daher läuft das Programm im Hintergrund! Wie kann ich so einen Task als der User starten, der Eingeloggt ist UND es soll per batch angelegt werden, so in der art "at 8:00 c:\xxx.bat"

thx
Bitte warten ..
Ähnliche Inhalte
Linux
gelöst Google Chrome startet nicht (12)

Frage von Thomas91 zum Thema Linux ...

Windows 10
Windows 10 Task Zugriff verweigert

Frage von Marabunta zum Thema Windows 10 ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(3)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (41)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Off Topic
gelöst Fachzeitschriften als E-Book oder hardcoded? (11)

Frage von KowaKowalski zum Thema Off Topic ...

Windows 10
Windows Store Apps ohne Windows Store installieren (10)

Frage von keefien zum Thema Windows 10 ...