Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Geschwindigkeitseinbruch durh Router?!

Frage Netzwerke Router & Routing

Mitglied: bonito

bonito (Level 1) - Jetzt verbinden

03.11.2014, aktualisiert 05.11.2014, 1150 Aufrufe, 6 Kommentare

Hallo an alle,

ich brauche mal wieder Eure Hilfe.
Sobald ich meinen MikroTik RB2011uas zwischen Netzwerkanschluß und Rechner klemme, geht die Geschwindigkeit massiv in den Keller. Ich habe dann eine Tx-Rate von 1,5-4Mbps, eine Rx-Rate von 9-30kbps (extreme Schwankungen, teilweise sogar Rx-Raten von 3,5Mbps)
Verbinde ich den Rechner direkt mit der Netzwerkdose, läuft alles super. Beim direkten Anschluss habe ich Pingzeiten von 70-100ms, mit Router liegen die Antwortzeiten zwischen 400ms bis hin zum Timeout.
Meine erste Vermutung war ein falsch gesetzter MTU-Wert. Dieser muß für meinen PPPoE auf 1480 gesetzt sein (laut meinem Netzanbieter). Schließe ich den Rechner ohne Router ans Netz, gehen Pakte bis 1450byte ohne Fragmentierung durch. Danach gibt es die Meldung "Das Paket müßte fragmentiert werden."
Im Router habe ich für das Interface "PPPoE-out1" den MTU-Wert und den MRU-Wert auf 1480 gesetzt (hatte auch mit 1450 und 1400 experimentiert). Mit diesen Einstellungen sind teilweise gar keine Pings von intern nach extern möglich (und wenn doch, dann mit Antwortzeiten von 500-3500ms!!).
WAN liegt auf Etherport1, der hat aber einen MTU-Wert von 1500. Gleiches gilt für die local-bridge. Die Firewallregeln sind Default.

Jetzt weiß ich nicht, ob ich einfach zu blöd bin, oder ob und wo ich einen Parameter anpassen muß. Ich hatte schon meinen Netzanbieter in Verdacht, der bei sich gecheckt hat, ob alles läuft. Dabei kam es wohl auch zu Schwankungen in den Antwortzeiten. Seltsam aber, dass mit direkt angeschlossenem PC alles problemlos läuft....

kurze Info zum Aufbau:
Netzwerkzugang über Kabelanbieter (Wohnungsgenossenschaft), Verbindung über PPPoE
Router Mikrotik RB2011uas, Router OS v6.20; WAN auf eth1, LAN auf eth6 oder WLAN

Danke schonmal für Eure Hilfe...
Gruß
bonito
Mitglied: aqui
LÖSUNG 03.11.2014, aktualisiert 05.11.2014
Im Router habe ich für das Interface "PPPoE-out1" den MTU-Wert und den MRU-Wert auf 1480 gesetzt (hatte auch mit 1450 und 1400 experimentiert)
Das ist falsch ! Es ist besser die MSS Werte auf dem lokalen LAN Interface zu setzen, damit Endgeräte schon selber gleich niemals Frames größer 1480 Byte senden. So zwingst du den Router zum fragemntieren was nicht gut ist....siehe dein Ergebnis.
Es reicht dann auf dem PPPoE Interface einzig niur die MTU auf 1492 zu setzen. Warum dein Provider so einen niedrigen Wert verwendet ist schleierhaft ?!
Es würde erheblichen Sinn machen wenn du mal mit einem nackten IP Interface also OHNE PPPoE und NAT (Masquerading) einmal den Durchsatz misst mit NetIO oder IPerf !
So oder so wird der 2011er aber 1 Gig in Wirespeed Forwarding bringen, diese HW kann das eigentlich.
Bitte warten ..
Mitglied: coltseavers
03.11.2014 um 11:17 Uhr
Hi aqui,

habe gerade gleiches Problem.
Nochmal zum mitschreiben:
MTU bei PPPoE also auf 1492, ok. Was ist mit MRU? Auch 1492? Und am LAN-Interface das gleiche, oder dort 1500?

Gruß,
Colt
Bitte warten ..
Mitglied: aqui
LÖSUNG 03.11.2014, aktualisiert 05.11.2014
Die MRU ist bei Ethernet eigentlich Blödsinn, denn es wird nicht separat unterschieden ob Sender oder Empfänger bei Ethernet.
Relevant ist einzig und allein die MTU bzw. MSS auf den lokalen LAN Segmenten mehr nicht.
Welche max. MTU dein Provider supportet kannst du leicht selber mit einem Ping rausbekommen:
http://www.gschwarz.de/mtu-wert-ermitteln
Sieh dir das beispielhaft mal an einer Cisco Router Konfig an:
interface Ethernet 1
description Lokales LAN
ip address 192.168.100.254 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
!
interface PPPoE
description DSL Einwahl Interface
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp

So sollte es bei jedem DSL Router sein mit den MTUs und MSS.
Bitte warten ..
Mitglied: bonito
05.11.2014 um 08:39 Uhr
Hallo aqui,

mit den Einstellung nach Deiner Empfehlung scheint es zu funktionieren. Besten Dank.
Kannst Du mir noch erklären, wozu es die "local Bridge" (was macht die überhaupt?) und das "PPPoE-out"-Interface gibt, wenn man die einzelnen eth-Ports noch separat konfigurieren kann/muss? Das macht die Sache m.E. komplizierter, da man (so wie ich es geschafft habe) Konfigurationen wählen kann, die sich gegenseitig widersprechen... Seltsam.

Gruß
bonito
Bitte warten ..
Mitglied: aqui
05.11.2014, aktualisiert 07.11.2014
Über die Bridge fügt man mehrer Ports als eine Layer 2 Domain zusammen um z.B. eine Gruppe von Ports als Switch zu nutzen.
Da der MT auch selber PPPoE Server spielen kann um PPPoE Clients zu terminieren muss man die PPPoE Funktion entsprechend definieren.
Bitte warten ..
Mitglied: bonito
07.11.2014 um 08:11 Uhr
ah, ok, alles klar. Das mit dem Switch macht die Sache für mich verständlich. Und mit Deiner Erklärung PPPoE-Client vs. PPPoE-Server kommt für mich ein Sinn dahinter.
Danke nochmal und bis zur nächsten Frage...
Bitte warten ..
Ähnliche Inhalte
Router & Routing
gelöst Suche guten Router für Router-Kaskaden (15)

Frage von McLion zum Thema Router & Routing ...

Router & Routing
gelöst Router Cascade: Welcher von beiden Routern sollte VPN Server sein? (5)

Frage von Radlauf zum Thema Router & Routing ...

Internet
Ein Router an den anderen anschließen (8)

Frage von simon939 zum Thema Internet ...

Router & Routing
gelöst Kabel Deutschland Router CBN CH6640E Statische Route (4)

Frage von Maik82 zum Thema Router & Routing ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(14)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Windows Server
Kennwort vergessen bei Hyper vserver 2012r (12)

Frage von jensgebken zum Thema Windows Server ...

Linux Desktop
Bildschirmauflösung unter Linux festlegen (12)

Frage von itebob zum Thema Linux Desktop ...

Windows Userverwaltung
gelöst Administrator hat alle Rechte verloren (10)

Frage von mrdead zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Gebäude mit WLAN ausstatten (9)

Frage von udobec zum Thema LAN, WAN, Wireless ...