Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Hilfe mit Virtual Box Virtuelles Netzwerk einrichten

Frage Netzwerke

Mitglied: OsiMac

OsiMac (Level 1) - Jetzt verbinden

28.05.2014, aktualisiert 19:12 Uhr, 4297 Aufrufe, 3 Kommentare

Siehe angehängte Datei für Konfiguration.


Hallo,

Ich habe ein Problem. Ich habe auf einem Rechner Virtual Box installiert. Dort 4 Maschinen aufgesetzt. Windows 8, 2x Windows Server 2008 R2, und Windows Server 2012 R2. Habe in Virtual Box unter Netzwerk jede Netzwerkkarte auf internes Netz gestellt. Dann die Maschinen installiert. überall gasterweiterung installiert. Die Firewall freigabe überall zwecks PING aktiviert. Die IPs vergeben (siehe Grafik). Auf den 2 Server 2008 habe ich die LAN-Routing (über Routing und Ras ROlle) installiert. Und jeweils 1 ne statische Route vergeben.


Wenn ich jetzt von meinem win 8 client pinge komme ich bis zur ersten Firewall aber nicht bis zur zweiten durch. ping ssagt Zeitüberschreitung bei der Anforderung.

Finde meinen Fehler einfach nicht. Ich denke das alles richtig konfiguriert ist. Ich denke mal es liegt an Virtual Box mit den Netzwerkkarten?!???!?!


Bitte um hilfe

b389c91641bf7b9256bffefc5505dd36 - Klicke auf das Bild, um es zu vergrößern
Mitglied: aqui
28.05.2014, aktualisiert um 20:31 Uhr
Soweit klingt das alles richtig...
  • IP Adressierung stimmt
  • Gateways stimmen soweit auch alle
  • Virtual Box Einrichtung ist auch OK
Das ist schon richtig das die Virtual Box NICs im Hostmodus arbeiten müssen, denn deine jeweiligen NICs müssen ja zwingend untereinander isoliert sein, denn du routetst ja über deine Server. Bridging und NAT scheiden also richtigerweise aus hier.

Soweit klingt das alles plausibel. Vermutlich liegt der Teufel im Detail. Also wie immer strategisch und schrittweise vorgehen um den Fehler einzugrenzen !
Hier die einzelnen Schritte:
  • Zuerst alle internen Peer to Peer Verbindungen gegenseitig pingen 10.1.0.er Partner, 172.16.0.er Partner und 192.168.100.er Partner unter sich. Das muss klappen !
  • Dann jeweils vom 10.1.0.er Client (Win8) das 172.16.0.111 Interface pingen. Das muss auch klappen weil der Server 2008 dazu keine Routing Info braucht, da die Netze direkt an ihm dran sind. Sind die lokalen Firewalls dort richtig customized muss das auch klappen. Wenn nicht, hast du hier ein Firewall Problem !!
Analog machst du das mit 192.1.68.100.112er server und dem 172.16.0.112 Interface auf dem dortigen 2008. Gleiches Spielchen auch das muss klappen wenn die lokalen Firewalls richtig customized sind. Falls auch nicht ist wie wieder nur ein Firewall Problem der Grund !
  • Ganz wichtig bei dem obigen Setup ist das du dort KEIN ICS machst an beiden 2008 Server (NAT bzw. IP Adresstranslation) !! Die 2008er müssen transparent routen OHNE ICS !!
  • Wenn das alles klappt sind das schon 80% ! Als nächstes gilt es die statischen Routen zu überprüfen an den 2008ern. Du musst auf dem 2008 lediglich je eine einzige Route definieren: route add 192.168.100.0 mask 255.255.255.0 172.16.0.112 -p auf dem linken 2008 (Win8) und analog route add 10.1.0.0 mask 255.255.255.0 172.16.0.111 -p auf dem rechten 2008 (DC1). route print zeigt dir auf beiden 2008 ob die Routen korrekt in der jeweiligen Routing Tabelle sind !
  • Stimmen wieder lokale Firewall Freigaben muss nun ein transparentes Pingen aller Komponenten möglich sein. Zusätzlich solltest du hier Traceroute (tracert bei Winblows) und Pathping Kommandos verwenden das dir alle passierten Hops anzeigt.

Was generell zu beachten ist:
Die Endgeräte und Router werden in deinem Setup mit fremden Absender IP Adressen konfrontiert wie ja üblich beim Routing. Hier leuchtet gleich immer die rote Firewall lampe !! Generell blockt die Winblows Firewall alles was nicht vom lokalen Netzwerk kommt, vergiss das nicht ! Firewalling hier immer customizen oder generell ganz ausstellen temporär um nicht in diese Falle zu laufen.
Ferner muss auch ICMP zugelassen werden auch von fremden IPs. ICMP ist Ping und Traceroute.

Beachtet man all das sollte es fehlerlos klappen.
Grundlagen zum Routing auf Winblows und dessen Fallstricke mit ICS erklärt dir dieses Forumstutorial:
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
All die Infos dort gelten analog natürlich auch für virtuelle Rechner.

Wenn du mit den beiden Win 2008 "Routern" nur Internet Router emulieren möchtest ist das gelinde gesagt sehr unglücklich gewählt, denn um Router zu emulieren in einer VM Umgebung nimmt man in der Regel natürlich KEIN Winblows auch wenns generell natürlich damit geht.
Hier wärst du mit einer schlanken Linux Distro wie z.B. Xubuntu erheblich besser bedient in einer VM.
Allein schon deshalb weil du dort Pakete wie "Quagga" oder "Bird" mit einem simplen Mausklick installieren kannst di dir dann dynmaisches Routing supporten in der WAN/DMZ Emulation. So ist viel realitätsnaheres Routing in einer Testumgebung möglich und befreit einen von lästigen Windows Einschränkungen und Macken.

Alternativ zu Linux Router kannst du fix und fertige Firewall Router verwenden die schon als VM Image fertig vorliegen wie z.B. Monowall oder dessen Schwester pfSense.
Mit einem Web GUI zur Konfig hat man dort richtiges Routerfeeling und muss keinen Server Boliden bändigen.
Was Quagga als Router Paket anbetrifft findest du Grundlagen zum Betrieb hier:
http://www.administrator.de/wissen/netzwerk-management-server-mit-raspb ...
Genug gequatscht....

OK...also nun erstmal strategisch den Fehler eingrenzen !
Bitte warten ..
Mitglied: OsiMac
28.05.2014 um 21:20 Uhr
Vielen Lieben Dank. Es lag an meinen Statischen Routen


SUPER !!!!
Bitte warten ..
Mitglied: aqui
29.05.2014 um 09:54 Uhr
An was da genau ? Würde der Forums Community hier sicher helfen Fehler zu vermeiden....

Wenns das denn war bitte dann auch
http://www.administrator.de/faq/32
Nicht vergessen ?
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Virtualisierung
gelöst QEMU KVM - VMware Workstation - Oracle Virtual Box - Was denkt ihr? (17)

Frage von twoDarkMessiah zum Thema Virtualisierung ...

Windows Update
Windows Update funktioniert nicht in Virtual Box (7)

Frage von donfigo zum Thema Windows Update ...

Netzwerke
Windows Netzwerk einrichten (7)

Frage von Enel85 zum Thema Netzwerke ...

Windows Netzwerk
Client-Server-Netzwerk einrichten (5)

Frage von Elduderino zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...