Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

htacces Problem

Frage Entwicklung

Mitglied: FPMH

FPMH (Level 1) - Jetzt verbinden

01.01.2009, aktualisiert 16:40 Uhr, 3438 Aufrufe, 2 Kommentare

Hallo zusammen,

^^zuerst einmal muss ich mich für meinen schlecht gewählten Titel entschuldigen. Mir ist leider kein kurzer prägnanter Titel für mein Problem eingefallen. Ich werde dieses hier jetzt möglichst kurz und einleuchtend erläutern ^ ^

Worum es geht:
Ich möchte auf einer Homepage ein Verzeichnis mit Hilfe von .htaccess mit einem Passwort versehen. Das .htaccess und .htpasswd file wurden erstellt und in das zu Sichernde Verzeichnis kopiert.

.htaccess
01.
AuthUserFile /hp/av/ac/ov/www/vaevictis/privat/.htpasswd 
02.
AuthGroupFile /dev/null 
03.
AuthName "Mitgliederbereich" 
04.
AuthType Basic 
05.
Require valid-user
.htpasswd
01.
test:MTTuFPm3y4m2o
Problem:
Es tritt nun folgendes Problem auf. Wenn ich nun den Gesicherten Bereich aufrufe, öffnet sich das von mir erwünschte Eingabefenster mit Benutzer- und Passwortabfrage. Gebe ich nun den Benutzernamen "test" und das unverschlüsselte Passwort "123" ein, passiert nichts. Das Eingabefenster schließt sich lediglich kurz und öffnet sich dann erneut. Ich habe leider keine Ahnung woran dies liegt. Eine Vermutung wäre, dass das verschlüsselte Passwort nicht stimmt, da ich das Passwort 123 in mehrere Online-MD5-Generatoren eingegeben habe und meist unterschiedliche werte herauskamen.

Daten
Der Server läuft mit der Apacheversion
Apache/2.0.54 (Debian GNU/Linux)

Zur Erstellung der .htaccess und .htpasswd Dateien habe ich mehrere Generatoren versucht und auch die "normale" Eingabe mithilfe eines Editor.
Mitglied: Arano
01.01.2009 um 17:23 Uhr
Hallo Felix,

habe mir deine Direktiven mal kopiert und es nach gebaut, hat wunderbar funktioniert !
Dachte dann noch, das es vielleicht an einer fehlerhaften absoluten Pfadangebe liegen könnte, aber diese würde zu einem "500 Internal Server Error" führen.

Kurz überlegt... eine Einstellung im Firefox geändert und siehe da, selbes verhalten wie du es beschriebst.
Was hatter gemacht, er hat die Cookies deaktiviert.

Überlegung war, das durch das wiedererscheinen der Autorisationsabfrage, die vorher durchgeführt nicht "gespeichert" wurde und so die Abfrage wieder erscheint.
Wo werden die Daten gespeichert, in den Cookies.

Guck mal nach ob dein Browser Cookies akzeptiert.

~Arano
Bitte warten ..
Mitglied: FPMH
01.01.2009 um 20:19 Uhr
Cookies sind akzeptiert. Aber danke für deinen versuch
Bitte warten ..
Ähnliche Inhalte
Windows Server
SimpleHelp - Problem (4)

Frage von ArnoNymous zum Thema Windows Server ...

Microsoft
Problem mit meinem PC (24)

Frage von AaronH96 zum Thema Microsoft ...

DNS
gelöst Wieder ein Problem mit der ASA (4)

Frage von Yannosch zum Thema DNS ...

Vmware
gelöst Keyboard problem (7)

Frage von rocco61 zum Thema Vmware ...

Neue Wissensbeiträge
Viren und Trojaner

Neues Botnetz über IoT-Geräte

Information von certifiedit.net zum Thema Viren und Trojaner ...

Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
Externe IP von innen erreichbar machen (15)

Frage von Windows10Gegner zum Thema Router & Routing ...

Windows Installation
Windows 10 neu installieren (12)

Frage von imebro zum Thema Windows Installation ...

Windows Server
Frage zu Server Rack (11)

Frage von rainergugus zum Thema Windows Server ...