Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Kann httpd Dienst nicht starten.

Frage Internet Server

Mitglied: Mr.FSB311

Mr.FSB311 (Level 1) - Jetzt verbinden

07.09.2014, aktualisiert 09.09.2014, 1899 Aufrufe, 13 Kommentare, 4 Danke

Ich habe bei 1blu einen vServer mit dem OS:centos-6-x86_64

Der httpd Dienst wird mir im Virtuzzo Panel als gestoppt angezeigt.
Jeder versuch ihn über das Panel zu starten Scheitert. (Mit der Meldung :Starten des Dienstes "httpd" fehlgeschlagen.
Cannot start/stop/restart service: httpd starten: httpd: bad user name webfresh
[FEHLGESCHLAGEN] )

Ich bin aber als root eingelogt nicht als webfresh.
Auf einer sub Domain auf dem Server ist allerdings ein User 'webfresh' definiert.

Ich weiß nicht wie ich den Dienst per ssh starten könnte.

in /etc/init.d/ gibt es nur ein httpd. Ich habe versucht über
/etc/init.d/httpd restart ohne erfolg.

über / reboot geht das Teil in die Knie und sartet neu, aber ohne den httpd Dienst.

Danke für eure Bemühungen.
Mitglied: Lochkartenstanzer
07.09.2014 um 18:25 Uhr
Moin,

schau mal ins syslog. Villeich will ja die virtuozzo software den Dienst als Benutzer webfresh starten?

Wie man apache manuell startet hat ja orcape schon verlinkt.

lks
Bitte warten ..
Mitglied: wiesi200
07.09.2014 um 18:43 Uhr
Hallo,

Panel bei Linux, Igitt.

Per sah startet man den Dienst über:
01.
service https erstarrt

Es ist auch nicht wichtig mit welchem Benutzer man angemeldet ist sondern mit welchen der dienst ausgeführt wird.
Dur wirst dir die Apache Config ansehen müssen. Da ist mit Sicherheit der User eingetragen
Bitte warten ..
Mitglied: Dobby
07.09.2014 um 18:45 Uhr
@wiesi200

service https erstarrt
Ja erstarrt ist er ja schon! Also dann nimm lieber restart.

Gruß
Dobby
Bitte warten ..
Mitglied: wiesi200
07.09.2014 um 18:53 Uhr
Zitat von Dobby:

@wiesi200

> service https erstarrt
Ja erstarrt ist er ja schon! Also dann nimm lieber restart.

Gruß
Dobby


Ich bekomm noch mal nen Anfall mit der Autokorrektur.
Bitte warten ..
Mitglied: Pjordorf
07.09.2014 um 19:05 Uhr
Hallo,

Zitat von wiesi200:
Ich bekomm noch mal nen Anfall mit der Autokorrektur.
Schalt sie ab......
Bitte warten ..
Mitglied: SlainteMhath
08.09.2014 um 08:37 Uhr
Moin,

Auf einer sub Domain auf dem Server ist allerdings ein User 'webfresh' definiert.
Existiert denn der user auch im System? bzw hat er euch entsprechende Rechte auf das DocumentRoot?

lg,
Slainte
Bitte warten ..
Mitglied: Mr.FSB311
08.09.2014 um 08:52 Uhr
Das habe ich selbst schon gefunden. Ich habe es versucht. Alles ohne erfolg.
Service httpd erstarrt , restart. ..... Mit oder ohne /sbin/ davor.
Bei # Service httpd restart : fehlgeschlagen bad User Name webfresh
Aber eingeloggt bin ich als root im ssh Client zur Zeit per iPad.
Reboot macht er, nur der httpd Dienst bleibt gestoppt.

Bekomme langsam die Kriese.
Thorsten Lemke
Bitte warten ..
Mitglied: Lochkartenstanzer
08.09.2014, aktualisiert um 09:04 Uhr
Zitat von Mr.FSB311:

Das habe ich selbst schon gefunden. Ich habe es versucht. Alles ohne erfolg.
Service httpd erstarrt , restart. ..... Mit oder ohne /sbin/ davor.
Bei # Service httpd restart : fehlgeschlagen bad User Name webfresh
Aber eingeloggt bin ich als root im ssh Client zur Zeit per iPad.
Reboot macht er, nur der httpd Dienst bleibt gestoppt.

Bekomme langsam die Kriese.
Thorsten Lemke

Dann schalt mal das debugging in der Config ein und schau in die logfiles!

Den LogLevel debug kanst Du ggf auch global statt nur in dem einen virtualhost setzen.

lks

PS: Hast Du inzwischen in die Logdateien geschaut?
Bitte warten ..
Mitglied: wiesi200
LÖSUNG 08.09.2014, aktualisiert 09.09.2014
Zitat von Mr.FSB311:

Das habe ich selbst schon gefunden. Ich habe es versucht. Alles ohne erfolg.
Service httpd erstarrt , restart. ..... Mit oder ohne /sbin/ davor.
Bei # Service httpd restart : fehlgeschlagen bad User Name webfresh
Aber eingeloggt bin ich als root im ssh Client zur Zeit per iPad.
Reboot macht er, nur der httpd Dienst bleibt gestoppt.

Noch mal, es sich absolut egal wie du angemeldet bist. Es spielt eine Rolle mit welchen Benutzer der Dienst ausgeführt wird.
Und das steht normal im Config File vom Apache.

das findet man unter /etc/apache2 oder /etc/httpd

und in diesem File ist dann eine Zeile "user xxxx" und "group xxxx" hier wird vermutlich der Name webfresh drinnen stehen.
Meist läuft der Apache aber mit "www-data"
Bitte warten ..
Mitglied: 16568
08.09.2014 um 09:45 Uhr
Und mit https wirds auch nix, wenn dann eher httpd

Was sagt denn ein:

01.
 tail -f -n 15 /var/log/syslog
direkt nachdem Du versucht hast, den Apachen neu zu starten?


Lonesome Walker
Bitte warten ..
Mitglied: Lochkartenstanzer
08.09.2014 um 09:52 Uhr
Zitat von 16568:

Und mit https wirds auch nix, wenn dann eher httpd

Was sagt denn ein:

01.
 tail -f -n 15 /var/log/syslog
direkt nachdem Du versucht hast, den Apachen neu zu starten?


oder /var/log/apache2/error.log

lks
Bitte warten ..
Mitglied: Mr.FSB311
08.09.2014 um 09:57 Uhr
Mache ich später,habe im Moment zu tun.
Danke Lockkartenstanzer.
Bitte warten ..
Ähnliche Inhalte
Windows Server
Flexlm aus Kommandozeile als Service starten (3)

Frage von rodgerwilco zum Thema Windows Server ...

Ubuntu
Bacula Jobs starten nicht mehr

Frage von D1Ck3n zum Thema Ubuntu ...

Windows Server
gelöst Server 2008 R2: Aufgabe ohne bestimmten Benutzer starten - wie? (3)

Frage von honeybee zum Thema Windows Server ...

Neue Wissensbeiträge
Windows 10

Plattformdienst für unbekannte Geräte (7023)

Tipp von KMUlife zum Thema Windows 10 ...

Administrator.de Feedback

Umgangsformen auf der Seite

(7)

Information von Frank zum Thema Administrator.de Feedback ...

Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(11)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Server
Windows Server Komplettspiegelung (15)

Frage von pdiddo zum Thema Windows Server ...

Batch & Shell
gelöst Dir tc Befehl unter Windows 10 macht Probleme (14)

Frage von sugram zum Thema Batch & Shell ...

Windows Server
Windows Server 2016 RDS Remoteapp Anzeigefehler (11)

Frage von qlnGenius zum Thema Windows Server ...