Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Microsoft Windows Server

GELÖST

Hyper-V Netzwerkadapter Ausfall

Mitglied: Gadlae

Gadlae (Level 1) - Jetzt verbinden

22.12.2014, aktualisiert 19.01.2015, 2238 Aufrufe, 23 Kommentare

Hallo Admingemeinde

Seit geraumer Zeit habe ich ein Problem mit einem Hyper-V Host. Ich hoffe Ihr habt noch eine Idee.

Also kurz zum Überblick:

Server: Dell PowerEdge R720
OS: Windows Server 2012 R2
Netzwerkadapter: 4x Broadcom Gigabit Ethernet

1x Netzwerkadapter für Host
3x für Hyper-V (NIC-Teaming über Windows Server)

Jetzt zum Problem:

Meine Virtuellen Maschinen verlieren immer wieder die Verbindung zum Netzwerk.
Also der Betrieb läuft ganz normal und immer zwischen 19 und 21 Uhr am Abend, verlieren Sie die Verbindung zum Netzwerk. Danach muss ich den Netzwerkadapter neu starten damit es wieder funktioniert.

Das NIC-Teaming habe ich zum test aufgehoben und alles auf einen Adapter gelegt. => das gleiche Problem..... (nicht so häufig, aber immer noch)
Die Treiber habe ich auch neue installiert und bin sogar mit dem Driver Booster 2 darüber (obwohl ich nicht so Fan bin von diesen Tools).

Habt Ihr noch eine Idee?


LG Gadlae



Mitglied: DerWoWusste
22.12.2014, aktualisiert um 13:43 Uhr
Hi.

Was passiert denn zwischen 19 und 21 Uhr? Hoher Traffic durch Backups zufällig? Die Ursache sollte sich doch finden.
Welchen Treiber hast Du aktualisiert, den vom Host?
Bitte warten ..
Mitglied: Gadlae
22.12.2014 um 13:41 Uhr
Hi

Zwischen 19 und 21 Uhr verlieren die Virtuellen Maschinen die Verbindung zum Netzwerk.
Nein keine Backups und auch sonst nichts spezielles. Ich habe das auch schon geprüft mit der Netzwerklast und Test angestellt außerhalb der Zeit und innerhalb dieser Zeit, bei beiden ist nichts passiert.
Die Treiber vom Host (Netzwerkadapter) habe ich aktualisiert. In den VMs ist auch die neuste Version von den Integrations Tools installiert.
Bitte warten ..
Mitglied: DerWoWusste
22.12.2014 um 13:46 Uhr
Nun musst Du wohl oder über genauer hinsehen. Es wird einen kausalen Zusammenhang geben, der in diesen Zeitraum fällt.
Stelle also fest, wann genau es passiert (Überwache von außen per ping), dann hast Du eine sekundengenaue Zeit und kannst nachsehen, was da für Tasks liefen, was für Events geschrieben wurden usw.

Als weiteren Test würde ich eine VM mit einem anderen OS installieren (Linux zum Beispiel) und sehen, wie es der ergeht.
Bitte warten ..
Mitglied: Gadlae
22.12.2014 um 13:56 Uhr
Okay
ich dachte vielleicht hat jemand noch eine Idee.

Den virtuellen Linux geht es genau so....

Oder ist ein Windows Bug bekannt?
Bitte warten ..
Mitglied: DerWoWusste
22.12.2014, aktualisiert um 14:12 Uhr
Den virtuellen Linux geht es genau so
Das macht die Sache doch interessant. Dann sieht es eindeutig nach einem hostseitigen Problem aus.
Weitere Fragen:
-was loggt Linux währenddessen?
-was bedeutet "Adapter neu starten" für Dich genau (bei Windows/bei Linux)?
-welchen Zustand zeigen die Netzwerkkarten denn vor dem Neustart an (Win/Lin)?
-Laufen auf dem Host geplante Tasks?
-Läuft auf dem Host irgendeine Software außer dem Hypervisor?
Bitte warten ..
Mitglied: Gadlae
22.12.2014 um 14:22 Uhr
Das macht die Sache doch interessant. Dann sieht es eindeutig nach einem hostseitigen Problem aus.

Ja das Denke ich auch.

-was loggt Linux währenddessen?

kann ich leider nicht sagen da inzwischen kein Linux mehr darauf läuft. Aber ich weis das es auch dort das gleiche Problem war.

-was bedeutet "Adapter neu starten" für Dich genau (bei Windows/bei Linux)?

Rechtsklick auf den Adapter => deaktivieren
Rechtsklick auf den Adapter => aktivieren

Das ganze auf dem Host (Windows Server 2012 R2)

-welchen Zustand zeigen die Netzwerkkarten denn vor dem Neustart an (Win/Lin)?

ganz Normal, keine Fehlermeldungen im Eventlog

-Laufen auf dem Host geplante Tasks?

Nein um diese Zeit nicht erst um 1:00 Uhr

Dazu noch kurz: Es taucht zu 90% um diese Zeit auf(19-21Uhr). Also nicht immer.

-Läuft auf dem Host irgendeine Software außer dem Hypervisor?

Nur noch das Windows Server Backup aber erst um 1:00 Uhr
Bitte warten ..
Mitglied: DerWoWusste
22.12.2014 um 14:30 Uhr
Ok, ein paar Fragen hat Columbo noch:
-was zeigen die NICs der Gäste an? Bringt ein Neustart der Gast-NIC nichts, und deswegen wurde die Host-NIC neu gestartet, oder wurde das mit der Gast-NIC nie probiert?
-wann suchen die Gäste nach Updates, wann der Host? Schau mal ins Windowsupdate.log
-ist der Host gepatcht?
-das Eventlog des Hosts gibt nichts her zu der Zeit? Mag ich nicht ganz glauben.

Und auf dem Host laufen ganz sicher geplante Tasks - nur nicht welche, die Du erstellt hast, sondern eingebaute. Taste Dich mal über das Eventlog an die Zeiten ran, da sollte genau stehen, wann die NIC wieder aktiviert wurde und im Taskplaner ist auch ein Verlauf/ein Eventlog zur Hand.
Bitte warten ..
Mitglied: Gadlae
22.12.2014 um 14:39 Uhr
Dann beantworte ich Colombo doch gerne die Fragen

-was zeigen die NICs der Gäste an? Bringt ein Neustart der Gast-NIC nichts, und deswegen wurde die Host-NIC neu gestartet,
oder wurde das mit der Gast-NIC nie probiert?

Die gäste haben einfach keine Verbindung zum Netzwerk das nach dem Adapter kommt. Also untereinander können sie kommunizieren.
Der neustart der Gäste NICs bringt nichts...

-wann suchen die Gäste nach Updates, wann der Host? Schau mal ins Windowsupdate.log

Standard mäßig habe ich das über die GPO auf 3 Uhr morgens gelegt.

-ist der Host gepatcht?

Host auf dem neusten stand mit den Updates

-das Eventlog des Hosts gibt nichts her zu der Zeit? Mag ich nicht ganz glauben.

So habe gerade gemerkt das ich einen komischen Filter drin hatte.
Jetzt spuckt er was aus:

Error

NetBT

A duplicate name has been detected on the TCP network. The IP address of the computer that sent the message is in the data. Use nbtstat -n in a command window to see which name is in the Conflict state.
Bitte warten ..
Mitglied: DerWoWusste
22.12.2014, aktualisiert um 14:43 Uhr
Na bitte, das ist doch schon die Ursache. Ein weiterer Rechner mit dem selnen Namen wie der Host ist im Netzwerk unterwegs. IP siehe Event.
Bitte warten ..
Mitglied: Gadlae
22.12.2014 um 14:45 Uhr
Kann das von mehreren Netzwerkadaptern kommen?
Da sonst kein weiterer Rechner mit dem Namen unterwegs ist
Bitte warten ..
Mitglied: DerWoWusste
22.12.2014 um 14:47 Uhr
Hast Du die IP angeschaut? Damit sollte das doch zu finden sein.
Bitte warten ..
Mitglied: Gadlae
22.12.2014 um 14:49 Uhr
Ja es zeigen 4 verschiedene IPs auf den gleichen Namen.
Aber das sollte ja klar sein da ich 4 Adapter habe
Bitte warten ..
Mitglied: Gadlae
22.12.2014 um 14:56 Uhr
Ich habe eher eine Meldung gefunden die passt.

Und das auch immer in der zeit 19-21Uhr

Warning
Broadcom NetXtreme Gigabit Ethernet #3: The network link is down. Check to make sure the network cable is properly connected.


Und dies immer wieder auf einem anderen Adapter außer auf dem der nichts mit dem Hyper-V zu tun hat
Bitte warten ..
Mitglied: DerWoWusste
22.12.2014 um 14:57 Uhr
"zeigen auf den gleichen Namen"? Die anderen 3 IPs sind was, virtuelle Switches?
Mein 12er R2 hat auch 4 Karten, alle 4 sind virtuelle Switches, keine Probleme.

Es ist schwer zu glauben, dass der Fehler wirklich von alleine kommt.
Bitte warten ..
Mitglied: Gadlae
22.12.2014 um 15:00 Uhr
Sind alles Physische Adapter die dann an einem Virtuellen Switch hängen.

Aber eben wie oben genannt habe ich noch eine neue Meldung gefunden, was ja darauf hinweist das sie die Verbindung verlieren.
Bitte warten ..
Mitglied: jsysde
22.12.2014 um 15:02 Uhr
Moin.

Hast du die BACS installiert? Machst du das Teaming darüber?
Oder über die integrierte Teaming-Funktion von 2012R2?

Cheers,
jsysde
Bitte warten ..
Mitglied: Gadlae
22.12.2014 um 15:07 Uhr
Moin

Das Teaming lief über die 2012R2 Funktion. Aber ich habe sie deaktiviert um heraus zu finden ob es daran liegt.
Aber Fehlanzeige
Und seit ich das Teaming deaktiviert habe habe ich den Fehler mit NetBT
Bitte warten ..
Mitglied: jsysde
LÖSUNG 22.12.2014, aktualisiert 19.01.2015
Moin.
Zitat von Gadlae:
Das Teaming lief über die 2012R2 Funktion. Aber ich habe sie deaktiviert um heraus zu finden ob es daran liegt.
Aber Fehlanzeige
Und seit ich das Teaming deaktiviert habe habe ich den Fehler mit NetBT

Und BACS installiert?
Ich hatte unschöne Effekte bei installierter BACS und Verwendung der 2012R2-Teamingfunktion.

Wenn installiert, tät' ich BACS mal runterwerfen.

Und btw. bei den DELL-Kistchen gibt es doch auch regelmässig Firmware-Updates für alle möglichen Komponenten, sind die auch aktuell? Nicht nur die Treiber?

Cheers,
jsysde
Bitte warten ..
Mitglied: aqui
22.12.2014 um 15:15 Uhr
Machst du das Teaming darüber?
Vermutlich das faslche "Teaming" und nichts was 802.3ad basierend ist mit LACP. Das einzige was Switches verstehen.
MS ist da etwas verwiirend.
Lesenswert dazu ist das:
http://www.administrator.de/link/windows-nic-teaming-230298.html
Oder entsprechende Threads hier zu dem Thema:
http://www.administrator.de/content/detail.php?id=247466&token=446
http://www.administrator.de/index.php?content=173909
http://www.administrator.de/index.php?content=110462
http://www.administrator.de/index.php?content=112965
http://www.administrator.de/index.php?content=113735
http://www.administrator.de/index.php?content=117829
Ist das nicht sauber umgesetzt kann sowas passieren wie das obige...
Bitte warten ..
Mitglied: psannz
LÖSUNG 22.12.2014, aktualisiert 19.01.2015
Sers,

NIC Firmwares sind auch aktuell? Vor nem Jahr gab es mit u.a. bei den R720ern mit Broadcom NICs über mehrere Monate massiv Probleme wenn VMQ von den VMs genutzt wurde. Unabhängig davon ob irgend ein Teaming statt findet.

Grüße,
Philip
Bitte warten ..
Mitglied: Gadlae
22.12.2014 um 15:20 Uhr
Jetzt wo du es sagst. Das Management von Broadcom habe ich etwa 1 Woche bevor es angefangen hat installiert.
Ich schmeiße das definitiv einmal runter.
Bitte warten ..
Mitglied: Gadlae
22.12.2014 um 15:24 Uhr
Die Links werde ich mir mal durchsehen.

Die Firmware habe ich nie aktualisiert aber das ganze hat 3 Monate funktioniert und die einzige Änderung war das ich diese Managementkonsole installiert habe.
Deinstallieren, Reboot und ein paar Tage warten.

Danke für die Kommentare, ich meld mich dann nachdem ich es getestet habe.

LG Gadlae
Bitte warten ..
Mitglied: Gadlae
19.01.2015 um 16:28 Uhr
Also nach der Aktualisierung von der Firmware und der Neuinstallation von den Netzwerkadaptern läuft alles ohne Probleme.
mal sehen wie es weitergeht.

Danke für die Hilfe

LG Gadlae
Bitte warten ..
Ähnliche Inhalte
Hyper-V
Hyper-V Win XP kein Netzwerkadapter vorhanden
gelöst Frage von 115122Hyper-V5 Kommentare

Hallo, ich habe letzte Woche zwei virtuelle PCs aufgesetzt, einmal mit Windows Server 2012 R2 und eine mit Win ...

Hyper-V
Hyper-V unter Hyper-V installieren
gelöst Frage von ConfettiHyper-V3 Kommentare

Hallo, ich habe auf meinem Windows 8 Pro - PC die Virtualisierungssoftware Hyper-V installiert. Als Virtualen PC hab ich ...

Windows Server
Netzwerkadapter auf V-Server deaktiviert
gelöst Frage von franki2k3Windows Server27 Kommentare

Hallo zusammen! Ich habe ein Riesenproblem und hoffe, dass ich mir helfen könnt. Ich habe einen VServer bei Strato. ...

Hyper-V
Hyper-V: Kein Internetzugriff der Hyper-V Clients
gelöst Frage von wksadmmrHyper-V

Update Update Problem besteht nicht mehr. Ich habe, bevor ich diese Frage eingestellt habe, ziemlich an den VM's bzw. ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 20 StundenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 1 TagTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 1 TagSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 1 TagSicherheit9 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Sicherheit
Meltdown und Spectre: Die machen uns alle was vor
Information von FrankSicherheit25 Kommentare

Aktuell sieht es in den Medien so aus, als hätten die Hersteller wie Intel, Microsoft und Co den aktuellen ...

Netzwerke
Packet loss bei "InternetLeitungsvollauslastung"
gelöst Frage von Freak-On-SiliconNetzwerke17 Kommentare

Servus; Ja der Titel klingt komisch, is aber so. Wenn die Internetleitung voll ausgelastet ist, hab ich extreme packet ...

Ubuntu
Ubuntu - Starter für nicht vertrauenswürdige Anwendungen
Frage von adm2015Ubuntu17 Kommentare

Hallo zusammen, Ich verwende derzeit die Ubuntu Versionen 17.10 bzw. im Test 18.04. Ich habe mehrere .desktop Dateien in ...

Windows 10
Automatische daten kopieren, USB zu USB unter Win10 im Hintergrund
Frage von DerEisigeWindows 1016 Kommentare

Hallo Leute, ich bin auf der Suche nach einem Skript, dass von einem USB Stick automatisch nach dem einstecken ...