Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Hyperlink in Excel funktioniert nach speichern der Datei nicht mehr

Frage Microsoft Microsoft Office

Mitglied: KMP1988

KMP1988 (Level 2) - Jetzt verbinden

26.10.2009, aktualisiert 18.10.2012, 31371 Aufrufe, 16 Kommentare

Servus

bei einem Kunden von uns habe ich folgendes Problem:
Wenn ich im Excel einen Hyperlink hinzufügen will funktioniert er problemlos bis ich auf speichern klicke...
Ab dann funktioniert der Hyperlink nicht mehr...
Keine Fehlermeldung, gar nichts...

Bei meinem Excel funktioniert es aber problemlos..
was kann das sein?

Gruß Kernmaster
Mitglied: 76109
26.10.2009 um 12:17 Uhr
Hallo Kernmaster!

Das ist schon sehr sonderbar. Enthält die Excel-Datei Makro's? Und ist der Hyperlink-Text noch da?

Gruß Dieter
Bitte warten ..
Mitglied: KMP1988
26.10.2009 um 12:33 Uhr
Die Datei enthält keine Makro`s.
Der Hyperlinktext ist noch da aber verändert...
vor dem Link sind sehr viele backslashe
Bitte warten ..
Mitglied: SamTrex
26.10.2009 um 12:44 Uhr
Hi,
in welchem Format speicherst du denn die Datei?
xls oder xlsx

Ich bin mir da zwar nicht sicher, aber die xlsx unterstützt einiges nicht.
Probier mal.

Gruß Sam
Bitte warten ..
Mitglied: KMP1988
26.10.2009 um 12:54 Uhr
Ich speichere im xls Format.
Es ist Excel 2003.
Bitte warten ..
Mitglied: 76109
26.10.2009 um 13:25 Uhr
Hallo Kernmaster!

Sorry, für dieses Phänomen habe ich leider keine Erklärung.

Gruß Dieter
Bitte warten ..
Mitglied: 25110
26.10.2009 um 14:11 Uhr
Hallo,

eine Möglichkeit: Extras > Optionen > Allgemein > Weboptionen > Dateien
Dort die Option „Links beim Speichern aktualisieren“ deaktivieren.

lies mal bei Microsoft nach: http://support.microsoft.com/kb/890474/de

mfg
Bitte warten ..
Mitglied: KMP1988
26.10.2009 um 14:34 Uhr
Danke ich werds ausprobieren!!!
Bitte warten ..
Mitglied: KMP1988
30.10.2009 um 11:48 Uhr
es hat nicht geklappt...
Ich habe den Hacken rausgetan aber es funktioniert immer noch nicht...

Hatte jetzt mal einen einfall das es nicht klappen könnte weil in dem Link mehrere Leerzeichen drin sind...
Bei mir im Büro funktionieren die Links auch mit Leerzeichen.
Aber beim Kunden nicht... Da es eine große Firma ist sind Leerzeichen in Ordner und Dateien nicht zu verhindern...
Wisst ihr evtl noch eine Lösung??
Bitte warten ..
Mitglied: 76109
30.10.2009 um 12:42 Uhr
Hallo Kernmaster!

Also, an den Leerzeichen sollte es nicht liegen, zumal die Standard-Ordner von Windows z.B. "Eigene Dateien" etc. auch Leerzeichen enthalten. Nur Web-Url's dürfen keine Leerzeichen enthalten. Ansonsten habe ich leider immer noch keine Erklärung.

Gruß Dieter

PS. Ruf doch mal bei Microsoft an!
Bitte warten ..
Mitglied: KMP1988
30.10.2009 um 13:05 Uhr
Ja das komische ist einfach wenn ich den Link anlege dann füllt er die Leerzeichen nach dem speichern automatisch mit "%20" aus...
Des ist aber nur bei diesem Kunden!
Bei mir funktioniert es einwandfrei...
Bitte warten ..
Mitglied: 76109
06.11.2009 um 09:59 Uhr
Hallo Kernmaster!

Also, inzwischen ist mir was aufgefallen und vermute, dass die Links auf Ordner/Dateien in einer Server-Umgebung zeigen. Insofern habe ich zusammengefasst dieses Beispiel gefunden, was das genannte Phänomen und auch warum sich der Hyperlink nicht speichern lässt, erklären würde.

Clientseitig ist Voraussetzung, dass die Freigabe "\\server\%username%" auf einen Laufwerksbuchstaben z.B. "X:" gemapped wurde. der Pfad sieht dann in etwa so aus: "X:\\\\Ordner\\\\Datei.xy"

Gruß Dieter
Bitte warten ..
Mitglied: KMP1988
06.11.2009 um 10:09 Uhr
Also du meinste wenn die Freigabe auf einen Laufwerksbuchstaben gemapped ist, funktioniert es?!
Bitte warten ..
Mitglied: 76109
06.11.2009 um 10:16 Uhr
Hallo Kernmaster!

Sorry, aber das kann ich nur vermuten, da ich selbst keine Serverumgebung habe und es somit auch nicht testen kann.

Gruß Dieter
Bitte warten ..
Mitglied: KMP1988
06.11.2009 um 10:22 Uhr
Soweit ich es in erinnerung hab wurde das Laufwerk schon gemappt...
Komm erst wieder am Montag zum Kunden...
Da kann ich nachschaun.
Danke!!

Gruß Stephan
Bitte warten ..
Mitglied: mrplow
28.01.2010 um 16:34 Uhr
Dieses Problem bzw. die Frage wird als gelöst markiert, nur eine Antwort ist nicht vorhanden. Ich habe ein ziemlich ähnliches Problem und Suche daher immer noch nach der Lösung.

Habe eine Excel-Datei, mit Hyperlinks, die auf einem gemappten Laufwerk liegt, auf die unterschiedliche User zugreifen sollen. Die Hyperlinks verweisen auf unterschiedliche Ordner auf selbigem Laufwerk. Klickt man den Link an, öffnet sich der entsprechende Ordner. Anlegen und Aufrufen der Links klappt erstmal. Sobald aber der Rechner aus war, nicht das Laufwerk denn dies ist immer an, und ich die Excel-Datei wieder öffne und auf den Link zugreifen will, kommt die Fehlermeldung: "Die Adresse dieser Web Site ist unzulässig. Überprüfen Sie die Adresse und versuchen Sie es erneut." Auch passiert dies wenn ein anderer User darauf zugreifen will.
Wie im ersten Post beschrieben, fallen auch mir die Veränderungen in der Syntax ins Auge, die ich auch nicht gänzlich nachvollziehen kann. Die Links funktionieren aber dennoch, denn mit einem Trick konnte ich dies herausfinden. Nehme ich die Excel-Datei und speichere diese als Kopie ab, dann funktionieren die Links. Nur für die tägliche Arbeit kann ich ja nicht ständig die Datei als Kopie speichern und die Alte ersetzen. Vielleicht hat ja jemand von Euch, nach dieser etwas genaueren Beschreibung, einen wirklichen Lösungsansatz.
Würde mich sehr freuen.
Bitte warten ..
Mitglied: 76109
28.01.2010, aktualisiert 18.10.2012
Hallo mrplow!

Also, eine professionelle Lösung für dieses Probleme habe ich leider nicht, allerdings eine mögliche Alternative z.B.:
A B
1
2 http://www.administrator.de/forum/hyperlink-in-excel-funktioniert-nach- ... =WENN(A2<>"";HYPERLINK(A2;"Link");"")
Wobei in den Zellen mit den aktuellen Hyperlinks, die Hyperlinks per rechtsklick entfernt werden, sodass nur der Text stehen bleibt und die Formel in eine beliebige Zelle eingefügt, die Schriftfarbe blau geändert wird, dann sollte diese Methode funktionieren.

Gruß Dieter
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
HTML
gelöst Zelle aus Excel in HTML-Datei einer E-Mail darstellen (3)

Frage von Sil3nz3r zum Thema HTML ...

VB for Applications
gelöst Datei mit variablem Namen einlesen und als Excel speichern (1)

Frage von Anrion zum Thema VB for Applications ...

VB for Applications
gelöst VB Skript Excel Datei (3)

Frage von Frager zum Thema VB for Applications ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (21)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...