Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Icacls funktioniert nicht

Frage Entwicklung Batch & Shell

Mitglied: K-ist-K

K-ist-K (Level 1) - Jetzt verbinden

07.01.2015, aktualisiert 08.01.2015, 1506 Aufrufe, 3 Kommentare

Hallo,

ich möchte unter C:\ einen Ordner anlegen, nennen wir diesen Ordner einfach "TEST"
Das möchte ich mit einen Script realisieren, automatisch einen Ordner anlegen für alle AD User über GPO.

Mein Ablauf:

Script anlegen xxx.cmd
01.
if exist C:\TEST goto is_created 
02.
mkdir C:\TEST 
03.
 
04.
icacls C:\TEST /grant Jeder:(CI)(OI)(RX) /inheritance:d 
05.
icacls C:\TEST /grant *S-1-5-11:(CI)(OI)(RX) /inheritance:d 
06.
 
07.
:is_created 
08.
 
09.
code 
10.
code 
11.
code
Das Problem.
Alle Gruppen was ich neu hinzufüge die passen.
Wenn aber Gruppen schon vorhanden sind wie die (Authentifizierte Benutzer)
dann werden die Rechte nicht angepasst.

Warum möchte ich die Rechte ändern ?
Damit die User den Ordner nicht löschen können.

(CI)(OI) - Veerben auf alle Unterordner und Dateien 
(F) Vollzugriff 
(M) Ändern 
(RX) Lesen und Ausführen 
(N) Kein Zugriff
Habe ich was falsch gemacht oder ist das ein Bug ...... ?

Lg K
Mitglied: 114757
LÖSUNG 07.01.2015, aktualisiert um 16:54 Uhr
Moin,
du gibts zwar die Vererbungsoptionen in deinen Zeilen an aber keinerlei Rechte hinter den Vererbungsoptionen. Die Rechte dürfen dabei nicht in Klammern stehen.
also z.B. (OI)(CI)F
Siehe: http://technet.microsoft.com/de-de/library/cc753525(v=ws.10).aspx

Gruß jodel32
Bitte warten ..
Mitglied: K-ist-K
07.01.2015, aktualisiert um 16:55 Uhr
Also ist mein Code falsch ?

icacls C:\TEST /grant Jeder: (CI) (OI) (RX) /inheritance: d

Ich hab jetzt Leerzeichen reingemacht, damit keine Smileys kommen

Habs jetzt gefunden dieser Befehl funktioniert:
icacls C:\TEST /grant *S-1-5-11 : (d,wdac) /inheritance:d


DANKE für die Hilfe
Bitte warten ..
Mitglied: bastla
07.01.2015 um 19:19 Uhr
[OT]
Hallo K-ist-K!
Ich hab jetzt Leerzeichen reingemacht, damit keine Smileys kommen
U.a. dafür gibt es ja die "Code"-Formatierung ...

Grüße
bastla
[/OT]
Bitte warten ..
Ähnliche Inhalte
Windows 10
Windows 10 Update funktioniert nicht (8)

Frage von master3477 zum Thema Windows 10 ...

MikroTik RouterOS
gelöst Mikrotik externe SD Card funktioniert nicht (9)

Frage von sebasscha zum Thema MikroTik RouterOS ...

Router & Routing
gelöst WOL über zwei Router - Ping funktioniert nicht (3)

Frage von erdmelone zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...