Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

IIS7 - PHP langsam

Frage Internet Server

Mitglied: pascal1888

pascal1888 (Level 1) - Jetzt verbinden

19.07.2011 um 20:41 Uhr, 5198 Aufrufe, 1 Kommentar

Hallo,

ich hab mich in letzter zeit damit rumgeschlagen mit dem IIS7 klar zu kommen. Zuvor hatte ich xampp mit Apache laufen. ich wollte mich aber mal mit dem IIS beschäftigen.

Die erste hürde war PHP zum laufen zu bekommen. Da stellte sich die Frage ob über ISAPI oder CGI.
Der Webinstaller von Microsoft hat dies aber dann Problemlos erledigt und zwar über FastCGI da ISAPI anscheinend bei PHP 5.3 nicht mehr unterstützt wird.

Meine Seite welche vorher Problemlos lief auf dem Apache und dem Mysql vom xampp läuft jetzt auf dem IIS.
Allerdings wird immernoch die MySql vom xampp genommen.

Jetzt haben ich das Problem dass sich die seiten über den IIS langsamer als vom Apache aufbauen. An was könnte das denn liegen?

Ich habe eine Dyndns weiterleitung.

Allerdings läuft der FTP dienst vom IIS sehr schnell ... da merkt man keine verzögerung.

Hat jemand eine Idee ?

Gruß
Pascal
Mitglied: pascal1888
20.07.2011 um 10:55 Uhr
Ich habe das Problem in den griff bekommen und wollte hier mal noch meine Lösung mitteilen ;)

also es lag daran dass anscheinend PHP 5.3 ein Problem mit dem auflösen von "localhost" hat. Es wurde in einem anderen Forum berichtet IPv6 zu deaktivieren. Wenn man dies nicht möche dann einfach localhost mit der IP also 127.0.0.1 ersetzen in den skripten dann klappts.

Es ist echt spürbar schneller.

Gruß
Pascal
Bitte warten ..
Ähnliche Inhalte
Server-Hardware
gelöst ESXi 6.0 Schreibvorgang langsam auf DL 380 G7 (9)

Frage von Leo-le zum Thema Server-Hardware ...

PHP
PHP PDO Problem (1)

Frage von Tiggr1994 zum Thema PHP ...

Ubuntu
Cron spamt root mit mails zu (php sessionclean) (4)

Frage von tommy1735 zum Thema Ubuntu ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...