Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Netzwerke Router & Routing

InterVlan Routing - Cisco

Mitglied: PatrickKnott

PatrickKnott (Level 1) - Jetzt verbinden

23.11.2007, aktualisiert 25.11.2007, 5246 Aufrufe, 1 Kommentar

Hallo Gemeinde,

ich hoffe ihr könnt mir helfen. Erstma bitte ich bin kein Cisco Experte mache aktuell eine Ausbildung bei der Telekom und hoffe in den 3 Jahren etwas schlauer zu werden und auch das Zerfitikat von Cisco zu bekommen (Berufsschule).

Nun zu meinem Problem wir / ich hatten in der Realität einen Layer2-Switch von AT und einen Cisco Router 2600. Es ging um einen Versuchsaufbau, den Switch wurden 24 Vlans zu seinen 24 Ports zugewiesen den letzten (24) als Trunk an diesem hing der Router... Leider funktionierten unsere Ideen nicht also setzte ich mich mit Packet Tracer hin und probiere es daheim.

Das Problem ist die beiden PC's und der Server können sich jetzt alle gegenseitig anpingen, ich wöllt es aber lieber so das nur die VLAN-ID's 10 mit der 24, sowie die 11 mit der 24. Später eventuell neben der 24 auch die 9 ( InternetRouter Teledat 820 )

Also nur mit dem Server, und nicht gegenseitig... Geht das?


Einige Daten:

Pc0: 192.168.10.2
Pc1: 192.168.11.2
Server: 192.168.24.100

Konfiguration des Routers:
01.
version 12.2 
02.
no service password-encryption 
03.
04.
hostname Router 
05.
06.
07.
08.
09.
interface FastEthernet0/0 
10.
 no ip address 
11.
 duplex auto 
12.
 speed auto 
13.
14.
interface FastEthernet0/0.1 
15.
 encapsulation dot1Q 1 native 
16.
 ip address 192.168.1.1 255.255.255.0 
17.
18.
interface FastEthernet0/0.10 
19.
 encapsulation dot1Q 10 
20.
 ip address 192.168.10.1 255.255.255.0 
21.
22.
interface FastEthernet0/0.11 
23.
 encapsulation dot1Q 11 
24.
 ip address 192.168.11.1 255.255.255.0 
25.
26.
interface FastEthernet0/0.24 
27.
 encapsulation dot1Q 24 
28.
 ip address 192.168.24.1 255.255.255.0 
29.
30.
ip classless 
31.
ip route 192.168.24.0 255.255.255.0 FastEthernet0/0.24  
32.
ip route 192.168.10.0 255.255.255.0 FastEthernet0/0.10  
33.
ip route 192.168.11.0 255.255.255.0 FastEthernet0/0.11  
34.
ip route 192.168.1.0 255.255.255.0 FastEthernet0/0.1  
35.
36.
37.
38.
39.
line con 0 
40.
line vty 0 4 
41.
 login 
42.
43.
44.
end
Konfiguratuion Switch:
01.
version 12.1 
02.
no service password-encryption 
03.
04.
hostname Switch 
05.
06.
07.
08.
interface FastEthernet0/1 
09.
 switchport trunk allowed vlan 10-11,24 
10.
 switchport mode trunk 
11.
12.
interface FastEthernet0/2 
13.
14.
interface FastEthernet0/3 
15.
16.
interface FastEthernet0/4 
17.
18.
interface FastEthernet0/5 
19.
20.
interface FastEthernet0/6 
21.
22.
interface FastEthernet0/7 
23.
24.
interface FastEthernet0/8 
25.
26.
interface FastEthernet0/9 
27.
28.
interface FastEthernet0/10 
29.
 switchport access vlan 10 
30.
31.
interface FastEthernet0/11 
32.
 switchport access vlan 11 
33.
34.
interface FastEthernet0/12 
35.
36.
interface FastEthernet0/13 
37.
38.
interface FastEthernet0/14 
39.
40.
interface FastEthernet0/15 
41.
42.
interface FastEthernet0/16 
43.
44.
interface FastEthernet0/17 
45.
46.
interface FastEthernet0/18 
47.
48.
interface FastEthernet0/19 
49.
50.
interface FastEthernet0/20 
51.
52.
interface FastEthernet0/21 
53.
54.
interface FastEthernet0/22 
55.
56.
interface FastEthernet0/23 
57.
58.
interface FastEthernet0/24 
59.
 switchport access vlan 24 
60.
61.
interface Vlan1 
62.
 ip address 192.168.1.2 255.255.255.0 
63.
64.
line con 0 
65.
66.
line vty 0 4 
67.
 login 
68.
line vty 5 15 
69.
 login 
70.
71.
72.
end
40aa96c1e786e6cb5b94feae90ac1f40-vlan - Klicke auf das Bild, um es zu vergrößern
Mitglied: aqui
25.11.2007 um 12:59 Uhr
Schon wieder ein Cisco Knecht mehr...
Die Lösung ist aber ganz einfach:

Der 2950 ist ein reiner Layer 2 Switch, hier wirst du also nichts mit einem Blocken des verkehrs zwischen den VLANs, das ja der Router über die virtuellen Subinterfaces macht.

Hier konfigurierst du nun eine ganz banale Access Liste, die dein Problem dann elegant löst

So sieht sie aus:
01.
interface FastEthernet0/0 
02.
 no ip address 
03.
 duplex auto 
04.
 speed auto 
05.
06.
interface FastEthernet0/0.1 
07.
 encapsulation dot1Q 1 native 
08.
 ip address 192.168.1.1 255.255.255.0 
09.
10.
interface FastEthernet0/0.10 
11.
 encapsulation dot1Q 10 
12.
 ip address 192.168.10.1 255.255.255.0 
13.
 ip access-group 100 in 
14.
15.
interface FastEthernet0/0.11 
16.
 encapsulation dot1Q 11 
17.
 ip address 192.168.11.1 255.255.255.0 
18.
 ip access-group 101 in 
19.
20.
interface FastEthernet0/0.24 
21.
 encapsulation dot1Q 24 
22.
 ip address 192.168.24.1 255.255.255.0 
23.
 
24.
access-list 100 permit ip 192.168.10.0 0.0.0.255 192.168.24.0 0.0.0.255 
25.
access-list 101 permit ip 192.168.11.0 0.0.0.255 192.168.24.0 0.0.0.255
Damit ist dann von den Interfaces FastEthernet0/0.10 und FastEthernet0/0.11 nur noch eine Verbindung ins 24er Subnetz möglich.
Für dein 9er Subnetz machst du es dann analog !! Je nachdem was du in die ACL einkonfigurierst, kannst du die Verbindung auch noch für weideres Netze öffnen falls gewünscht.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Router für InterVLAN Routing gesucht
gelöst Frage von Ch3p4cKRouter & Routing21 Kommentare

Hallo zusammen, ich bin auf der Suche nach einem Router, den ich zum Routen zwischen VLANs nutzen kann. Zur ...

Router & Routing
Routing zwischen VLAN mit Cisco RV320
gelöst Frage von Reini82Router & Routing7 Kommentare

Hallo allerseits, wir haben uns den Cisco RV320 Dual-WAN Router zugelegt damit wir zum einen unsere beiden DSL-Anschlüsse zusammenlegen ...

Switche und Hubs
Cisco SG300 - Routing Problem
Frage von StandardpasswortSwitche und Hubs15 Kommentare

Okay, wie erwartet bekomme ich die das Routen mit dem SG300 nicht hin. Hier nochmal die gewünschte Zielkonfiguration: VLAN10: ...

Router & Routing
Cisco SG300 - Kein Routing ins VLAN
gelöst Frage von Fluxx1337Router & Routing4 Kommentare

Hallo zusammen, Was ich möchte sieht man gut auf der Skizze. PC1 soll sich im dhcp Netz der Fritzbox ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 16 StundenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 1 TagTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 1 TagSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 1 TagSicherheit9 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Sicherheit
Meltdown und Spectre: Die machen uns alle was vor
Information von FrankSicherheit25 Kommentare

Aktuell sieht es in den Medien so aus, als hätten die Hersteller wie Intel, Microsoft und Co den aktuellen ...

Netzwerke
Packet loss bei "InternetLeitungsvollauslastung"
gelöst Frage von Freak-On-SiliconNetzwerke17 Kommentare

Servus; Ja der Titel klingt komisch, is aber so. Wenn die Internetleitung voll ausgelastet ist, hab ich extreme packet ...

Ubuntu
Ubuntu - Starter für nicht vertrauenswürdige Anwendungen
Frage von adm2015Ubuntu17 Kommentare

Hallo zusammen, Ich verwende derzeit die Ubuntu Versionen 17.10 bzw. im Test 18.04. Ich habe mehrere .desktop Dateien in ...

Windows 10
Automatische daten kopieren, USB zu USB unter Win10 im Hintergrund
Frage von DerEisigeWindows 1016 Kommentare

Hallo Leute, ich bin auf der Suche nach einem Skript, dass von einem USB Stick automatisch nach dem einstecken ...