Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Laufwerkmapping mit runas funktioniert nicht

Frage Microsoft

Mitglied: hambuergaer

hambuergaer (Level 1) - Jetzt verbinden

23.12.2008, aktualisiert 09:42 Uhr, 5440 Aufrufe, 12 Kommentare

Hallo zusammen,

ich bin gestern im Rahmen eines anderen Vorhabens auf ein Problem gestoßen. Ich versuche mit "runas" ein Laufwerk zu mappen. Führe ich den Befehl

net use h: \\servername\freigabename Passwort /USER:domäne\user

unter dem User aus, der angemeldet ist, dann funktioniert das Mapping. Schreibe ich ein Script, in dem das Laufwerksmapping eingebunden ist, und starte das Script mit runas, dann funktioniert das Mapping leider nicht

runas /user:aktuell_angemeldeter_user c:\temp\map-drives.bat

Hintergrund ist folgender. Ich möchte mit Hilfe von Autoexnt beim Start meines Servers ein paar Server-Programme automatisch starten, ohne das ein User angemeldet ist. Davor muss ein Laufwerk gemappt werden. Ich dachte, wenn ich die Scripte mit runas ausführe, dann würden gleichzeitig die Laufzeitumgebunden meines Users geladen werden.

Hat dafür jemand eine Erklärung? Ich habe in dem Script, welches ich per runas ausführe auch ein "start explorer" eingebaut um zu schauen, ob das Laufwerk dort auftaucht...
Mitglied: 68030
23.12.2008 um 09:49 Uhr
Hi

Warum mit runas das Script starten runas verwendest Du nur um das Script zb: als Administrator ausführen wenn der User keine Rechte hat????

Bau dein Script anders :

net use h: \\servername\freigabename Passwort / User:domaine\user
Speichere es als zb: mounting.bat

und jetzt schreibe ein zweites script das es ausführt :
runas user:test #

  1. = pfad des scriptes

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: hambuergaer
23.12.2008 um 10:07 Uhr
Hallo #remi#,

das habe ich auch schon versucht, leider mit dem selben Ergebnis Ich finde es komisch, dass es auch nicht funktioniert, wenn ich runas mit dem User starte, mit dem ich ohnehin gerade angemeldet bin (lediglich zum testen).
Bitte warten ..
Mitglied: HubertN
23.12.2008 um 10:50 Uhr
Originalauszug aus der Anleitung von Microsoft:
Da noch keine Benutzerumgebungsvariablen deklariert worden sind, wenn "AutoExNT" beim Systemstart ausgeführt wird müssen Sie mit vollständigen Pfadangaben arbeiten.

da es auch nicht klappt, wenn du angemeldet bist: Was ist denn dir Rückmeldung deines Servers ???


edit: starte ggf. doch mal den Dienst mit den entsprechenden Benutzerdaten. Dann wierd das Script mit diesen Benutzerdatehn ausgeführt und du kannst vielleciht ganz auf die Konstruktion mit runas verzichten.
Bitte warten ..
Mitglied: 68030
23.12.2008 um 11:18 Uhr
runas user:user@domaine.at oder auch ohne domaine script.bat
danach fragt er nach dem passwort kommst du soweit ?

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: hambuergaer
23.12.2008 um 11:29 Uhr
Zitat von 68030:
runas user:user@domaine.at oder auch ohne domaine script.bat
danach fragt er nach dem passwort kommst du soweit ?

Mit freundlichen Grüßen

Ja, so weit komme ich! Das Skript wird auch angeblich anständig ausgeführt.
Bitte warten ..
Mitglied: hambuergaer
23.12.2008 um 11:30 Uhr
Zitat von HubertN:
Originalauszug aus der Anleitung von Microsoft:
Da noch keine Benutzerumgebungsvariablen deklariert worden sind,
wenn "AutoExNT" beim Systemstart ausgeführt wird
müssen Sie mit vollständigen Pfadangaben arbeiten.


da es auch nicht klappt, wenn du angemeldet bist: Was ist denn dir
Rückmeldung deines Servers ???


edit: starte ggf. doch mal den Dienst mit den entsprechenden
Benutzerdaten. Dann wierd das Script mit diesen Benutzerdatehn
ausgeführt und du kannst vielleciht ganz auf die Konstruktion
mit runas verzichten.

Das Skript wird ohne Fehler gestartet...
Bitte warten ..
Mitglied: 68030
23.12.2008 um 12:01 Uhr
Wird das Luafwerk nicht gemountet dann liegt es am dem zweiten batch ! oder?

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: hambuergaer
23.12.2008 um 12:57 Uhr
Zitat von 68030:
Wird das Luafwerk nicht gemountet dann liegt es am dem zweiten batch !
oder?

Mit freundlichen Grüßen


Ne, führe ich Mapping-Batch von Hand aus, dann funktioniert es. Lediglich im Zusammenhang mit runas klappt es nicht.
Bitte warten ..
Mitglied: 68030
23.12.2008 um 14:29 Uhr
wie schaut das run as script aus ? poste es mal hier
danke

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: hambuergaer
23.12.2008 um 15:11 Uhr
Zitat von 68030:
wie schaut das run as script aus ? poste es mal hier
danke

Mit freundlichen Grüßen

runas /user:servername\username C:\WINDOWS\system32\map_drive_g.bat

Der User, der sich hinter user:servername\username verbirgt ist lokaler Admin!!!

map_drive_g.bat sieht wie folgt aus:

net use g: \\servername\freigabename PASSWORT /USER:domäne\User

Habe überall eine PAUSE eingebaut, um zu schauen, ob die Skripte anständig ausgeführt werden. Das scheint der Fall. Bei keinem Skript taucht ein Fehler auf. Führe ich das Mapping-Skript von Hand aus, dann wird das Laufwerk verbunden...
Bitte warten ..
Mitglied: cskcsk
23.12.2008 um 16:50 Uhr
Das mit dem Runas befehl funktioniert nicht. Der übergibt die Informationen nicht.
Ich habe aus diesem Grund das Tool "RunassPC" genommen. Funktioniert genau so wie "Runas"
Hinzu kommt, das das Tool die Benutzerdaten verschlüsselt was Runas nicht macht.

Hoffe konnte helfen

VG csk
Bitte warten ..
Mitglied: 68030
24.12.2008 um 07:42 Uhr
hi

ich würde runas anderst machen und zwar wie folgt:

mit domaine : runas /user:username@domaine c:\windows\system32\map_drive_g.bat
ohne domaine: runas /user:username c:\windows\system32\map_drive_g.bat
Mit freundlichen Grüßen

#tremi#
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Router & Routing
Transparenter Proxy funktioniert nicht? (1)

Frage von mrserious73 zum Thema Router & Routing ...

Linux
LTSP: PXE Boot funktioniert nicht (23)

Frage von Fenris14 zum Thema Linux ...

Virtualisierung
Drucker aus einer VM heraus funktioniert nicht (5)

Frage von NCCTech zum Thema Virtualisierung ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (22)

Frage von patz223 zum Thema Windows Userverwaltung ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (19)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...