Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Laufzeitfehler 429 Vermutlich ein VBA Fehler?!

Frage Entwicklung VB for Applications

Mitglied: cyberdevil0815

cyberdevil0815 (Level 1) - Jetzt verbinden

02.11.2011 um 15:15 Uhr, 14454 Aufrufe, 5 Kommentare

Excel 2007 inkl. aktuellen Servicepack und dem Reportingstool JetReport sich nicht ausführen

Hallo zusammen,

ich hoffe es handelt sich um ein VBA Fehler.

Ich erhalte bei Einbinden eines Add-Ins (Dateiendung *.xlam) 4 mal die Fehlermedlung "Laufzeitfehler 429".

Das Tool lief bis Montag auf einem Terminalserver reibungslos. Es wurden keine Updates oder sonstiges gefahren (automatische Updates deaktiviert, User haben keine Installrechte etc.)

Wie bekomme ich die Fehler wieder weg. Mehr oder weniger vermute ich einfach mal, dass es sich um einen Registryfehler handelt. Wenn hier ein Schlüssel fehlt, wie kann ich diesen wieder herstellen?

Ich bin absolut ratlos, wie das Überhaupt passieren konnte.
Mitglied: Pago159
02.11.2011 um 15:34 Uhr
Hallo cyberdevil0815,

  • hast du mal in die Ereignisanzeige geschaut?
  • Wenn ja, was ist dort vermerkt?
  • Wie wirkt sich der Laufzeitfehler aus?
  • Welches OS hast du?
  • Welche Add-Ons sind installiert?
  • .........

Deine Angaben sind doch recht dürftig, wenn ich in einer Werkstatt anrufe und denen sage, mein Auto stottert plötzlich aber ich habe nix gemacht,
meinst du die können mir etwas sagen, wenn ich denen keine Weiteren Inf o´s gebe?

Lg Grapper
Bitte warten ..
Mitglied: NetWolf
02.11.2011 um 15:35 Uhr
Moin Moin,

ja, die Fehlermeldung wird im VBA generiert. Der Grund ist ein anderer.

Um dir helfen zu können benötigen wir hier mehr Informationen:
Welches Betriebssystem? Servicepack?
Welches Office? Servicepack?
Welches Office - Programm verursacht den Fehler?
Welche Office - Addins sind installiert?
Wie lautet die Fehlermeldung ganz genau?
Welches Anti-Virus-Programm nutzt du? Regelmäßige Updates sind aktiviert?

Prüfen -> IE Einstellungen hinsichtlich Active-X
Prüfen -> Anti-Virus-Programm Verhalten bei Active-X

Lösung -> das Addon neu installieren/registrieren

Grüße aus Rostock
Wolfgang
(Netwolf)
Bitte warten ..
Mitglied: cyberdevil0815
02.11.2011 um 16:14 Uhr
Hallo NetWolf,

sorry ist mir im Nachhinein erst aufgefallen, das mein Problem sehr sehr vage beschrieben wurde. Sorry musste gerade mal eben schnell gehen.


Welches Betriebssystem? Servicepack?

Windows 2003 Server Standard, 32 Bit, Service Pack 2 (Terminalserver)

Welches Office? Servicepack?

Office 2007, Service Pack 3

Welches Office - Programm verursacht den Fehler?

MS Excel

Welche Office - Addins sind installiert?

KEINE Bis auf Standad Add-Ons, welche funktionieren.
Zusatz Add-On ist das Tool JetReport, eines Drittanbieters (www.jetreport.com)

Wie lautet die Fehlermeldung ganz genau?

Laufzeittfehler ´429´
Objekterstellung durch ActiveX - Komponente nicht möglich

Welches Anti-Virus-Programm nutzt du? Regelmäßige Updates sind aktiviert?

Clam Server Antivirus inkl. regelmässiger manueller Updates. Letzte Woche Freitag Update installiert, da lief alles noch. Montag kam der Ausfall.

Prüfen -> IE Einstellungen hinsichtlich Active-X

IE habe ich erst einmal Alles erlaubt

Prüfen -> Anti-Virus-Programm Verhalten bei Active-X

Läuft sauber durch, ohne Fehlermeldungen, jedoch selber Excel Fehler.

Lösung -> das Addon neu installieren/registrieren

Office komplett deinstalliert, neu installiert, Add-On komplett deinstalliert, neu installiert, selber Fehler.
Bitte warten ..
Mitglied: NetWolf
02.11.2011 um 17:09 Uhr
Moin Moin,

das schreibt der Hersteller zum Problem: http://support.microsoft.com/kb/828550/de
Thema Deinstallieren von Office: verwende das Tool von M$, und starte dann den Rechner neu!

Das hier bitte auch mal für Office 2007 durchführen: http://www.wintotal.de/tipparchiv/?id=1007

Es kann ja auch einfach sein, dass es einen Fehler in der .XLAM Datei gibt, die diesen Fehler verursacht. Oder dass die Installation von Jet 4.0 nicht sauber gelaufen ist und/oder von einem anderen (Datenbank-)Programm verändert wurde.

Auffällig ist der zeitliche Zusammenhang mit dem Update des Anti-Virus-Programms.

Grüße aus Rostock
Wolfgang
(Netwolf)
Bitte warten ..
Mitglied: cyberdevil0815
11.11.2011 um 08:14 Uhr
Guten morgen zusammen,

langsam kann ich mein geschildertes Problem eingrenzen bzw. hab eine Ahnung wo das herkommen kann. Ein User mit Co-Admin Rechten konnte vom Server den Deinstaller seitens JetReports nicht mehr verwenden, und hat den Pfad auf der HDD als auch in der Registry manual gelöscht, hierbei hat er nach "Jet" die Registry durchforstet und hat offensichtlich die Jet4.0 Einträge, welche für Access und Co dienlich sind gelöscht. Ich konnte aber schon ein wenig Schadensbegrenzung betreiben, zumal der User soeben von den Rechten degradiert wurde *grrrrr

Derzeit besteht noch folgendes Problem.

Software Office 2007 inkl. Service Packs deinstalliert
Software JetReports deinstalliert

Reboot durchgeführt

Als lokaler Admin:
Office 2007 inkl. aktuellen SP neuinstalliert
JetReports neu installiert
MDAC 2.8 neuinstalliert
Reboot

Nun kann ich als Lokaler Admin das Tool in Excel verwenden und das ganze auch noch FEHLERFREI

ABER:

Domänenadmin als auch die Terminaluser haben nach wie vor das Problem, ebenfalls wird die installierte Software JetReport in der Programmstartleiste (Windows Logo ==> Programme ==> JetReports) nu als lokaler Admin angezeigt, die weiteren Benutzer als auch Domänenadmin sehen den EIntrag nicht.

Für mich liegt nur ein Rechteproblem augenscheinlich vor (bei der Install von JetReports kann auch die Option gewählt werden, alle Benutzer oder nur der aktuelle, hier habe ich natürlich alle User ausgewählt). Der Übertrag in die Startleiste findet nicht statt, sowie das registrieren des JetModuls scheinbar auch nicht.

Jemand noch eine Idee?!?!?

By the way, hier mal ein Screenshot: beim Starten von Excel
www.project-ae.de/downloads/ms_excel_jetreport_addin.JPG

Screenshot wenn ich die Meldung wegklicke:
www.project-ae.de/downloads/ms_excel_jetreport_addin_nach wegklicken.JPG


Wenn ich die Fehlermeldung mittels Beenden wegklicke (ca. 10 x muss ich das tun), fliegt meine komplette Ribbon Leiste weg.

Ansicht des Add-Ins:
www.project-ae.de/downloads/ms_excel_jetreport_addin_detail.JPG
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
VB for Applications
SNMP Abfrage in EXCEL über VBA (5)

Frage von SebastianL zum Thema VB for Applications ...

Microsoft Office
gelöst VBA: Dateiinhalte in Abhängigkeit des Dateinamens importieren (4)

Frage von Booster07 zum Thema Microsoft Office ...

Drucker und Scanner
Laserjet 3600N Fehler PCL Error (1)

Frage von grillinator95 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
TK-Netze & Geräte
gelöst Telefonanlage gesucht (39)

Frage von Xaero1982 zum Thema TK-Netze & Geräte ...

Windows Netzwerk
Anmeldung an Domäne schlägt oft fehlt (Fehlermeldung: falsches Passwort) (24)

Frage von harald.schmidt zum Thema Windows Netzwerk ...

Exchange Server
gelöst Wie freigegebenes Postfach immer als primäre Sendeadresse verwenden? (18)

Frage von Flinxit zum Thema Exchange Server ...

Microsoft Office
Outlook 2016 - Keine Mails sichtbar (nach Suche schon) (17)

Frage von Hirschix3 zum Thema Microsoft Office ...