Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Layer 2 oder Layer 3 Switch?

Frage Netzwerke

Mitglied: edvmaedchenfueralles

edvmaedchenfueralles (Level 1) - Jetzt verbinden

15.06.2011, aktualisiert 18.10.2012, 25006 Aufrufe, 23 Kommentare

Hallo zusammen!
Wie kann ich im nachhinein feststellen, ob unsere bestehenden Switch im Unternehmen Layer 2 - oder Layer 3 Switch sind?
Bei einem Layer 3 - Switch müsste irgendwo ein Verweis auf die IP-Adresse des angeschlossenen Gerätes sein, oder?

Danke im Voraus!

Mit freundlichen Grüßen
Mitglied: kopie0123
15.06.2011 um 11:05 Uhr
Hey,

ein Layer 2 Switch arbeitet transparent, du k annst ihn also nicht ansprechen.
Ein layer 3 Switch hat eine Ip Adresse und kann routen. Wobei ich den Begriff Layer 3 Switch furchtbar finde Für mich ist es ein Router

Gruß
Bitte warten ..
Mitglied: Edi.Pfisterer
15.06.2011 um 11:32 Uhr
Hallo!
Möchte nicht der "Besserwisser" sein, aber StingerMAC hat nicht recht...

Es gibt auch Layer 2 Switches, die managable sind, dh, die über eine IP-Adresse ansprechbar sind (und in Wahrheit sind das die Meisten am Markt befindlichen...)


Es hilft Dir nur ein Blick in das Manual!
Womit StingerMAC Recht hat: wenn er eine Routing-Funktionalität aufweist, dann handelt es sich um einen Layer-3-Switch

lg
Edi
Bitte warten ..
Mitglied: kopie0123
15.06.2011 um 11:37 Uhr
Hey,

dann ist es kein reines Layer 2 Switch oder zumindest eine Managementkomponente auf layer 3?

Auf Layer 2 sind keine IP Adressen definiert, somit kann das Switch hier nach keine Aussgaben treffen über Priorisierung oder VLN oder ähnliches.

Gruß
Bitte warten ..
Mitglied: edvmaedchenfueralles
15.06.2011 um 11:42 Uhr
Hallo Edi!
Bin vor einiger Zeit über deine Homepage www.schulnetz.info gestolpert! Ein dickes "Gefällt mir" an dieser Stelle (falls du der richtige bist)! Hat mir mein Thema VLAN sehr geholfen!

Wenn es ein Layer 3 Switch ist, müsste bei den Ports nicht nur die MAC-Adresse sondern auch die IP-Adresse des angeschlossenen Geräts sichtbar sein, oder? Ein Layer 3 Switch arbeitet ja mit IP-Adressen!

lg
Bitte warten ..
Mitglied: Lochkartenstanzer
15.06.2011 um 11:59 Uhr
Zitat von edvmaedchenfueralles:
Ein Layer 3 Switch arbeitet ja mit IP-Adressen!

Nicht notwendigerweise. Im Prinzip können alle möglichen Layer-3-Protokolle Anwendung finden.

Theoretisch müßte der switch selbst nicht mal managebar sein oder selbst eine IP-Adresse haben, sondern könnte anhand der Layer-3-Protokollinformation im Frame das switching durchführen. Praktisch kann aber jeder Layer-3-Switch mindestens IP, wenn nicht noch mehr.

Merke: Es gibt nicht nur IP auf dem Äther.
Bitte warten ..
Mitglied: brammer
15.06.2011 um 12:02 Uhr
Hallo,

@StingerMAC
das ist so nicht ganz richtig!
Layer2 switche können das sehr wohl! Sieh dir mal die Cisco 2960 an!
Das ist ein reiner Layer2 Switch der sowohl eine Management IP haben kann als auch VLAN fähig ist.


Der "normale" Unterschied zwischen Layer2 und Layer3 Switche ist meist das die Layer3 Switche eine gewisse Routing Fähigkeit haben.

brammer
Bitte warten ..
Mitglied: Edi.Pfisterer
15.06.2011 um 14:51 Uhr
Hallo edvmaechenfueralles (verschärfter Nick

Bin vor einiger Zeit über deine Homepage www.schulnetz.info gestolpert! Ein dickes "Gefällt mir" an dieser Stelle (falls du der richtige bist)!
Ja, der bin ich!
Noch dickeres "Gefällt mir" für Dein Kompliment!!!!

brammer hat recht(er), es gibt eine Unzahl von Layer-2-Switches, die über ein Interface (GUI u/o CLI) gemanaget werden können...
(die meisten von Netgear zum Beispiel, aber auch 3Com, HP, etc etc)

Da viele Layer2-Switches Zusatzfunktionen anbieten wie VLAN-fähigkeit (Nicht gleich Routing zwischen VLANS !!!), Spanning Tree, etc müssen sie ja über eine Möglichkeit verfügen, diese Funktionen zu konfigurieren bzw. zu enablen...

Sag uns einfach, welche(s) Modell(e) Du bei dir hast, dann können wir Dir (relativ) sicher sagen, was Deine Komponenten können und was nicht...

lg
Danke nochmals
Edi
Bitte warten ..
Mitglied: aqui
15.06.2011, aktualisiert 18.10.2012
Layer 3 Switches haben pro VLAN (oder auch pro Port) eine IP Adresse um zwischen den VLANs routen zu können. Kollege Stinger... hat also nicht ganz unrecht mit dem "Router" allerdings muss man immer sagen das der Switch nebenebei auch noch L2 Switching macht was ein reiner Router nicht kann. Insofern ist die Bezeichnung "L3 Switch" schon gerechtfertigt.
Ansonsten findest du weitere Tutorials zu dem Thema hier:
http://www.heise.de/netze/VLAN-Virtuelles-LAN--/artikel/77832
bzw. für die Praxis
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
http://www.administrator.de/wissen/vlan-routing-%c3%bcber-802.1q-trunk- ...
Normalerweise geht jeder halbwegs normal intelligente Netzwerk Admin zur Klärung deiner Frage auf die Webseiten des Switchherstellers, gibt die Modellnummer ein und liest sich das Datenblatt dazu durch. Aber wir können das natürlich auch gerne für dich hier machen wie oben ja schon angeboten...
Wenn dort nix von L3 oder Routing steht ist es ein dummer L2 Switch ohne Routing Funktion.
Bitte warten ..
Mitglied: edvmaedchenfueralles
16.06.2011 um 14:26 Uhr
Es geht darum, das ich ein (oder mehrere) VLAN einrichten möchte (erste Gehversuche mit VLAN...)!

Folgende Geräte sind vor Ort:
3com Superstack 3 3824
3com Superstack 3 3812
3com Superstack II 3300
Enterasys B3G124-48
3com Superstack 3 4900 SX

VLAN können alle (es gibt zumindest bei jedem Switch einen Eintrag "VLAN"). Ist es sinnvoll (oder überhaupt möglich) ein VLAN über Switche verschiedener Hersteller und Typen zu realisieren?
Zum routen müsste halt ein eigener Router her, da anscheinend keiner der Switche auf Layer 3 arbeitet.

Wie wär das dann eigentlich wenn ich z.B. 5 VLANs einrichten möchte? Dann brauch ich 5 Router, oder? Edit: OK, ein Router mit 5 Netzwerkkarten wird's wohl auch tun!

Danke!

Mit freundlichen Grüßen Bernhard
Bitte warten ..
Mitglied: brammer
16.06.2011 um 15:29 Uhr
Hallo,

nein wenn du zwischen VLAN's routen willst brauchst du nur einen Router!

Außerdem hast du mit dem 3com Superstack 3 4900 SX ein Layer 3 fähigen und damit Routing fähigen Switch (wenn ich die Spezifikation auf die schnelle richtig gelesen habe).
Zumindest mit RIPv2, als Routing Protokoll, ist das möglich.

brammer
Bitte warten ..
Mitglied: aqui
16.06.2011, aktualisiert 18.10.2012
Die 3 Com Superstack III 3800er Serie sind reine Layer 2 Switches also kein Routing:
http://www.pco2.com/v/vspfiles/downloadables/switch%203800%20family.pdf

Desgleichen für den Superstack II 3300 Serie auch kein Routing:
http://igor.chudov.com/manuals/3Com-Superstack-Network-Switch.pdf

Entensys B3 ist ein routingfähiger L3 Switch !
http://www.enterasys.com/company/literature/b3-ds.pdf

Superstack III 4900 ist ebenfalls ein routingfähiger L3 Switch !
http://www.soft-und-hardware.de/docu_products/13535.pdf

Also mindestens mit 2 deiner vorhandene Switches dem Entensys und dem 3Com 4900 kannst du problemlos zwischen deinen 5 VLANs routen und benötigst nix externes !
Um deine Frage aufzugreifen: Für 5 VLANs bräuchte man natürlich keinen 5 Router, das ist natürlich Blödsinn.
Wie man VLANs extern routet kannst du hier genau nachlesen:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Dort hast du auch ein paar Switchkonfigs als Beispiel. Ein externer Router mit 5 Interfaces wäre z.B. ein Mikrotik 750 für 30 Euronen der sowas kann.
Vergiss das aber ist ja unwichtig für dich denn 2 deiner Switches sind ja L3 Switches mit denen du die VLANs ganz einfach koppeln kannst ohne den ganzen externen Schnickschnack !
Ein klassisches L3 Switchnetz sieht z.B. dazu so aus (Core = L3 Routing Switch, Access = L2 Switch):

cbd02541153fdaf4376026b03fd512a5-switchnetz - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: edvmaedchenfueralles
16.06.2011 um 15:35 Uhr
DANKE!
Das hab ich wohl übersehen!
Ist es ein Problem wenn ich Hardware unterschiedlicher Hersteller verwende?
Bitte warten ..
Mitglied: brammer
16.06.2011 um 15:41 Uhr
Hallo,

bei den 3com Geräten untereinander gibt es keine Probleme.
Der Enterasys kann auch mit allem Umgehen.
Ob allerdings die 3com billig teile in allen Punkten Standardkonform sind, das würde ich nicht shcriftlich garantieren.
Es gibt für diese Kommunikation Standards an diese sich alle Hersteller mehr oder weniger halten.

brammer
Bitte warten ..
Mitglied: aqui
16.06.2011 um 16:19 Uhr
@edvmaedchenfueralles
Ist es ein Problem wenn du Benzin von Aral oder Esso oder Jet tankst ?? Die Antwort kannst du dir selber geben, oder ??
IP ist ein weltweiter Standard und ob der durch Entensys, 3Com, oder Taiwan MischiMuschi Switches fliesst spielt kein Rollo !!
Sollte man als edvmaedchenfueralles eigentlich wissen ?!
Das wovon der Kollege brammer etwas Bauchschmerzen hat ist das Handling bei tagged VLANs mit dem default VLAN 1. Der IEEE 802.1q Standard gibt vor das es immer untagged mit an tagged Uplinks liegt. 3 Com macht es da in der Tat etwas anders und überträgt dieses VLAN nicht untagged an Trunks.
Es gibt aber im Kommandoset ein Kommando was das auch wieder einschaltet....kannst also ganz beruhigt sein...ist eh nur Layer 2 !
Für dein Routing zwischen deinen 5 VLANs ist das so oder so völlig irrelevant.
Bitte warten ..
Mitglied: edvmaedchenfueralles
17.06.2011 um 09:01 Uhr
OK, DANKE an alle für die Hilfe!
Werde diesen Thread mal schließen und zum Testen beginnen...
Bitte warten ..
Mitglied: edvmaedchenfueralles
20.06.2011 um 11:04 Uhr
Hallo nochmal!
Bin jetzt gerade am Testen meines VLANs!

Hab mir den 3com Switch 3300 vorgenommen und 2 Ports der VLAN-ID 101 und 2 Ports der VLAN-ID 102 zugewiesen. Das funktioniert soweit auch!

Wenn ich jetzt einen weiteren Switch dazunehme (Enterasys) und ein weiteres Gerät ins VLAN 102 einbinden will (das auf den enterasys hängen soll) dann erstelle ich auf dem enterasys ein VLAN mit der selben VLAN ID wie vom 3com Switch (VLAN-ID 102) und weise diese VLAN-ID dem entsprechenden Port am Enterasys zu! Weiters verbinde ich den 3com Switch und den Enterasys Switch auf je einem Port der Switches das auf "tagged" gestellt wurde. Ist das so korrekt?
Das Gerät im VLAN 102 vom Enterasys Switch kann von den VLAN 102 Geräten des 3com Switch nämlich nicht erreicht werden! Was mach ich da falsch?

Danke im Voraus!
Bitte warten ..
Mitglied: aqui
20.06.2011 um 11:38 Uhr
Ja, richtig ! Du suchst dir einen Port aus an dem Du die beiden Switches verbinden willst.
Diesen Port setzt du als tagged Port in den entsprechenden VLANs, sowohl im 3Com als auch im Entensys. Die VLAN IDs (Nummern) müssen natürlich identisch sein auf beiden Switches für diese tagged VLANs am Port !
Dann verbindest du beide Switches mit genau diesem Port und gut ist.
Alle die VLANs die dann tagged an diesem Port übertragen werden findest du auf beiden Switches wieder bzw. kommen dort auch wieder raus.
Hier mal ein Beispiel für eine simple Cisco oder HP Syntax der Konfig. (Ist mehr oder weniger gleich bei beiden). Beide Switches sind über Port 1 tagged verbunden und haben jeweils 1 Endgeräte Port in VLAN 101 und VLAN 102 (Jeweils Port 10 und 11).
Beide VLANs sind so transparent über den tagged Link auf beiden Switches verfügbar.
Anhand der Konfig Logik erschliesst sich dir das dann sofort wie es funktioniert !
Prinzipschaubild:
29de1e1b429e703657deeb60bd60541e - Klicke auf das Bild, um es zu vergrößern

Cisco Config
!
interface FastEthernet0/1
description Tagged Verbindung zw. den. Switches
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface FastEthernet0/10
description Enduser Ports in VLAN 101
switchport access vlan 101
spanning-tree portfast
!
interface FastEthernet0/11
description Enduser Ports in VLAN 102
switchport access vlan 102
spanning-tree portfast
!

HP Config
interface 1
name "Tagged Verbindung zw. den. Switches"
exit

vlan 101
name "VLAN 101"
untagged 10
tagged 1
exit
vlan 102
name "VLAN 102"
untagged 11
tagged 1
exit

Solch einen Konfig funktioniert zwischen allen Switchen einwandfrei. Das ist ein simples und banales Standardszenario im VLAN Umfeld !
Bitte warten ..
Mitglied: edvmaedchenfueralles
21.06.2011 um 07:55 Uhr
Es ist mir gelungen auf beiden Switch (3com 3300 und enterasys B3G124) separate VLANs einzurichten.
Switchübergreifend hab ich allerdings noch meine Probleme!

Kann mir jemand sagen, wie ich hier Bilder hochladen kann, dann könnte ich mein Problem verdeutlichen...
Bitte warten ..
Mitglied: brammer
21.06.2011 um 08:59 Uhr
Hallo,

steht alles in den FAQ: Grafiken / Bilder

brammer
Bitte warten ..
Mitglied: edvmaedchenfueralles
21.06.2011 um 10:29 Uhr
OK, so sollte fürs erste das Endergebnis aussehen:
ba8d53b7ac475f4c80931625363ef73b - Klicke auf das Bild, um es zu vergrößern

Die Ports mit denen die beiden Switch verbunden sind, sind das Port 19 auf dem 3COM und das Port 25 auf dem enterasys!

Wie gesagt, die VLANs funktionieren separat. Nur Switch übergreifend (siehe Bild 1) will es einfach nicht klappen! Sobald ich auf dem enterasys die Einstellung für das Port 25 auf "Tagged Frames" stelle ist der enterasys vom 3com aus nicht mehr erreichbar!

Hier die Einstellungen:

3COM:
c420380717802e25d38d9bc0f60d6b48 - Klicke auf das Bild, um es zu vergrößern

a5d910b7138843d02174426435f251f3 - Klicke auf das Bild, um es zu vergrößern


Enterasys:

989dd0acf7aa792cfe621b0b3e06aeaf - Klicke auf das Bild, um es zu vergrößern

39a5a1a5d8546973a4720c54294947c7 - Klicke auf das Bild, um es zu vergrößern

Auf dem 3COM sind die VLAN 2 - Ports: 7 und 8 und auf dem enterasys 17 und 18!


Danke im Voraus!
Bitte warten ..
Mitglied: brammer
21.06.2011 um 13:25 Uhr
Hallo,

auf den Bildern des Enterasys ist zu sehen das de Ports im VLAN 102 sind.
Bei den Bildern des 3com kann ich das nicht erkennen.
Die VLAN's müssen identisch heißen, d.h. die VLAN ID muss dieselbe sein.



brammer
Bitte warten ..
Mitglied: edvmaedchenfueralles
21.06.2011 um 14:30 Uhr
Juhu, die Lösung ist gefunden!
Einstellungen auf dem 3COM Switch Port 19: siehe 1. 3COM Bild des vorherigen Posts (sonst nichts)
Einstellung auf dem Enterasys Switch: siehe 1. Enterasys-Bild des vorherigen Posts: oben das entsprechende VLAN auswählen -> Port: "ge.1.25"; Status: "Add"; Egress: "Egress"

That's it!



Danke an alle für die Hilfe!
Bitte warten ..
Mitglied: aqui
21.06.2011 um 16:56 Uhr
Alles wird gut !
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Router & Routing
Verständisfrage Layer 3 Switch - Firewall - VLAN (4)

Frage von praxxzz zum Thema Router & Routing ...

Router & Routing
gelöst Layer 3 Switch Routing nach Firewall (5)

Frage von gansa28 zum Thema Router & Routing ...

Hyper-V
Windows Server 2012 R2 NIC Teaming mit Lancom Switch

Frage von onkel87 zum Thema Hyper-V ...

Switche und Hubs
gelöst Trunk für 2xCisco Switch. Wo liegt der Fehler? (43)

Frage von JayyyH zum Thema Switche und Hubs ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (19)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (19)

Frage von patz223 zum Thema Windows Userverwaltung ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (15)

Link von Penny.Cilin zum Thema Viren und Trojaner ...