Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Linux Bootmenu Menu.lst wohl falsch

Frage Linux RedHat, CentOS, Fedora

Mitglied: winlin

winlin (Level 2) - Jetzt verbinden

12.04.2013 um 16:22 Uhr, 2035 Aufrufe, 2 Kommentare

Hallo Leute,

habe ein funktionierendes Dualbootsystem welches ich von remote administriere. Da ich ja nicht vor Ort bin habe ich mir überlegt das ich das Bootverhalten so einstelle wie ich es gerade benötige. Also ob nun Linux bootet oder Windows. Wenn gerade Linux gebootet ist und ich nun möchte das das System unter Windows bootet bearbeite ich einfach die menu.lst und setze als default den Wert 2 ein:
01.
# grub.conf generated by anaconda 
02.
03.
# Note that you do not have to rerun grub after making changes to this file 
04.
# NOTICE:  You have a /boot partition.  This means that 
05.
#          all kernel and initrd paths are relative to /boot/, eg. 
06.
#          root (hd0,0) 
07.
#          kernel /vmlinuz-version ro root=/dev/vgroot/root 
08.
#          initrd /initrd-version.img 
09.
#boot=/dev/sdb 
10.
default=0 
11.
timeout=30 
12.
splashimage=(hd0,0)/grub/splash.xpm.gz 
13.
#hiddenmenu 
14.
title Red Hat Enterprise Linux Client (2.6.18-194.26.1.el5) 
15.
	root (hd0,0) 
16.
	kernel /vmlinuz-2.6.18-194.26.1.el5 ro root=/dev/vgroot/root    
17.
	initrd /initrd-2.6.18-194.26.1.el5.img 
18.
title Red Hat Enterprise Linux Client (2.6.18-194.26.1.el5debug) 
19.
	root (hd0,0) 
20.
	kernel /vmlinuz-2.6.18-194.26.1.el5debug ro root=/dev/vgroot/root    
21.
	initrd /initrd-2.6.18-194.26.1.el5debug.img 
22.
title Windows7 
23.
    rootnoverify (hd0,2) 
24.
    chainloader +1 
25.
    makeactive
Wenn ich dann unter Windows im System bin dann greife ich auf die Bootplatte mittels des Tools ext2fds zu damit ich die menu.lst bearbeiten kann und wieder unter Linux booten kann. Nur jetzt habe ich das Problem das er permanent unter Windows bootet auch wenn ich den default Wert wieder auf 1 setze. WARUM???
Mitglied: 64748
12.04.2013 um 20:02 Uhr
Hallo,

es könnte daran liegen, dass Windows andere Dateiformate und z.B. auch andere Zeilenumbrüche verwendet als Linux. Leider hab ich von Grub keine Ahnung, ich weiß also nicht, ob man hinter die 2, also am Ende der Zeile noch was anhängen darf. Ansonsten würde ich dort mal einen Kommentar hinter setzen oder noch einige Leerzeichen hinter die 2 setzen.

Markus
Bitte warten ..
Mitglied: winlin
15.04.2013 um 08:11 Uhr
Nein es lag wohl daran das die menu.lst ja auf die grub.conf verweist. Nur war das Problem das ich unter Windows dich ext3 Partition zwar mounten konnte und auch schreiben - aber das Problem ist das wenn ich in der menu.lst was ändere die Änderung nihct in der grub.conf durchgeführt wird...hab das dann direkt in der grub.conf geändert.
Bitte warten ..
Ähnliche Inhalte
Microsoft
Bootmenü über Teamviewer?
Frage von icke68746Microsoft3 Kommentare

Hallo alle Miteinander! Ich warte einen Rechner über Teamviewer, auf dem zwei Betriebssysteme (Ubuntu und Windows 7) installiert sind. ...

Ubuntu
Grub2 - Bootmenu ausblenden
gelöst Frage von tirenietsUbuntu5 Kommentare

Grüß euch, kurz zur Infrastruktur: 1x Ubuntu Server(Version 14.04.1 LTS) Grub2-Version: 2.02~beta2-9ubuntu1 Was ist das Problem: Wir haben auf ...

Hardware
Bootmenü mit USB-Tastatur?
gelöst Frage von Leogal0010Hardware1 Kommentar

Hey, Administratoren! Ich habe ein problem mit meinem (etwas älterem) PC. Und zwar habe ich mir eine neue Tastatur ...

Windows Installation
booten von USBstick mit NANO Server - Bootmenue (GPT?) überschrieben
gelöst Frage von mukknmohreWindows Installation11 Kommentare

hi ich wollte den nano server ausprobieren - ich habe mittels "nano server image builder" tool ( ) einen ...

Neue Wissensbeiträge
Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 10 StundenViren und Trojaner1 Kommentar

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 13 StundenRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 3 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Heiß diskutierte Inhalte
Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell12 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Vmware
DOS 6.22 in VMWare mit CD-ROM
gelöst Frage von hesperVmware10 Kommentare

Hallo zusammen! Ich hab ein saublödes Problem. Es ist eine VMWare mit DOS 6.22 zu erstellen auf dem ein ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Cloud-Dienste
PIM als SaaS Nutzungsgebühr
Frage von vanTastCloud-Dienste8 Kommentare

Moin, wir haben uns ein PIM (Product Information Management) nach unseren Ansprüchen für viel Geld als SaaS-Lösung bauen lassen. ...