Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Linux Server mit 2 NIC´s in zwei Netzen, antwortet nur auf einem Netz

Frage Netzwerke Router & Routing

Mitglied: mike-berlin

mike-berlin (Level 1) - Jetzt verbinden

07.10.2004, aktualisiert 08.10.2004, 6437 Aufrufe, 17 Kommentare

Hallo "Kollegen",

folgendes Problem.
Wir haben einen Server konfiguriert (Linux) welcher mit zwei NIC's in zwei verschiedenen Subnetzen hängt (192.168.1.x sowie 192.168.200.x).
Versucht jemand aus dem Netz 192.168.1.x den Server auf der Ip 192.168.1.168) zu erreichen kommt eine Antwort. Ein Ping auf die Server IP 192.168.200.168 (zweitze NIC im zweiten Subnetz 192.168.200.x) aus dem Netz 192.168.1.x geht nicht., obwohl sonst sämtliche Geräte im Netz 192.168.200.x erreicht werden können.
Genaus umgekehrt. Ein Zugriff aus dem Netz 192.168.200.x auf die Server IP 192.168.200.168 klappt. Ein Zugriff aus dem Net 192.168.1.x auf die Server IP 192.168.200.168 klappt nicht, obwohl sonst auch alle Gerät vom Netz 192.168.200.x in dem Netz 192.168.1.x erreichbar sind.

Ganz offenbar ist dem Server nicht ganz klar auf welcher der beiden karten er Antworten soll.
Wie kann ich ihm klar machen das Anfragen aus dem Netz 192.169.1.x auf die Server IP 192.168.1.168 auch über diese Karte und bei Anfragen aus dem Netz 192.168.1.x auf die Server NIC 192.168.200.168 Antworten über diese Karte (IP) erfolgen sollen ?

Danke im voraus für jede Unterstützung !

Grüße aus Berlin,
Mike
Mitglied: Atti58
08.10.2004 um 09:32 Uhr
Nur so nebenbei, Deine Netze sind keine Subnetze sondern eigenständige Netze mit der Maske 255.255.255.0.

Zu Deinem Problem: Ich nehme an, Du musst auf Deinem Server statische Rouene eintragen, damit er weiß, dass er bei Anfragen an das 192.168.200.0 Netz das Interface 192.168.1.16 benutzen und bei Anfragen an 192.168.1.0 das Interface 192.168.200.1 verwenden soll. Dazu musst Du mit "route add" arbeiten, sieh Dir am besten die man-Pages an,

Gruß

Atti
Bitte warten ..
Mitglied: das-omen
08.10.2004 um 09:38 Uhr
Hi!

Habe ich das jetzt richtig verstanden. Der Server steht in beiden Teinetzen mit jeweils einer Karte. Dann müsste er auch normalerweise in beiden Netzen antworten können ohne dass du Routen eintragen musst weil er kennt ja beide Teilnetze schon. Kontrolliere mal genau die Einstellungen für die eine Netzwerkkarte. Da sie aus ihren eignen Teilnetz keinen Pong sendet könnte dort irgend was falsch konfiguriert sein. Liegt vieleicht ein Filter oder einer Firewall auf der KArte?


Tschau

Das Omen
Bitte warten ..
Mitglied: Atti58
08.10.2004 um 09:45 Uhr
@ Omen

... es sind keine Teilnetze! Und somit sollte das jeweilige Standardgateway auch nicht auf die andere Karte zeigen sondern auf die eigene.

@ Mike

Was gibt denn der Befehl "route" aus, vielleicht kabnnst Du das mal posten.

Gruß

Atti.
Bitte warten ..
Mitglied: das-omen
08.10.2004 um 09:53 Uhr
Hi!

@ atti

Sondern was für Netze? Der Server steht in beiden Netzen physisch mit einer Karte drin also sollte er beide Netze kennen. Wenn er keinen Pong auf der Karte zurücksenden die im Teilnetz steht dann hat es nichts mit Routen zu tun.


Tschau

Das Omen
Bitte warten ..
Mitglied: mike-berlin
08.10.2004 um 09:54 Uhr
Hallo "Kollegen",

erstmal danke für die prompte Unterstützung.

die Routingtabelle sieht wie folgt aus:


linux1:~# route
Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
localnet 192.168.1.251 255.255.255.0 UG 0 0 0 eth0
localnet * 255.255.255.0 U 0 0 0 eth0
192.168.200.0 * 255.255.255.0 U 0 0 0 eth1
default 192.168.1.251 0.0.0.0 UG 0 0 0 eth0


eth0 hängt am Netz 192.168.1.x
eth1 am Netz 192.168.200.x
Bitte warten ..
Mitglied: das-omen
08.10.2004 um 09:56 Uhr
Hi!

Sorry verlesen! Hast du überhaut routing aktiviert?


Tschau

Das Omen
Bitte warten ..
Mitglied: Atti58
08.10.2004 um 09:58 Uhr
Worin besteht denn eigentlich Dein Problem, es kann doch nicht sein, dass es "nur" die fehlende Antwort der "entfernten" Netzwerkkarte des Servers ist? Sollen denn die User aus Netz A die PC's in Netz B nicht sehen (und umgekehrt)?

Gruß

Atti
Bitte warten ..
Mitglied: mike-berlin
08.10.2004 um 10:04 Uhr
Vielleicht noch eine Info dazu.

Für alle Geräte welche im Netz 192.168.1.x hängen ist das Standardtgateway die 192.168.1.251 (Layer3 Switch). Dieser arbeitet auch als Standardgateway für alle Geräte im Netz 192.168.200.x unter der Adresse 192.168.200.1.
Generell laufen also alle Netze auf diesem Switch auf. Eine Anfrage aus dem Netz 192.168.1.x an den Server und die karte eth0 (192.168.1.168) läuft über die 192.168.1.251 an die eth0 (an dieser Karte ist ja auch das Standardgateway 192.168.1.251 eingetragen).
Eine Anfrage aus dem Netz 192.168.1.x an den Server und die karte eth1 (192.168.200. 168) läuft auch über 192.168.1.251 und dann an die 192.168.200.168

Grüße,
Mike
Bitte warten ..
Mitglied: das-omen
08.10.2004 um 10:08 Uhr
Hi!

Hast du auf dem Server routing aktiviert?


Tschau

Das Omen
Bitte warten ..
Mitglied: mike-berlin
08.10.2004 um 10:11 Uhr
also das routing erfolgt direkt über den Layer3 switch an dem die beiden netze hängen.
sehen darf auch jeder alles. das klappt auch. alle geräte in allen netzen können alles anpingen
das problem ist eben nur das der server mit den zwei nic's nicht so antwortet wie er antworten sollte. anfagen aus dem netz 192.168.1.x auf server nix 192.168.1.168 klappen. anfragen aus dem netz 192.168.1.x auf server nic 192.168.200.168 klappen nicht.


grüße,
mike
Bitte warten ..
Mitglied: mike-berlin
08.10.2004 um 10:13 Uhr
auf dem server selber ist kein routing aktiviert. ist das denn erforderlich ? er soll ja eigentlich selber gar nicht routen. nur antworten. auf der richtigen karte.
wenn anfragen kommen an die 192.168.1.168 dann auch auf dieser karte. anfragen an die 192.168.200.168 dann auf dieser karte
Bitte warten ..
Mitglied: das-omen
08.10.2004 um 10:14 Uhr
Hi!

Ja sicher habe ich auch so verstanden. Versuche doch mal auf dem Server das Routing zu aktivieren.

Tschau

Das Omen
Bitte warten ..
Mitglied: mike-berlin
08.10.2004 um 11:00 Uhr
also Routing (unter Linux IP forwarding) hatten wir schon eingestellt und getestet. Leider auch ohne den gewünschten Erfolg
Bitte warten ..
Mitglied: das-omen
08.10.2004 um 11:02 Uhr
Hi!

hmm muss mal anders Fragen warum ist es so wichtig das die andere Karte antwortet?


Tschau

Das Omen
Bitte warten ..
Mitglied: mike-berlin
08.10.2004 um 11:10 Uhr
Wir hatten vorher zwei getrennte Machinen. Eine im Netz 192.168.1.x und eine im Netz 192.168.200.x
Die Anwendungen der zweiten Maschine sollen auf die erste Kiste migriert werden (bessere Auslastung).
Da wir einen haufen Anwender/ Entwickler haben die mit der festen IP arbeiten bzw. die Anwendungen auf der Kiste auf die IP festgelegt sind, war es aus unserer Sicht einfacher die bisherige Adresse beizubehalten. Eine Änderung / Anspassung der IP's bei den Anwendungen und bei den Usern ist mit einem irren Aufwand verbunden und defakto nciht machbar / vertretbar.
daher eine kiste mit zwei NIC's unter beibehaltung der IP Konfig. So zumindest die Idee
Haben auch schon versucht beide Adressen / Netze an nur eine Karte zu binden. aber das war leider auch nicht so richtig von erfolg gekrönt.


Grüße,
Mike
Bitte warten ..
Mitglied: Atti58
08.10.2004 um 13:02 Uhr
Wenn ich mir die Routingtabelle so ansehe, sehe ich nur ein Standardgateway für beide Karten. Meiner Meinung nach müsstest Du ein zweites Standardgateway in das 192.168.200.0 Netz der Karte eth1 zuweisen.

Gruß

Atti
Bitte warten ..
Mitglied: mike-berlin
08.10.2004 um 13:49 Uhr
also mit zwei standardgateways haben wir es zar auch schon versucht, aber das hat nicht geklappt. macht auch eigentlich keinen sinn da das standardgateway nur dann zum einsatz kommt wenn eine adresse nicht aufgelöst werden kann. generell gibt es meines wissens nur ein standardgateway auf jedem rechner.
noch n paar ideen ?


Grüße,
Mike
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Linux
Linux-Server (IGEL UMS5) auf Windows umziehen (2)

Frage von Holywarrior1 zum Thema Linux ...

Debian
gelöst Kein Zugriff auf Linux Server nach Neustart - Alle Ports zu (22)

Frage von itschloegl zum Thema Debian ...

Hyper-V
Windows Server 2012 R2 NIC Teaming mit Lancom Switch (3)

Frage von onkel87 zum Thema Hyper-V ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Microsoft
Ordner mit LW-Buchstaben versehen und benennen (19)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...