Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Login mit WGET

Frage Internet

Mitglied: wgetter95

wgetter95 (Level 1) - Jetzt verbinden

20.05.2007, aktualisiert 14:00 Uhr, 16692 Aufrufe, 3 Kommentare

bunutzername:passwort@host funktioniert nicht

beim login auf einer website verwende ich folgende syntax:
wget http://www.host.de\login.php --post-data=user=xy&pass=yz

dabei übernimmt wget nur den "user", für pass kommt die windowms-cmd-standardmeldung datei nicht vorhanden oder falsch geschrieben

wenn ich die vorgegebene Reihenfolge nutze, also
wget --post-data=user=xy&pass=yz http://www.host.de\login.php

meldet wget "missing url"
Mitglied: bastla
20.05.2007 um 11:20 Uhr
Hallo wgetter95 und willkommen im Forum!

Versuch es mit folgender Schreibweise:
01.
wget http://www.host.de\login.php --post-data=user=xy^&pass=yz
Hintergrund: "&" wird in der Commandshell dazu verwendet, Befehle zu kombinieren - mit "^" davor wird es "maskiert", dem Interpreter also mitgeteilt, dass tatsächlich das Zeichen "&" gemeint ist.

Grüße
bastla
Bitte warten ..
Mitglied: paulepank
20.05.2007 um 12:57 Uhr
Hallo ,

Zitat aus der Hilfe von wget

wget --post-data user=foo&password=bar http://server.com/auth.php

cu paulepank
Bitte warten ..
Mitglied: wgetter95
20.05.2007 um 14:00 Uhr
genau das habe ich mir gedacht, wusste nur nicht, wie man das umgeht - mit "" scheint es auch zu klappen, dennoch werde ich es nachher mal mit ^ testen
Bitte warten ..
Ähnliche Inhalte
Windows 10
gelöst Windows 10 Login extrem langsam, Rechner hängt sich auf (10)

Frage von Yell-ing zum Thema Windows 10 ...

Windows Server
gelöst Domänen Account mit SMB Zugang für einfache Geräte (ohne Login-Möglichkeit) (2)

Frage von kpieper zum Thema Windows Server ...

CMS
gelöst PhpMyAdmin Login-Seite wird nicht dargestellt (3)

Frage von Static zum Thema CMS ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Viren und Trojaner
Ransomware .nm4 (14)

Frage von Zyklo92 zum Thema Viren und Trojaner ...

Microsoft Office
+1.000 Ordner in Outlook: Wie besser? (11)

Frage von Matsushita zum Thema Microsoft Office ...

Zusammenarbeit
Administrator Verhalten nach Vertragskündigung (10)

Frage von sysbone zum Thema Zusammenarbeit ...