Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

lokales Netzwerk (mit Fritzbox) zw. 2PCs zu langsam

Frage Netzwerke LAN, WAN, Wireless

Mitglied: gerry-ges

gerry-ges (Level 1) - Jetzt verbinden

02.01.2008, aktualisiert 11.01.2008, 16175 Aufrufe, 13 Kommentare

LAN mittels Fritzbox

Hallo,

ich habe eine Fritzbox 7170, an der ich 2 PCs per LAN angeschlossen habe (Desktop und Laptop). Die jeweilige Verbindung mit dem Internet klappt problemlos und ist schnell.

Wenn ich jedoch Dateien von einem PC auf den anderen übertrage, dann geht das nur mit einer Geschwindigkeit von ca. 4 Mbit/s. Wenn ich den einen PC (Laptop) per WLAN anschließe, so beträgt die max. Geschwindigkeit nur 2 Mbit/s.

Dies scheint mir ein wenig zu langsam.
Das Netzwerk funktioniert aber ansonsten gut. Beide PCs können "sich sehen" und Dateien freigeben.

Auf dem Desktop befindet sich XP Home, auf dem Laptop Vista (habe dies aber auch mit XP ausprobiert).

Auf dem Desktop ist ein Netzwerkeintrag "Internetgateway" zu sehen. Hier wird eine Übertragungsrate von 1,1Mbit/s angezeigt. Die
Übertragungsrate der normalen Netzwerkkarte wird mit 100Mbit/s angezeigt.

Ich habe dies auch schon mit einer anderen Fritzbox ausprobiert, insofern gehe ich von einem Netzwerkproblem aus. Aber: Das Netzwerk
funktioniert ja, nur sehr langsam.

Woran kann dies liegen ???

Noch zur Info: Die IP-Adressen habe ich sowohl über DHCP, als auch mal mittels fester IP vergeben. Daran liegts nicht.

Danke im voraus
Mitglied: LordGurke
02.01.2008 um 17:34 Uhr
Was sind denn für Protokolle bzw. Dienste für die einzelnen LAN-Verbindungen installiert?
Es reichen normalerweise
    • Client für Microsoft-Netzwerke
    • Dienst für Datei- und Druckerfreigabe
    • Internetprotokoll (TCP/IP) <- Version 4, IPv6 ist nicht notwendig!

Falls dort noch andere Protokolle stehen diese erstmal testweise deaktivieren. Wenn das nichts hilft, auf beiden Rechnern die Firewall komplett ausschalten.
Bitte warten ..
Mitglied: aqui
02.01.2008 um 17:40 Uhr
Der Eintrag Internetgateway kommt sehr wahrscheinlich vom aktivierten UPnP Protokoll auf der Fritzbox. Generell ist UPnP ein erhebliches Sicherheitsrisiko und sollte im Setup der Fritzbox (oder bei Routern allgemein) besser deaktiviert werden !
Wenn das erledigt ist, kannst du den Eintrag aus den Eigenschaften der Netzwerkumgebung löschen er sollte dann auch nicht wieder auftauchen... Das vorweg...

Um die Fritzbox als Verursacher ausschliessen zu können solltest du beide Geräte einmal direkt von Netzwerkkarte zu Netzwerkkarte mit einem Crossover Ethernetkabel verbinden. Dann machst du den Transfer nochmal und misst wieder die Zeit.
(Natürlich geht dieser Crossover Check nur mit manuell vergeben IPs, da der DHCP Server auf der FB ja nun nicht präsent ist !)
Wichtig ist das du beim Laptop der ggf. beide Netzadapter (Kupfer und WLAN) aktiviert hast das WLAN deaktivierst. Es sollte immer nur ein Adapter aktiv sein, da sonst ggf. beide im selben IP Netz hängen und Windows erheblich Probleme damit bekommt.
Ist der Durchsatz bei Der Direktverbindung wieder so schlecht kannst du die FB dann sicher ausschliessen.
Der Fehler liegt dann vermutlich an den Netzwerkkarten. Es ist möglich das es ein Autonegotiation Problem der Karten ist (Speed und Duplex Verhalten).
Um das ebenfalls auszuschliessen solltest du die Karten unter Windows in den Eigenschaften der Treiber einmal fest auf 100 Mbit und Fullduplex einstellen und den Transfertest wiederholen.
Damit du dich nicht immer auf Windowsperfomance verlassen musst gibt es gute Tools wie z.B. NetIO (http://www.ars.de/ars/ars.nsf/docs/netio) das dir für unterschiedliche Packetgrößen die Performance deines Netzwerkes anzeigen.
Das Prg musst du nur entpacken und kannst es direkt auf der Eingabeaufforderung laufen lassen !
Mit entsprechendem Tuning der Einstellungen sollte auf alle Fälle ein erheblich besserer Durchsatz erreichbar sein, wenigstens auf dem Kupferanschluss !

Der schlechte Durchsatz im WLAN kann daran liegen, das sich Nachbarschafts WLANs auf deiner oder in der Nähe deiner Funkfrequenz (Kanal) befinden.
Du solltest darauf achten das du mindestens 5 Funkkanäle Abstand zu diesen hälst, damit dein WLAN fehlerfrei funktioniert.
Auf welchen Kanälen diese WLAN Netze senden kannst du mit einem Tool wie z.B. dem www.NETSTUMBLER.com sehen.
Bitte warten ..
Mitglied: gerry-ges
02.01.2008 um 20:14 Uhr
Hallo,

danke für die (bisherigen) Antworten...

1) Bzgl. Internetgateway: UPnP Protokoll hatte ich schon mal getestet...ich hatte mich nur über die angezeigte Übertragungsrate von 1,1Mbit/s gewundert.

2) Cross over Check: Gute Idee. Ich habe auch so ein Kabel, aber leider derzeit ausgeliehen. Insofern muss der Test ein wenig warten. Oder kann ich auch ein normales Netzwerkkabel verwenden ??

3) Bzgl. der Protokolle:
o Client für Microsoft-Netzwerke
o Dienst für Datei- und Druckerfreigabe
o Internetprotokoll (TCP/IP) <- Version 4
o Internetprotokoll (TCP/IP) <- Version 6 (hatte ich auch schon mal deaktiviert -> o. Erfolg)
o E/A Treiber für Verbindungsschicht Typologieerkennung
o Anwort für für Verbindungsschicht Typologieerkennung

Auf dem Vista-Laptop sind die obigen aktiv, auf dem dem XP-Desktop sind die ersten 3 aktiv sowie der QoS-Paketplaner

4) Die Übertragungsrate habe ich manuell auf 100 Mbit Vollmodus gestellt -> ohne Auswirkung

5) Auf dem Laptop habe ich abwechselnd den LAN-Adapter bzw. WLAN deaktiviert und mit dem jeweils aktiven gearbeitet -> ohne Auswirkung

6) WLAN: Die Internetverbindung ist ja schnell genug. Trotzdem werde ich mal den Kanal wechseln.

7) Die angesprochenen Programme werde ich mal testen...

Der beste Check scheint mir derzeit der CrossOver Check zu sein. Leider komme ich - wie gesagt - derzeit nicht an das Kabel, da der "Ausleiher" (auch) noch in Urlaub ist.

Kann ich auf dem Desktop ggf. mal Linux (z.B. von DVD ohne Installation) verwenden oder als 2. Betriebssystem neben XP installieren ?? Bringt das etwas ??
Bitte warten ..
Mitglied: aqui
03.01.2008 um 16:49 Uhr
Nein, wenn du NetIO nimmst zum Test zeigt dir das die reine LAN / WLAN Performance an undabhängig vom Betriebssystem. Da bringt also ein anderes OS rein gar nichts.
Kannst aber spassehalber ja mal eine Live CD wie z.B. die von der ct mit Knoppix booten und es versuchen. Der Unterschied dürfte minimal sein.

Der Crossover Check ist in der Tat der der nun am meisten aussagt !
Übrigens: So ein Kabel kostet ein paar Euro imlokalen Handel, sofern du nicht auf die Urlauber warten willst
Bitte warten ..
Mitglied: gerry-ges
03.01.2008 um 21:20 Uhr
genau, ich wollte nicht warten und habe mir eines gekauft.
Dummerweise (ich kann das immer noch selbst nicht glauben) habe ich dann festgestellt, dass
der Desktop bereits mit einem Crossover Kabel an das hausinterne Netz (von dort dann mit normalem Netzkabel) angeschlossen war. Ziemlich blöd, aber einen Unterschied macht es nicht, egal, welches Kabel angeschlossen ist.

Die PCs habe ich dann lokal mit dem Crossover Kabel verbunden.
Auch hier beträgt die Geschwindigkeit ca. 4 MB/s. Gleiches erziele ich ja auch über die Fritzbox
per LAN (per WLAN die Hälfte).

Also liegt die unzureichende Geschwindigkeit wie schon vermutet nicht an der Fritzbox, sondern an der Netzkonfiguration !?!

Ich würde gerne das Tool NetIO ausprobieren, habe aber keine Ahnung wie. Was heisst, ich kann es direkt in der Eingabeaufforderung laufen lassen ? Da passiert doch nichts ??
Bitte warten ..
Mitglied: aqui
04.01.2008 um 12:11 Uhr
Du entpackst das Tool (Die Binaries für Windows) in ein Verzeichnis und kopierst das Windows Binary (ausführbare Date .exe) auch auf den 2ten Rechner

Du öffnest die Eingabeaufforderung auf beiden Rechner und startest einen Rechner als NetIO Server und den anderen als NetIO Client. Das geht so:

Server: netio -t -s <return>

Client: netio -t <ip_adresse_server> <return>

Tipp: Wenn du nur netio ohne Parameter aufrufst hilft dir das Programm mit der Hilfe Ausgabe
Dann rennt das Programm los und zeigt dir online die Performance vom Netz.

Was meinst du übrigens genau mit MB/s ???
Sollen das Mega Byte oder Mega Bit sein ?? Hier bist du ziemlich unpräzise...
Das wäre ja dann noch ein erheblicher Unterschied !! Bei 4 Mbyte/s wären das dann ca. 32 Mbit/s. Zwar ein grottenschlechter Wert für ein 100 Mbit/s Netzwerk aber mehr oder weniger normal wenn du z.B. Netzwerkkarten mit RealTek Chipsatz hast.
Dieser Chipsatz bürdet einen Großteil des Packet Handlings der Rechner CPU auf, so das diese Karten eine sehr schlechte Performance im Netz haben und man sich davon keine Wunder erwarten darf !
Ob du solche Karten einsetzt kannst du im Gerätemanger nachprüfen.
Das dein Crossover Kabel auch am Switch funktioniert ist mehr oder weniger normal, da moderne Switches meist MIDI-X supporten und somit eine Kreuzverbindung in Kabeln selbstständig erkennen und sich entsprechend automatisch anpassen.
Bitte warten ..
Mitglied: gerry-ges
08.01.2008 um 22:14 Uhr
ok, hast recht, ich meine Mega Byte /s.
Aber 4 MB/s finde ich trotzdem etwas langsam. Vor allem dauert das ewig, bis dieser
maximale Wert erreicht wird. In Vista kommt dann erst die Meldung, dass die die verbleibende Zeit berechnet wird, und dann geht´s so laaanngsaam los. Nach ein paar Minuten erhöht sich dann die Geschwindigkeit.

Tatsächlich hat der alte Desktop (Pentium4, 2 Gigahertz) eine RealTek Netzwerkkarte eingebaut.

Jetzt zum netio Tool. Heraus kam folgendes:

Packet size 1k bytes: 593 KByte/s Tx, 289 KByte/s Rx.
Packet size 2k bytes: 718 KByte/s Tx, 275 KByte/s Rx.
Packet size 4k bytes: 1058 KByte/s Tx, 645 KByte/s Rx.
Packet size 8k bytes: 1038 KByte/s Tx, 1142 KByte/s Rx.
Packet size 16k bytes: 1179 KByte/s Tx, 713 KByte/s Rx.
Packet size 32k bytes: 788 KByte/s Tx, 1343 KByte/s Rx.

Wohl gemerkt, der Laptop war per WLAN angeschlossen.

Und was sagt mir das jetzt ????
Bitte warten ..
Mitglied: gerry-ges
08.01.2008 um 22:26 Uhr
bei jeder Ausführung des Tools netio erhalte ich völlig andere Werte.
Was soll mir das bringen ?
Bitte warten ..
Mitglied: aqui
09.01.2008 um 12:18 Uhr
Das ist doch logisch bei WLAN wie du ja selber wissen solltest. Die Connect Raten bei 802.11b und .g WLAN variieren je nach aktueller Feldstärke. Da reicht es schon wenn du nur etwas anders vorm Laptop sitzt um andere Werte zu bekommen. Das kann runtegehen bis 1 Mbit/s.

http://www.tomsnetworking.de/content/reports/j2005a/report_wlan_luege/

Deine unterschiedlichen Werte sind also nicht verwunderlich. Fazit der Messung ist das dein WLAN grottenschlechte Performance hat, da wahrscheinlich schlechte Feldstärke oder WLANs in der Umgebung deins stören (du musst mindestens 5 Kanäle Abstand zu diesen haben !!) Im Bereich von 4k und 8k großen Frames ist deine WLAN Karte noch am besten bei den kleineren Frames die am häufigsten sind am allerschlechtesten. Nicht verwunderlich bei Realtek Chipsätzen.
Es kann aber auch schlicht und einfach an billiger Hardware und damit an schlechter unempfindlicher Empfangs- und Sendeleistung liegen. Jedenfalls was das WLAN anbetrifft.

Bei LAN Adaptern hilft manchmal ein spielen mit aktuellen Treibern und das einstellen von statischen Parametern wie Duplex und Geschw. Modus. Bringt aber nicht allzuviel oft, leider !
Bitte warten ..
Mitglied: gerry-ges
09.01.2008 um 16:40 Uhr
wenn das WLAN so eine grottenschlechte Performance hätte, dann beträfe dies aber sicherlich auch die Internetverbindung. Die ist aber völlig ok.

Vielleicht sollte ich den Test nochmal per LAN machen, mal sehen, ob die Messungen dann gleich oder zumindest ähnlich sind, wenn man den Test wiederholt.
Aber trotzdem nochmal zum Verständnis. Wenn dort z.B. steht:
Packet size 1k bytes: 593 KByte/s Tx, 289 KByte/s Rx.
Was heisst das ??

Ansonsten glaube ich mittlerweile, liegt´s einfach an dem alten Desktop mit Realteck Karte.
Irgendwie war ich noch in dem Glauben, dass in einem lokalen Netzwerk die Geschwindigkeit kein "Problem" darstellt, auch bei älteren Geräten.

Noch etwas: Gibt es denn eine logische Erklärung dafür, warum die Geschwindigkeitsanzeige von Vista erst ewig für eine Berechnung braucht bzw. die Geschwindigkeit sich nach und nach erhöht ??
Bitte warten ..
Mitglied: aqui
11.01.2008 um 08:10 Uhr
Nein das ist ein vollkommener Trugschluss das die WLAN Verbindung die DSL Verbindung beeinflusst. beides hat rein gar nichts miteinander zu tun.

Das WLAN ist eine stinknormale Layer 2 Bridge (Mac Layer) aus Packetsicht zum LAN Interface. Es werden also alle Ethernetpackete vom WLAN Client über die Funk WLAN Wolke zum LAN Interface des Routers gebridgted und von da aus ins Internet geschickt.
Beides hat miteinander überhaupt nichts zu tun, jedenfalls nicht in Bezug auf eine Beeinflussung !
Wenn dein WLAN schlecht performt, kann ein am Router kabel angebundener Client mit voller Performance arbeiten.
Klar, wenn das WLAN schlecht ist und die Daten dort gestört werden und sie nur mit schlechter Performance am LAN Interface des Routers ankommen, kann natürlich auch nur diese schwache Datenrate die dort reintröpfelt ins DSL geroutet werden in sofern ist ein Beeinflussung dann richtig ! (Rückwärts gilt das dann auch..)

Ein WLAN Router ist nichts anderes als ein DSL Router mit am LAN Anschluss integriertem WLAN Accesspoint !
Bitte warten ..
Mitglied: gerry-ges
11.01.2008 um 13:47 Uhr
Klar, wenn das WLAN schlecht ist und die
Daten dort gestört werden und sie nur
mit schlechter Performance am LAN Interface
des Routers ankommen, kann natürlich
auch nur diese schwache Datenrate die dort
reintröpfelt ins DSL geroutet werden
in sofern ist ein Beeinflussung dann
richtig ! (Rückwärts gilt das dann
auch..)

Also wenn mein WLAN soo langsam wäre, dann müßte ich das (vielleicht) auch im Internet merken, da die Daten ja nur am Router "reintröpfeln". Der Flaschenhals wäre also nicht die Internetverbindung, sondern die Verbindung vom WLAN zum Router.

Mit den Kanälen werde ich auf jeden Fall mal testen.

Vielen Dank für die Erklärungen...auch wenn man in der IT ja nicht immer alles logisch erklären kann (zumindest kann ich das vom "SAP-Bereich" her beurteilen).
Bitte warten ..
Mitglied: aqui
11.01.2008 um 15:39 Uhr
Bei Windows ist es doch bekanntermaßen ähnlich...
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...