Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Mails an eigene Domain trotzdem über Relay schicken

Frage Microsoft Exchange Server

Mitglied: wiseguy

wiseguy (Level 1) - Jetzt verbinden

26.09.2012, aktualisiert 10:31 Uhr, 7300 Aufrufe, 6 Kommentare

Mein Szenario:
  • Windows Server 2008 R2
  • Exchange 2010
  • Vorgelagerter Mailserver (Linux Server im Internet) der über IMAP/SMTP angesprochen wird
  • Externe Domain: meinedomain.de
  • Interne Domain (das ist auch die Windows Domäne): meinedomain.intern

  • Nicht alle Mailbenutzer der Domain meinedomain.de nutzen den Exchange; Einige nutzen ausschließlich den IMAP/SMTP Server im Internet

Ich möchte, dass der Exchange Mails an meinedomain.de NICHT intern abfrühstückt. Er soll dafür den Connector zu dem vorgelagerten Linux Server im Internet nutzen.

Dafür habe ich einen Connector eingerichtet mit Adressraum *, der alle Mails über das externe Mailrelay schicken soll.

Wenn ich nun aber eine Mail an z.B. mailadresse@meinedomain.de schicke, versucht der Exchange die intern zuzustellen. Da kein Benutzer im AD diese Mailadresse hat, bekommt der Versender eine entsprechende Fehlermeldung.
Die Mailadresse gibts auch tatsächlich nur auf dem vorgelagerten Linux Server. Ich würde nun wollen, dass der Exchange alle Mails an meinedomain.de über den Relay Server versendet, unabhängig davon, ob der Empfänger auch ein Konto im AD ist/hat. (Die Mail wird dann vom Pop3 Connector halt wieder her geholt).

Wenn ich tatsächlich nur innerhalb meines Exchange Servers bleiben will, könnte ich ja die meinedomain.intern Mailadressen verwenden. Diese existieren tatsächlich nur für User des ADs.

Kann mir hier jemand weiterhelfen?

Lieben Gruß
Wiseguy
Mitglied: d4shoerncheN
26.09.2012 um 10:48 Uhr
Hallo,

schreib bitte noch dazu, wie du den neuen Sendeconnector konfiguriert hast.

Gruß
Bitte warten ..
Mitglied: wiseguy
26.09.2012, aktualisiert um 11:18 Uhr
Sendeconnector ist wiefolgt eingerichtet:
Registrierkarte "Adressraum":
Adressraum wie bereits genannt: *
Typ davon ist "SMTP" und Kosten "1". Er gillt für alle Subdomains. "Sendeconnector mit Bereich" ist nicht aktiviert (kenn die Option nicht).

Registrierkarte "Netzwerk":
Email über einen Smarthost leiten. Zugangsdaten dort entsprechen denen für den Linux Mailserver im Internet. "Die Einstellung für externes DNS-Lookup auf dem Transportserver verwenden" ist nicht aktiviert (Auch hier kenn ich die Option erstmal nicht bzw. weiß nicht was dieser Punkte genau bewirken würde).

Registrierkarte "Quellserver":
Hier ist einzig und allein mein Exchange Server eingetragen.


Ergänzungen:
"Sendeconnector mit Bereich":
Alle von Ihnen erstellen Sendeconnectors können standardmäßig von allen Hub-Transport-Servern in der Exchange-Organisation verwendet werden. Sie können jedoch den Bereich jedes beliebigen Sendeconnectors so einschränken, dass er nur von anderen Hub-Transport-Servern verwendet werden kann, die am gleichen Active Directory-Standort vorhanden sind. Wählen Sie zum Einschränken des Gültigkeitsbereichs des Sendeconnectors die Option Sendeconnector mit Bereich aus.
(Q: http://technet.microsoft.com/de-de/library/bb629503.aspx)

-> Da hier ja mehr eingeschränkt wird, hatte ich nicht angenommen, dass diese Option mein Problem lösen würde (und habs auch nicht ausprobiert). Was das alerdings genau ist, weiß ich nicht bzw. verstehe ich nicht ganz.


"Die Einstellung für externes DNS-Lookup auf dem Transportserver verwenden":
-> Auch hier klingt es nach einer Einschränkung und ohnehin nicht zu meinem Problem. Daher habe ich auch diese Option nicht ausprobiert.

Soweit ich auch gelesen habe, verhält sich der Exchange so, dass er interne Mails nicht über die Connectoren versendet; Diese Einstellung müsste sich also irgendwie verändern lassen. Oder alternativ irgend eine notlösung geschaffen werden (was natürlich nicht gerade toll wäre)
Bitte warten ..
Mitglied: Bap02-2
26.09.2012 um 11:26 Uhr
Hallo,

hier die Lösung. Ich hoffe Du kommst klar.

Problem 1: Zitat: "Wenn ich nun aber eine Mail an z.B. mailadresse@meinedomain.de schicke, versucht der Exchange die intern zuzustellen. Da kein Benutzer im AD diese Mailadresse hat, bekommt der Versender eine entsprechende Fehlermeldung."

Lösung 1: Stelle den Exchangeserver in der Verwaltungskonsole (Organisationskonfiguration)-HubTransport-Akzeptierte Domänen-Neue akzeptierte Domäne meinedomain.de auf Interne Relaydomäne. Dann im gleichen Fenster nochmal eine akzeptierte Domäne meinedomain.intern auf autorisierend. Somit schickt er alle Mails, die an Mailadressen gehen die nicht in der Domäne vorhanden sind, über den Sendeconnector nach draussen an den Linux Mailserver. Hab ich auch bei einem Kunden und das funktioniert wunderbar.

Problem 2: Zitat: "Ich würde nun wollen, dass der Exchange alle Mails an meinedomain.de über den Relay Server versendet, unabhängig davon, ob der Empfänger auch ein Konto im AD ist/hat. (Die Mail wird dann vom Pop3 Connector halt wieder her geholt)."

Lösung 2: Alle Mails ist unmöglich! Der Exchangeserver schaut schon aus Prinzip immer zuerst bei sich selber nach und Du bräuchtest dann auch keinen Exchangeserver
Bitte warten ..
Mitglied: Lochkartenstanzer
26.09.2012, aktualisiert um 12:45 Uhr
Moin,

Du könntest aber auch subdomains verwenden:

user@exchange.domain.tld
user@linux.domain.tld

Der exchange nimmt nur die Mails für exchange.domain.tld an und alles andere schickt er an linux.domain.tld als smarthost.

Dieser wiederum macht Address rewriting und schickt die mails mit user@domain.tld raus, bwz sortiert diese in den Postfächern der user bei sich ein wo sie dann der exchange und die externen user wieder abholen können.

Funktioniert bei einem Kunden vom mir einwandfrei. (Der hat zusätzlich noch historisch bedingt notes.domain.tld und david.domain.tld ).

lks


Edit: Leichte Ergänzungen/Korrekturen.
Bitte warten ..
Mitglied: wiseguy
26.09.2012 um 14:13 Uhr
@Bap02-2: "Lösung 1"; Super, das hat erstmal geklappt

Mit dem anderen Problem (Problem 2) werd ich also leider leben müssen

Danke euch
Bitte warten ..
Mitglied: Bap02-2
04.03.2013 um 02:19 Uhr
Hallo, könntest Du bitte das Thema abschließen und meine Antwort als die richtige kennzeichnen. Wäre echt nett von Dir.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...