Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

MS-DOS 6.22 - Tastaturlayout

Frage Entwicklung Batch & Shell

Mitglied: geTuemII

geTuemII (Level 3) - Jetzt verbinden

21.01.2009, aktualisiert 14:56 Uhr, 10848 Aufrufe, 6 Kommentare

Hallo @all,

ich konfiguriere gerade eine DOSE 6.22 (ja, wirklich!) in einem Virtuell PC. Dabei bereitet mir das Tastaturlayout einige Sorgen. Ich habe Country und Tastatur auf deutsch konfiguriert, das scheint auch zunächst funktioniert zu haben: keyb liefert Layout gr, Codepage 850, CON Codepage 850. Die Umlaute funktionieren und das Datumsformat ist deutsch (zb. mit dir).

Allerdings kann ich kein Backslash "\" eingeben, offensichtlich tun alle Tasten, die über AltGr gesteuert werden nicht. Gelagen sind übrigens ega.cpi und keyboard.sys

Kann sich von euch noch jemand erinnern, wie das funktioniert?

Ist das lange her...
geTuemII
Mitglied: 60730
21.01.2009 um 15:06 Uhr
Servus,

mir ist folgendes aufgefallen:

[ALT Gr] und Numtastatur 92 = \ (alter Hut - nichts besonderes)
Aber bei meinen VMware Server Clients funktioniert die 10+Tastatur nicht - bzw. da ich die eh nicht brauche - mußte ich mir noch keine Gedanken darum machen warum weshlab.

Von daher - funktioniert bei deinem Client der 10er Block?


Gruß
Bitte warten ..
Mitglied: geTuemII
21.01.2009 um 15:32 Uhr
Hi House,

der Nummernblock tut bei mir, aber AltGr+92 hilft nicht wirklich, da offensichtlich das Problem in der AltGr-Taste zu suchen ist. Ein Host-Problem kann es eigentlich auch nicht sein, habe gerade den zweiten getestet. --> dieselben Symtome

geTuemII
Bitte warten ..
Mitglied: telefix1
21.01.2009 um 15:47 Uhr
...ja ja...

Versuche es mal bitte mit dem Zeichensatz 437 statt mit 850...

config.sys
country=049,850 oder 437,Pfad der country.sys
mode con 850 oder 437
keyb gr,850 oder 437,Pfad der keyboard.sys


mfg telefix1
Bitte warten ..
Mitglied: n.o.b.o.d.y
21.01.2009 um 16:09 Uhr
Moin!

Beim VirtuallPC ist die AltGr-Taste doch die Hosttaste (für Vollbild und so). Leg die doch einfach um, dann sollte es auch in der VM gehen.

Datei > Optionen > Tastatur
Bitte warten ..
Mitglied: geTuemII
21.01.2009 um 17:05 Uhr
<aua><aua><aua><aua><aua><aua>

Moin n.o.b.o.d.y,

da habe ich wohl den Wald wieder einmal nicht vor Bäumen... Weil ich wegen des DOSEN-Setups schon ganz tief in längst verschütteten Erinnerungen graben mußte, hatte ich geglaubt, es müsse sich um ein Problem in der DOS-Config handeln.

Und kaum mache ich, was du sagst, tut auch schon alles

Danke,
geTuemII
Bitte warten ..
Mitglied: geTuemII
21.01.2009 um 17:06 Uhr
Hallo telefix1,

danke für die Idee, das hatte ich vorher schon probiert - tat auch nicht. Die Lösung findest du unten.

geTuemII
Bitte warten ..
Ähnliche Inhalte
Hyper-V
gelöst HyperV - ungültige MS-DOS Funktion (14)

Frage von Franz-Josef-II zum Thema Hyper-V ...

Datenbanken
gelöst MS SQL Abfragen und Formulare in Webseite einbinden (3)

Frage von Machello zum Thema Datenbanken ...

Backup
Backup-Software für IIS und MS SQL (2)

Frage von Ravelux zum Thema Backup ...

Exchange Server
gelöst MS Exchange Datenverlust RetentionAgent (2)

Frage von amarsin zum Thema Exchange Server ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(2)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (36)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Verschlüsselung & Zertifikate
Mit Veracrypt eine zweite interne (non-system) Festplatte verschlüsseln (11)

Frage von Bernulf zum Thema Verschlüsselung & Zertifikate ...

Internet Domänen
Nameserver ein Geist? (9)

Frage von zelamedia zum Thema Internet Domänen ...