Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Nagios3 check load

Frage Linux Linux Netzwerk

Mitglied: Neurosis404

Neurosis404 (Level 1) - Jetzt verbinden

02.07.2008, aktualisiert 12:30 Uhr, 7833 Aufrufe, 2 Kommentare

Servus,

ich sitze hier grade an einem Nagios Server, Version 3.0rc2. Ein riesiges Problem habe ich mit dem Plugin "check_load"; Über direktes aufrufen (Also als Beispiel ./check_load -w 0.04,5.00,8.00 -c 0.05,8.00,10.00) funktioniert alles, doch über einen define service klappt es leider nicht.

Hier meine configs (unformatiert):

Auszug aus der host.cfg

01.
define service{ 
02.
 
03.
host_name  -  host.domain.de 
04.
service_description  -  check_load 
05.
check_command  -  check_load -w 0.04,5.00,8.00 -c 0.05,8.00,10.00 
06.
<Kontaktdaten> 
07.
}
Auszug aus der commands.cfg

01.
# 'check_load' command definition 
02.
define command{ 
03.
 
04.
command_name  -  check_load 
05.
command_line  -  $USER1$/check_load -H $HOSTADDRESS$ -w $WLOAD1$,$WLOAD5$,$WLOAD15$ -c $CLOAD1$,$CLOAD5$,$CLOAD15$ 
06.
}

Als Fehlermeldung bekomme ich beim nagios check:

Service check command 'check_load -w 0.04,5.00,8.00 -c 0.05,8.00,10.00' specified in service 'check_load' for host 'host.domain.de'not defined anywhere!

Ein check_load --help gibt folgendes aus:

Usage:check_load [-r] -w WLOAD1,WLOAD5,WLOAD15 -c CLOAD1,CLOAD5,CLOAD15

Aber wenn ich das so in die commands.cfg kopiere, hilft mir das auch nicht weiter.
Ich habe auch durch ausklammern eines anderes Services getestet, ob nagios auf die richtige commands.cfg zugreift, und er tut es, daran kanns auch nicht liegen.

Hat irgendjemand eine Idee, was ich als Template in die commands.cfg eintragen muss? Google spuckt so viel aus, jedoch ist das wohl alles für Nagios Vers.2, auf jeden Fall klappt es nicht.
Mitglied: theton
02.07.2008 um 12:19 Uhr
Dein Problem ist die Zeile

check_command - check_load -w 0.04,5.00,8.00 -c 0.05,8.00,10.00

Das hast du ja schon als command definiert. Du musst in der Service-Definition die richtige Syntax benutzen

check_command check_load!<wert1>,<wert2>,...

Im übrigen haben die Bindestriche meiner Meinung nach dort nichts zu suchen zwischen dem "Befehl" und der "Definition", also nicht

check_command - definition

sondern

check_command definition
Bitte warten ..
Mitglied: Neurosis404
02.07.2008 um 12:30 Uhr
Ach man, auf sowas einfaches komm ich natürlich wieder nicht, dankeschön, ich teste es gleich mal.
Die Bindestriche sind nur der Übersichtlichkeit wegen hier im Forum, in der Config sind sie natürlich nicht zu sehen.
Bitte warten ..
Ähnliche Inhalte
Monitoring
Nagios Check selber schreiben
gelöst Frage von tux1996Monitoring4 Kommentare

Guten Tag, bis jetzt musste ich nie ein Nagios Plugin Schreiben da die benötigten Plugins schon vorhanden waren. Ich ...

Outlook & Mail
Mail Check für Taskleiste
gelöst Frage von linguinOutlook & Mail4 Kommentare

Hallo, banale Frage ich weiß. Aber auch Chip und Computer Bild macht keinen Spass mehr beim Runterladen. Ich such ...

Netzwerkmanagement
Load Balancer gesucht
Frage von pianoman82Netzwerkmanagement6 Kommentare

Hallo und Guten Abend! Ich hatte in der Vergangenheit einen Root-Server bei Hetzner und habe dort verschiedene virtuelle Maschinen ...

DNS
Load Balancing - Webservice Server
gelöst Frage von eyetSolutionsDNS1 Kommentar

Hallo, ich habe 2 Webservice Server in einem Rechenzentrum: Server 1 - NAT Adresse = 1.1.1.1 Server 2 - ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 1 TagApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement16 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...