Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Net use Verbindungen trennen sich trotz Persistent yes

Frage Microsoft Windows Server

Mitglied: woopinwolfman

woopinwolfman (Level 1) - Jetzt verbinden

18.04.2007, aktualisiert 23.05.2007, 15964 Aufrufe, 6 Kommentare

Guten Tag User und Admin's,
ich habe ein kleines Problem mit Windows XP Clients und einem Windows 2003 Server der kein Domänencontroller ist. Der Server soll ein reiner Plattenserver sein der ein 16 Bit Programm ( FOX ) im Netzwerk zur Verfügung stellen soll. Da Fox die Drucker auf LPT1: und LPT2: sucht habe ich den Drucker über einen Printserver der SMB unterstützt eingerichtet. Als Login-Script eine start.cmd ins Autostart der Clients kopiert.

Inhalt:
@echo off
net use h: \\server\Daten
net use K: \\server\home
net use L: \\server1\spam /user:login passwort

net use lpt1: \\Printserver\OKI /persistent:yes /user:login passwort
net use lpt2: \\Printserver2\OkI2 /persistent:yes /user:login passwort

Pause

Problem: Nach sehr kurzer Zeit erhalte ich unter dem Befehl "net use" die Meldung "Getrennt lpt1: \\Printserver\OKI" . Gleiches erhalte ich an einigen Rechnern von den gemappten Laufwerken. In der Ereignisanzeige stehen leider keine Fehler. Der Server hat auch genug Lizenzen. Kann mir eventuell jemand einen Tipp geben was das Problem sein kann?

Win2003 SP2

Danke für eure Hilfe

mfg. Wolfgang Utz
Mitglied: Iwan
18.04.2007 um 15:50 Uhr
ist es denn immer nur lpt1 oder ist auch lpt2 betroffen?
Bitte warten ..
Mitglied: woopinwolfman
18.04.2007 um 16:03 Uhr
Auch lpt2. Wenn ich die Drucker über Novell mit "net use lpt1: \\Novell\Oki" ins System einbinde bleibten die Verbindungen permanent verbunden. Vielleicht hilft das weiter. Danke
Bitte warten ..
Mitglied: rubberduck
18.04.2007 um 19:02 Uhr
Kleine Frage:
Wieso willst Du um den Drucker einzubinden Benutzernamen und PW mitgeben?
(Mal abgesehen davon, dass jeder der den Batch sieht, das PW Klartext vor der Nase hat)

Wenn Du nicht etwas ganz Lustiges gemacht hast, dann müsste "Jeder" die Berechtigung "Drucken" auf dem DruckerShare haben. Ergo brauchst Du keinen Benutzernamen und PW.

Da Du ja den Batch im Autostart hast, geht mir auch nicht ganz auf, wieso es PERSISTENT sein muss. Ohne PERSISTENT ist die Verbindung nur während der laufenden Sitzung gültig, weil das Ding aber bei jedem einloggen ausgeführt wird, sind die Drucker ja Verfügbar.

Novell ist bei mir zwar schon seeehr lange her aber:
Du schreibst
"net use lpt1: \\Novell\Oki"
soweit ich es Erinnerung habe bezieht sich NET USE immer auf den DOS-Befehl. Hatte Novell nicht einen Eigenen Befehl?
Wie auch immer, bei Deinem "Novell-Befehl" gibst Du weder PERSISTENT noch Benutzername und PW mit. Und trotzdem geht es...
Bitte warten ..
Mitglied: woopinwolfman
19.04.2007 um 12:22 Uhr
Leider habe ich ein Vista mitlaufen. Der Rechner verbindet sich nur mit einem Konica Drucker mit Benutzeranmeldung. Deshalb der User mit Passwort. Der User ist im Druckermenue eingerichtet.

Die Drucker sind alle über LPR auf den Clients eingerichtet. Damit kann ich aus FOX aber nicht drucken. Fox schickt den Druckauftrag an LPT1. Eben ein alter 16-Biter. Deshalb benutze ich "net use" um über SMB den Druckauftrag umzulenken. Funktioniert ja auch. Nur eben hält Windows die Verbindung nicht. Persistent habe ich nur zum testen in der Batch.

Mit net use kann ich alle freigegebenen Resourcen nutzen. Wer sie mir zur Verfügung steht spielt doch keine Rolle. Wichtig ist doch nur das SMB unterstützt wird. Gemeint war das wenn ich unter Novell die Freigabe mit net use ins System mappe die Verbindung dauerhalft bestehen bleibt. Bis zur nächsten Anmeldung. Bei der nächsten Anmeldung wird dann per Login-Script mit dem Befehl capture der Drucker wieder ins System gemappt. Hat den jemand einen Drucker mit net use lpt1: \\...... ins System gemappt. Bleibt das die Verbindung permanent bestehen? Oder steht da auch nach kurzer Zeit "Getrennt".

Unter Vista werden auch die Laufwerke nach kurzer Zeit rausgeschnissen. Das habe ich aber mit net config server /autoreconnect:-1 hinbekommen. Nur wird der Drucker immer wieder getrennt.
Bitte warten ..
Mitglied: woopinwolfman
23.05.2007 um 14:23 Uhr
Problem gelöst: Für alle die mal auf das gleiche Problem stossen.

Erst den Drucker auf dem Server einrichten und freigeben. Dann bei den Clients die Drucker mit net use lpt1: \\Serverfreigabe\Druckername /persistent:yes einrichten. Als zusatz habe ich noch net config server /autodisconnect:-1 eingegeben. Dann halten die Clients die Verbindung zu Drucker dauerhaft.

Bei Vista hatte ich das Problem das bei der net use lpt1: immer nach Benutzer und Passwort gefragt wurde. Erst wenn man im Gerätemanagerr den lpt1 deaktiviert lässt sich auch in Vista der Drucker mit net use einrichten.
Bitte warten ..
Mitglied: Biber
23.05.2007 um 21:52 Uhr
Moin woopinwolfman,

interessante Information, auch für mich neu...
Bei Vista hatte ich das Problem das bei der net use lpt1: immer nach Benutzer und Passwort gefragt wurde. Erst wenn man im Gerätemanagerr den lpt1 deaktiviert lässt sich auch in Vista der Drucker mit net use einrichten.

Neu ist für mich die Info, dass dieser Bug/dieses Feature tatsächlich auch nach Vi$ta hinübergerettet worden ist.. *grummel*...
Das Problem (bezogen auf physikalisch vorhandene LPT-Ports, also meist nur LPT1: ) besteht spätestens seit WinXP, ich glaube sogar auch unter Win2000.
Die COM/LPT-Devices im Gerätemanger mussten erst deaktiviert werden, bevor sich mit "net use" ein Anschluss zuordnen liess... und das auch nur mit Adminrechten.
o M$... eine weitere Kerbe auf dem Schwert, dass Dich irgendwann treffen wird...

Es gibt unter den Pre-Vi$ta-Versionen auch einen weiteren Workaround, der dann wahrscheinlich auch immer noch funktioniert:
  • falls ein physikalisch vorhander Port per "net use" zugeordnet werden soll: im gerätemanager deaktivieren
  • EINmalig ein "net use lpt1: \\druckerserver\drucker /p:yes /USER:einAdmin passwort" abfeuern

Der undokumentierte Schalter /p:yes statt /persistent:yes ist nicht das wesentliche, sondern dass der Useraccount ein Adminaccount ist.
Dadurch hätte/hat der normalberechtigte user auch gar nicht das Recht, diese Druckerzuordnung allein wieder zu lösen.

Grüße und vielen Dank fürs Posten Deiner Lösung
Biber
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
NET USE LPT1 (4)

Frage von MiSt zum Thema Batch & Shell ...

VB for Applications
VB.net Combobox databinding langsam (3)

Frage von ForgottenRealm zum Thema VB for Applications ...

Visual Studio
gelöst Vb.net: Word-Doc seitenweise durchsuchen nach Textmarke (7)

Frage von ahstax zum Thema Visual Studio ...

Neue Wissensbeiträge
Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(5)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(5)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Viren und Trojaner

Neue Magazin Ausgabe: Malware und Angriffe abwehren

Information von Frank zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
Windows Systemdateien
Warum System auf "C:" (29)

Frage von DzumoPRO zum Thema Windows Systemdateien ...

LAN, WAN, Wireless
Cisco SG200: Auf bestimmtem vLAN bestimmte TCP-Ports sperren (19)

Frage von SarekHL zum Thema LAN, WAN, Wireless ...

Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Batch & Shell
gelöst Batch um Benutzer aus Sitzung abzumelden (15)

Frage von zeroblue2005 zum Thema Batch & Shell ...