Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Net use unter WinXP macht Probleme

Frage Microsoft Windows Netzwerk

Mitglied: pgmende

pgmende (Level 1) - Jetzt verbinden

12.01.2010 um 10:58 Uhr, 4490 Aufrufe, 2 Kommentare

Netzlaufwerk kann nicht gelöscht und auch nicht neu verbunden werden.

Hallo!

Ich habe zu diesem Problem schon gegoogelt und auch hier im Forum einen größeren Thread gefunden, der das Problem aber nicht löste.

Von einem Win XP Prof. - Client soll auf eine Freigabe per Batchdatei gemappt werden:

- net use X: \\servername\freigabe
- führe einen bestimmten Job aus (rsync)
- net use X: /delete

Normalerweise eine leichte Übung, mit sowas arbeiten wir hier ständig. Bei einigen Clients gibts aber Probleme, der net use /delete - Befehl wird zwar "erfolgreich ausgeführt", die Netzverbindung wird mittels "net use" aber immer noch angezeigt. Bei "Status" steht aber weder OK noch Getrennt, sondern gar nichts. Im Explorer wird die Verbindung auch nicht mehr angezeigt.
Logischerweise wird die Verbindung mit dem gleichen Benutzer (und Rechten) ausgeführt, wie das Trennen. Nach einem Neustart ist die Verbindung tatsächlich weg und kann wieder neuverbunden werden.

Ein erneutes Verbinden führt zum Systemfehler 85 - Gerätename wird bereits verwendet.
Ein erneutes Trennen führt zum Fehler "Netzwerkverbindung nicht vorhanden".
Soweit die Logik aus Redmond...

Leider benötige ich hierbei einen Laufwerksbuchstaben, da ich mit rsync synchronisieren will.
Es sei denn, jemand kennt eine andere Lösung, wie man die cygdrive-Syntax für rsync unter Windows modifizieren kann, damit mit UNC-Pfaden gearbeitet wird.

Allerdings müsste es doch für das o.g. Netzlaufwerks-Problem eine Lösung geben...
Hat jemand einen Tipp für mich?

Viele Grüße,
Andreas
Mitglied: 60730
12.01.2010 um 12:48 Uhr
Servus,

warum auch immer....
Aber so sollte sich das Problem lösen lassen.

01.
net use X: \\servername\freigabe 
02.
start  /wait "führe einen bestimmten Job aus" (rsync) 
03.
net use X: /delete 
04.
net use |find "\\servername\freigabe" && net use \\servername\freigabe /delete /yes
Gruß
Bitte warten ..
Mitglied: pgmende
13.01.2010 um 10:55 Uhr
Hallo TimoBeil,

hat leider auch nicht geklappt.
Da mir die Windows-Netzlaufwerk-Sache so unsicher erscheint, schaue ich mir zur Zeit robocopy an, das ja ziemlich hoch gelobt wird.
Der Vorteil, direkt mit UNC-Pfaden arbeiten zu können umgeht schon einige Probleme...
Trotzdem danke!
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Batch & Shell
NET USE LPT1 (4)

Frage von MiSt zum Thema Batch & Shell ...

Windows Installation
gelöst Custom-ISO mit integr. Treibern macht Probleme als VM, kann das sein, kennt das jemand? (2)

Frage von departure69 zum Thema Windows Installation ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...