Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

netzlaufwerke ein paar probleme

Frage Microsoft Windows Netzwerk

Mitglied: 55283

55283 (Level 1)

15.06.2008, aktualisiert 16.06.2008, 3478 Aufrufe, 4 Kommentare

Hallo,

Folgendes Problem: Ich habe verschiedene Netzwerke (Privates Netzwerk, Firma, usw.. bei jedem Netzwerk habe ich eine andere IP).
In jedem Netzwerk gibt es Netzlaufwerke die das Laufwerk "L" haben. Also unterschiedliche Namen, aber alle das Laufwerk L.

Ich will nun Netzlaufwerke der jeweiligen Netzwerke mit Mausklick abrufen.

im Heimnetz ist Laufwerk L = Name1
im ersten Firmennetzwerk ist Laufwerk L = Name2
im zweiten Firmennetzwerk ist Laufwerk L = Name3

und je nachdem, in welchem Netzwerk ich mich befinde, soll "L" mit dem entsprechenden Server / Freigabe verknüpft sein.

Wie ist das umzusetzen? Gibt es da eine extra Software oder muss ich das per Hand machen, wie kann ich das machen?

danke schonmal,

Gruß
Mitglied: n4426
15.06.2008 um 20:13 Uhr
Hi Bernie,

leg folgendes Script im Autostart-Ordner ab oder leg es dir auf den Desktop und führe es dann aus.

LaufwerkVerbinden.cmd
01.
net user L: /delet y 
02.
 
03.
if exist "\\HomeServer\HomeShare" goto Home 
04.
if exist "\\FirmenServer1\Firma1Share" goto Firma1 
05.
if exist "\\FirmenServer2\Firma2Share" goto Firma2 
06.
 
07.
 
08.
:Home 
09.
net use L: "\\HomeServer\HomeShare" 
10.
goto Ende 
11.
 
12.
:Firma1 
13.
net use L: "\\FirmenServer1\Firma1Share"  
14.
goto Ende 
15.
 
16.
:Firma2 
17.
net use L: "\\FirmenServer2\Firma2Share"  
18.
goto Ende 
19.
 
20.
 
21.
:Ende 
22.
exit
Sollte das machen, wass du haben willst.

mfg
andi
Bitte warten ..
Mitglied: bastla
15.06.2008 um 20:58 Uhr
... bzw etwas kürzer:
01.
@echo off & setlocal 
02.
net use L: /d>nul 2>nul 
03.
if exist "\\HomeServer\HomeShare" net use L: "\\HomeServer\HomeShare">nul 
04.
if exist "\\FirmenServer1\Firma1Share" net use L: "\\FirmenServer1\Firma1Share" >nul 
05.
if exist "\\FirmenServer2\Firma2Share" net use L: "\\FirmenServer2\Firma2Share">nul
Grüße
bastla
Bitte warten ..
Mitglied: funkmasta2k
15.06.2008 um 23:03 Uhr
Mach es doch per Batch.

Je nachdem in welchem Netz Du Dich befindest, wird auch das passende Laufwerk gemappt.
01.
@echo off 
02.
if exist L: net use P: /delete 
03.
 
04.
ping /n 1 <ip> | find /i "bytes=" && GOTO Heimnetz 
05.
ping /n 1 <ip> | find /i "bytes=" && GOTO Firmennetzwerk 
06.
ping /n 1 <ip> | find /i "bytes=" && GOTO Firmennetzwerk2 
07.
 
08.
GOTO :EOF 
09.
 
10.
:Heimnetz 
11.
net use L: \\Server\Freigabe 
12.
GOTO :EOF 
13.
 
14.
:Firmennetzwerk 
15.
net use L: \\Server\Freigabe 
16.
GOTO :EOF 
17.
 
18.
:Firmennetzwerk2 
19.
net use L: \\Server\Freigabe 
20.
GOTO :EOF

Müsste so eigenlich klappen.

EDIT: Ok, da war jemand schneller
Bitte warten ..
Mitglied: 55283
16.06.2008 um 14:31 Uhr
Danke für euere Hilfe ! Hat mir weitergeholfen, genauso in Batch wie ich es wollte
Bitte warten ..
Ähnliche Inhalte
Windows Server
Probleme mit Serververbindung (1)

Frage von Enriqe zum Thema Windows Server ...

Windows Server
Probleme mit Client Software Zugriff auf Windows Server 2012 (8)

Frage von it-kolli zum Thema Windows Server ...

Windows Update
Immer wieder Probleme mit WSUS (W10 u W2k16 ) (4)

Frage von Leo-le zum Thema Windows Update ...

Netzwerke
gelöst PfSense: Probleme mit Wirksamkeit von Rules (12)

Frage von Fenris14 zum Thema Netzwerke ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...