Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzlaufwerke (SBS 2008) erscheinen nicht immer im Arbeitsplatz der Workstation XP SP3)

Frage Microsoft Windows Server

Mitglied: rudiwaren

rudiwaren (Level 1) - Jetzt verbinden

17.11.2009, aktualisiert 14:03 Uhr, 7471 Aufrufe, 9 Kommentare

Ich betreue als Lehrer ein Netzwerk mit SBS2008 Server und XP SP3 Clients. Im Sommer sind wir von NT40 Server auf den SBS Server (mit Hilfe eines Mitarbeiters einer Firma) umgestiegen. Komplette Neuinstallation, keinerlei Migration. Alle Clients konnten sich an der NT4-Domäne anmelden. Netzlaufwerke waren im Arbeitsplatz sichtbar.

Nun das eigentliche Problem. Das persönliche Homedirectory H. wird über die Usereigenschaften zugewiesen. Andere Netzlaufwerke I, J, ...werden über ein Loginscript für Lehrer, Schüler, Plaetze etc. zugewiesen. Das Prinzip hat sich bewährt und funktioniert auf fast allen Clients. Nur manchmal werden die Netzlaufwerke I,J,.. nicht im Arbeitsplatz sichtbar. Dann kann ein Neustart helfen, manchmal ein zweiter oder auch gar nicht. Wenn man aber ein Programm nutzt z.B. Word, dann findet man die Netzlaufwerke sowohl bei 'Datei öffnen' als auch bei 'Speichern unter'. Das Laufwerk I ist ein sogenanntes Austauschlaufwerk. Die Lehrkräfte stellen über diese Laufwerk den Schülern vorbereitet Dateien zur Verfügung. Deshalb fehlen (vor allem bei den kleinen aus 5 und 6) diese Laufwerke wirklich.
In den Loginstripten protokollieren wir mit, wer sich wann wo angemeldet hat. Hier erscheinen alle Anmeldungen, auch dann, wenn die Netzlaufwerke nicht im Arbeitsplatz erscheinen. Diese Erscheinung scheint mit nicht vom Client abhängig zu sein.

Bin über jeden Tipp dankbar, denn der Mitarbeiter der Firma scheint aufgegeben zu haben.

Herzlichen Dank
Rüdiger
Mitglied: Jochem
17.11.2009 um 15:34 Uhr
Moin,
Du könntest mal überprüfen, ob die Laufwerke nur durch das Logon-Script zugeordnet werden, oder ob an den Problem-PCs die Laufwerke noch per "Beim Neustart wieder verbinden" zugeordnet werden. Evtl. "beißen" sich diese Einstellungen.

Gruß J chem
Bitte warten ..
Mitglied: rudiwaren
18.11.2009 um 07:56 Uhr
Hallo Jochem,
danke für den Hinweis. Ich fahre nachher in die Schule und prüfe das.
Gruß
Rüdiger
Bitte warten ..
Mitglied: rudiwaren
18.11.2009 um 16:14 Uhr
Hallo Jochem,
bin in der Schule. "Beim Neustart wieder verbinden" ist nicht eingestellt.
Gruß
Rdügier
Bitte warten ..
Mitglied: rudiwaren
18.11.2009 um 16:49 Uhr
Hallo Jochem,
Deine Vermutung stimmt doch. Unter Netzlaufwerk verbinden ist vor "Beim Neustart wieder verbinden" ein Haken. Der lässt sich nicht raussnehmen, der einzig aktive Butten ist "Abbrechen". Der Haken ist immer da, egal auf welchen Laufwerksbuchstaben ich gehe.

Immer noch ratlos
rudiwaren
Bitte warten ..
Mitglied: geTuemII
19.11.2009 um 11:01 Uhr
Hallo rudiwaren,

wenn du die Laufwerke über Loginscript verbindest, kannst du sie doch auch zuvor dort erstmal alle löschen: net use * /delete . Dadurch stellst du zunächst einen definierten Status (nämlich keine Netzlaufwerke verbunden) her.

--> Vorsicht mit dem net use /delete, falls du Drucker auf LP-Ports gemountet hast!

geTuemII
Bitte warten ..
Mitglied: rudiwaren
19.11.2009 um 12:50 Uhr
Hallo geTuemll,
die Loginscripte sind vbs-Scripte angelegt von einem Usermanager "Netadmin"

Ich schnippel mal einen Ausschnitt des Lehrerscripts mit rein:

' Netadmin Loginskript
' # erstellt am 27.07.2009 11:53:56
'

'Alle Objekte referenzieren
On error resume next
Set wshshell = CreateObject("WScript.Shell")
Set fs = CreateObject("Scripting.FileSystemObject")
Set wshNetwork = CreateObject("Wscript.Network")
Set ADSysInfo = CreateObject("ADSystemInfo")
Set winNTInfo = CreateObject("WinNTSystemInfo")

' NETZLAUFWERKE verbinden
' # -> Lokale Laufwerksbuchstaben werden mit Freigaben auf Server verknüpft
'

Computername = wshNetwork.Computername
Domainname = winNTInfo.DomainName
Username = winNTInfo.Username
'----> Verknüpfung auf H: \\FDSWSERVER\HomesLehrer ------------------------
'wshNetwork.RemoveNetworkDrive "H:"
'wshNetwork.MapNetworkDrive "H:", "\\FDSWSERVER\HomesLehrer"

'----> Verknüpfung auf I: \\FDSWSERVER\ASchueler --------------------------
wshNetwork.RemoveNetworkDrive "I:"
wshNetwork.MapNetworkDrive "I:", "\\FDSWSERVER\ASchueler"

'----> Verknüpfung auf J: \\FDSWSERVER\ALehrer ----------------------------
wshNetwork.RemoveNetworkDrive "J:"
wshNetwork.MapNetworkDrive "J:", "\\FDSWSERVER\ALehrer"

'----> Verknüpfung auf K: \\FDSWSERVER\HomesSchueler ----------------------
wshNetwork.RemoveNetworkDrive "K:"
wshNetwork.MapNetworkDrive "K:", "\\FDSWSERVER\HomesSchueler"

'----> Verknüpfung auf L: \\FDSWSERVER\APlaetze ---------------------------
wshNetwork.RemoveNetworkDrive "L:"
wshNetwork.MapNetworkDrive "L:", "\\FDSWSERVER\APlaetze"


' ----- Ende Netzlaufwerke verbinden -------------------------------------------------------------


Das Anlegen von H habe ich rausgeblockt, das das homedirectory ja über die Benutzereigenschaften angelegt wird.
Alle Netzlaufwerke (so habe ich das verstanden) werden ersteinmal gelöscht und dann neu angelegt.
VBS habe ich so nicht gewählt, kam über den Usermanager "Netadmin"
Bitte warten ..
Mitglied: geTuemII
19.11.2009 um 16:21 Uhr
Hallo rudiwaren,

hm, ich bätschle (Batch-Files) meine Loginsscripts noch immer.

Teste folgendes, wenn gerade niemand weiter am System anmeldet.

  1. Kommentiere wshNetwork.MapNetworkDrive "I:", "\\FDSWSERVER\ASchueler" aus und melde an. Nun dürfte das LW I:\ nicht mehr auf der Maschine vorhanden sein, auch dann nicht, wenn der Zugriff über ein Office-Programm versucht wird. Danach setzte die auskommentierte Zeile wieder aktiv. Welches Ergebnis?
  2. Aber ich würde doch mal testhalber die LW-Buchstaben hochsetzen, also z.B. Z:\ verwenden? Ändert das was?

Was machst du noch alles in dem Loginscript, was Batch nicht könnte?

geTuemII
Bitte warten ..
Mitglied: rudiwaren
19.11.2009 um 19:01 Uhr
Hallo geTuemll,
danke für Deine Geduld. Heute habe ich bei den wichtigsten Rechnern die Synchronisierung rausgenommen. Morgen fahre ich nach berlin zur GMK-Tagung, Montag ist flexibler Ferientag - keiner in der Schule - und nach meinem TÜV-Termin habe ich "freies Netz".
Da werde ich Deine Hinweise ausprobieren.

Ich mache nichts - was macht das Loginscript - generiert von dem Usermanager Netadmin - mit mir?
Auf jeden Fall könnte ich Drucker zuweise - geht meines Wissens auch mit batch und es wird protokolliert, wer wann sich an welchem PC anmeldet. Ob batch das auch kann - ich weiß es nicht.
Gruß
rudiwaren
Bitte warten ..
Mitglied: rudiwaren
09.12.2009 um 10:33 Uhr
Hallo geTuemII,
mich gibts noch. Klassenfahrtbegleitung und Grippe - jetzt bin ich wieder dran.
Ich habe Deine Hinweise probiert.
zu 1. auskommentiert, Laufwerk weg, Kommentierung raus; Laufwerk bei allen WS im Office-Programm, aber nicht bei allen im Arbeitsplatz.
zu 2. Z benutzt, gleiches Ergebniswie bei 1.

aufgegeben, Jetzt werde ich eine Verknüpfung "Netzlaufwerke anzeigen" ins Profil legen. Dann müssen die User, die die Netzlaufwerke im Arbeitzsplatz benötigen, halt mal draufklicken. Warum diese Aktion? Hangel ich mich über die Netzwerkumgebung zu den Loginscripts und führe sie erneut aus, dann sind die Laufwerk im Arbeitsplatz zu sehen.
Meine Überlegungen, im Loginscript das Loginscript erneut ausführen zu lassen, führen nur in die Endlosschleife.
Jetzt fällt mir noch ein, ich könnte das Mappen der Netzlaufwerke ja im Script zweimal ausführen lassen.

Gruß
rudiwaren
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...