Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzlaufwerke per Script verbinden und trennen klappt nicht mehr

Frage Microsoft

Mitglied: sventtke

sventtke (Level 1) - Jetzt verbinden

03.01.2011 um 18:30 Uhr, 6329 Aufrufe, 4 Kommentare

Ich arbeite seit einiger Zeit -auch dank diesen Forums- mit kleinen CMD-Scripten, um Netzlaufwerke zu verbinden oder zu trennen. Seit einiger Zeit funktioniert das jedoch nicht mehr so richtig, ohne das mir klar wäre, warum. Nun versuche ich, den Fehler zu finden.

Hallo,

ich verbinde/trenne Netzlaufwerke zuhause und auch in der Arbeit mittels kleiner CMD-Scripts, die wie folgt aussehen:

@echo Laufwerk trennen:
@echo -----------------
net use Z: /d /y

@echo Laufwerk verbinden:
@echo -------------------
net use Z: \\xxx.xxx.xxx.xxx\Ordnername /user:\Username Password

Teils werden auch direkt Dateien auf den Netzlaufwerken geöffnet, indem noch folgende Zeile nachgeschoben wird:

@echo MS Excel wird gestartet!
start Z:\"Ordnername\Exceldatei.xls"

Das hat über Monate einwandfrei funktioniert, jedoch seit einiger Zeit gibts Probleme. Oft passiert einfach gar nichts, auch eine Fehlermeldung taucht nicht auf. Ich habe keine Ahnung, weshalb das so ist, denn ich habe nichts verändert.

Eine Möglichkeit hatte ich darin gesehen, dass ich Passwörter in den Scripten nicht geändert hatte, aber der Effekt tritt auch bei Usern auf, deren Passwörter nie geändert worden sind.

Fällt irgendwem was dazu ein? Es war wirklich eine elegante und einfach Lösung, die ich gerne wieder hätte.

Ciao

Sventke
Mitglied: Pjordorf
03.01.2011 um 19:20 Uhr
Hallo,

Zitat von sventtke:
Das hat über Monate einwandfrei funktioniert, jedoch seit einiger Zeit gibts Probleme. Oft passiert einfach gar nichts, auch
eine Fehlermeldung taucht nicht auf.
Na. Irgend etwas muss ja passieren.

Ich habe keine Ahnung, weshalb das so ist, denn ich habe nichts verändert.
Ich wars auch nicht

Mach mal in deinen Skripten ein Rem vor deinem @echo off und füge einfach mal ein Pause am ende ein. Dann solltest du schon mal etwas sehen können. beispiel:
01.
REM @Echo Off 
02.
 
03.
@echo Laufwerk trennen: 
04.
@echo ----------------- 
05.
net use Z: /d /y 
06.
 
07.
@echo Laufwerk verbinden: 
08.
@echo ------------------- 
09.
net use Z: \\xxx.xxx.xxx.xxx\Ordnername /user:\Username Password 
10.
 
11.
 
12.
Pause 
13.
 
14.
 
15.
@echo MS Excel wird gestartet! 
16.
start Z:\"Ordnername\Exceldatei.xls"
Gruß,
Peter
Bitte warten ..
Mitglied: 60730
03.01.2011 um 22:04 Uhr
moin,

@Pjodorf:
meine Lieblingszeile mit dem Echo aus dem Off finde ich garnicht ....

@Sventke:
den Fred würde ich aber gerne mal sehen, wo du die Zeile gefunden hast - das macht man nur unter ganz bestimmten Umständen...

  • Ich kenne ja wirklich einige Wege zum Ziel, aber /user:\Username Password in Verbindung mit Net Use kann nie so gelaufen sein.
  • /user:domain\Username Password wäre eher passend - aber warum wird das mit dem festen User und dem festen Passwort überhaupt bei euch gemacht?

Ganz kleiner Tipp am Rande: - den @ Trick kennst du ja - nutzt Ihn aber nicht da, wo er in dem Fall stehen sollte....
01.
if exist z:\ net use Z: /d /y 
02.
@net use Z: \\xxx.xxx.xxx.xxx\Ordnername /user:domain\Username Password 
03.
if not exist z:\  echo fehler & pause 
Ich tippe bei der Konstellation drauf, dass das Passwort abgelaufen oder geändert wurde.
Mit einem
net user username passwort /domain
Kannst du das Passwort neu setzen....
Nicht nur deshalb, sondern auch und vor allem wegen dem Passwort - das im Klartext in der Batch steht - löst man das aber "so" nicht.

Gruß
Bitte warten ..
Mitglied: sventtke
06.01.2011 um 10:45 Uhr
Hi,

•Ich kenne ja wirklich einige Wege zum Ziel, aber /user:\Username Password in Verbindung mit Net Use kann nie so gelaufen sein.

Doch, es ist genau so gelaufen, und zwar über etwa 1,5 Jahre. Den Tip hatte ich übrigens auch hier aus dem Forum bekommen.

•/user:domain\Username Password wäre eher passend - aber warum wird das mit dem festen User und dem festen Passwort überhaupt bei euch gemacht?

Ein Grund ist, dass ich zu Hause auch mit dem Firmen-PC, der mit User und Passwort in einer Domäne hängt, arbeite. Bis vor ca. 5 Monaten wurde mein Domänenpasswort nie geändert, seither muss ich es aufgrund neuer IT-Regeln in der Firma wieder aller 6 Wochen ändern. Das war natürlich ein Grund, weshalb Scripts mit diesem User nicht mehr funktioniert haben.
Ich habe sämtliche PC's zuhause, die alle nur in einer Arbeitsgruppe organisiert sind, mit Userprofilen inkl. Passwort versehen und entsprechende Freigaben für die verschiedenen Ordner auf dem NAS eingerichtet. Damit sich jeder User einfach per Klick von jedem PC (auch dem nichteigenen) via Script anmelden verbinden kann, habe ich diese Lösung gewählt. Zugegeben, das Klartext-Passwort im Script ist nicht optimal, aber zumindest bei uns zu hause kein Problem, da keiner darauf käme, in der CMD rumzuwühlen.

Gibts denn eine elegantere Lösung?
Bitte warten ..
Mitglied: sventtke
06.01.2011 um 11:40 Uhr
Hi nochmal,

hab jetzt weitgehend deine Tips umgesetzt (@ für \"Verstecken\" des Passwortes während der Anzeige des DOS-Fensters, überprüfen des Laufwerksbuchstabens vor dem Trennen und nach dem Verbinden) und die Passwörter neu gesetzt. jetzt scheint wieder alles sauber zu laufen. Hier nochmal der Script-Wortlaut, wie er jetzt verwendet wird und funktioniert:

@echo Laufwerk trennen:
@echo -----------------
if exist X:\\ net use X: /d /y

@echo Laufwerk verbinden:
@echo -------------------
@354 use X: \"\\\\xxx.xxx.xxx.xxx\\Ordnername\" /user:\\Username Password
if not exist X:\\ echo fehler & pause

@echo BackUp starten:
@echo ---------------
if exist X:\\ start C:\\\"WINDOWS\\system32\\ntbackup.exe\"

Vielen Dank nochmal für die Tips! Falls dennoch jemand eine bessere Lösung hat, bin ich natürlich weiterhin offen dafür.

Ciao

Sven
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Windows Server
gelöst Rechner neu starten per Script via Aufgabenplanung klappt nicht (4)

Frage von MaxKlaus13 zum Thema Windows Server ...

Windows Server
gelöst Netzlaufwerke mit einer VPN Verbindung verbinden lassen (16)

Frage von M.Marz zum Thema Windows Server ...

VB for Applications
gelöst VB Netzlaufwerk trennen und mappen klappt nicht so richtig (21)

Frage von Dr.Cornwallis zum Thema VB for Applications ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...