Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

auf Netzwerk warten

Frage Microsoft

Mitglied: photographix

photographix (Level 1) - Jetzt verbinden

24.04.2009, aktualisiert 09:20 Uhr, 14662 Aufrufe, 6 Kommentare

Hallo Leute,

folgendes Problem stellt sich in meinem Netzwerk (ne Menge XP Pro's an einfacher Windows Freigabe. Kein DC, AD, etc. )

Ich habe als vorläufige Lösung bis unser Samba PDC steht eine Netzwerkfreigabe wo die AnmeldeScripte liegen.
Diese lasse ich per Autostart -> Batch und Kix zum Start des Rechners einlesen. Zu 80% klappt das auch bei allen Rechnern.

Bei den restlichen 20% fehlt bei der Abarbeitung des Scriptes einfach das Netzwerk (unten neben der Uhr). Dieses wird auch zuletzt erst aktiviert. Dann ist das Script aber schon gelaufen....
Über die GPO bzw den RegSchlüssel "SyncForegroundPolicy" habe ich schon ein warten auf das Netzwerk erzwungen.
01.
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\CurrentVersion\Winlogon] 
02.
"SyncForegroundPolicy"=dword:00000001
MIt GPUPDATE /force ziehe ich das auch jedesmal fest.

Leider ohne Erfolg.

Hat jemand eine Idee. Aktuell löse ich das über einen "häßlichen" Workaround und lass die Batch etwas warten.

LG
Mitglied: jhinrichs
24.04.2009 um 10:04 Uhr
Hallo,
versuche doch mal Folgendes:
Verteilung der IP-Adressen per DHCP (reservierte IPs), das hat einen ziemlich sicheren "Warten auf das Netzwerk-Effekt", die entsprechende GPO wartet m. W., bis der Netzwerkadapter bereit ist (also initialisiert+IP), aber nicht, bis eine Verbindung aufgebaut ist, was z.B. bei WLAN durchaus dauern kann. Bei DHCP kann der Netzwerkadapter aber erst eine IP haben, nachdem die Verbindung aufgebaut worden ist.
Bitte warten ..
Mitglied: photographix
24.04.2009 um 10:16 Uhr
Hallo jhinrichs,

danke für deinen Beitrag.
Ich vergebe aber bereits auf allen Rechnern per DHCP die Ip Adressen.
Das ist es also auch nicht. Das Problem ist eher das entweder die GPO nicht zieht (wie kann ich das sehen?)
Oder ein anderes Problem.
Bitte warten ..
Mitglied: TWAWLW
24.04.2009 um 10:41 Uhr
Hi,

hab da mit Roaming Profiles ein ähnliches Problem, da hat das geholfen:

Turn off the fast logon enhancement

With the fast logon enhancement in Windows XP when users change from a local to a roaming profile, it will take two logons on each machine for profile changes to be registered. This is because the user always logs on with cached credentials; therefore it takes one logon for the network to notice that the user has become roaming and the second logon to apply these settings.

To ensure the best possible experience, enable the setting Always wait for the network at computer startup and logon, located at Computer Configuration\Administrative Templates\System\Logon.

Viel Erfolg,
TWAWLW
Bitte warten ..
Mitglied: jhinrichs
24.04.2009 um 12:29 Uhr
Welche GPO angewendet wird, kannst Du mit

gpresult

auf der Kommandozeile sehen.

Ich glaube aber fast, dass es schneller geht, den Samba-PDC mit Domänen-Logon-Script einzurichten, als jetzt hier eine Fehlersuche zu betreiben....
Bitte warten ..
Mitglied: photographix
24.04.2009 um 12:30 Uhr
Hi

die GPO "Always wait for the network at computer startup and logon" ist in der Regitry schon mein Schlüssel "SyncForegroundPolicy"
Den scheibe ich schon auf den Client. Leider ohne Erfolg.
Bitte warten ..
Mitglied: photographix
25.04.2009 um 11:26 Uhr
Wo sehe ich ob die GPO angewendet wurde? Laut GPRESULT zieht oder geht da garnix.

01.
Betriebssystem Microsoft (R) Windows (R) XP Gruppenrichtlinienergebnis-Tool v2.0 
02.
Copyright (C) Microsoft Corp. 1981-2001 
03.
 
04.
Am 25.04.2009 um 11:21:09 erstellt 
05.
 
06.
 
07.
 
08.
RSOP-Ergebnisse fr xxx\yyy auf xxx : Protokollierungsmodus 
09.
-------------------------------------------------------------------------------- 
10.
 
11.
Betriebssystemtyp:                     Microsoft Windows XP Professional 
12.
Betriebssystemkonfiguration:            Eigenst„ndige Arbeitsstation 
13.
Betriebssystemversion:                  5.1.2600 
14.
Dom„nenname:                 OM-RETRIEVER1 
15.
Dom„nentyp:                 Nicht zutreffend<Lokaler Computer> 
16.
Standortname:                   Nicht zutreffend 
17.
Zwischengespeichertes Profil:              
18.
Lokales Profil:               C:\Dokumente und Einstellungen\yyy 
19.
Langsame Verbindung? Ja 
20.
 
21.
 
22.
COMPUTEREINSTELLUNGEN 
23.
---------------------- 
24.
     
25.
    Zeit der letzten Gruppenrichtlinienanwendung: 25.04.2009 at 10:29:43 
26.
    Gruppenrichtlinie wurde angewendet von: Nicht zutreffend 
27.
    Gruppenrichtlinienschwellenwert fr langsame Verbindung:   500 kbps 
28.
 
29.
    Angewendete Gruppenrichtlinienobjekte 
30.
    -------------------------------------- 
31.
        Nicht zutreffend 
32.
 
33.
    Die folgenden Gruppenrichtlinie werden nicht angewendet, da sie herausgefiltert wurden. 
34.
    ---------------------------------------------------------------------------------------- 
35.
        Richtlinien der lokalen Gruppe 
36.
            Filterung:  Nicht angewendet (Leer) 
37.
 
38.
    Der Computer ist Mitglied der folgenden Sicherheitsgruppen: 
39.
    ----------------------------------------------------------- 
40.
        Administratoren 
41.
        Jeder 
42.
        Authentifizierte Benutzer 
43.
         
44.
 
45.
BENUTZEREINSTELLUNGEN 
46.
---------------------- 
47.
     
48.
    Zeit der letzten Gruppenrichtlinienanwendung: 25.04.2009 at 10:36:43 
49.
    Gruppenrichtlinie wurde angewendet von: Nicht zutreffend 
50.
    Gruppenrichtlinienschwellenwert fr langsame Verbindung:   500 kbps 
51.
 
52.
    Angewendete Gruppenrichtlinienobjekte 
53.
    -------------------------------------- 
54.
        Nicht zutreffend 
55.
 
56.
    Die folgenden Gruppenrichtlinie werden nicht angewendet, da sie herausgefiltert wurden. 
57.
    ---------------------------------------------------------------------------------------- 
58.
        Richtlinien der lokalen Gruppe 
59.
            Filterung:  Nicht angewendet (Leer) 
60.
 
61.
    Der Benutzer ist Mitglied der folgenden Sicherheitsgruppen: 
62.
    ----------------------------------------------------------- 
63.
        Kein 
64.
        Jeder 
65.
        Hauptbenutzer 
66.
        Benutzer 
67.
        INTERAKTIV 
68.
        Authentifizierte Benutzer 
69.
        LOKAL 
70.
        
Bitte warten ..
Neuester Wissensbeitrag
Router & Routing

192.168er Adresse im öffentlichen Netz

(2)

Erfahrungsbericht von visco-c zum Thema Router & Routing ...

Ähnliche Inhalte
LAN, WAN, Wireless
Access Point (VLAN, Multi-SSID) legt Netzwerk lahm (8)

Frage von humbeldi zum Thema LAN, WAN, Wireless ...

Netzwerke
Netzwerk Neuaufbau, Switches, VoIP, WLAN - 2ter Versuch (12)

Frage von daBrain85 zum Thema Netzwerke ...

Server-Hardware
Netzwerk mit mehreren PoE-Switchen (7)

Frage von kluska zum Thema Server-Hardware ...

Heiß diskutierte Inhalte
Zusammenarbeit
Als Administrator im Großraumbüro (29)

Frage von Dopamin85 zum Thema Zusammenarbeit ...

Exchange Server
Test-ActiveSyncConnectivity Error nach neuem Zertifikat (22)

Frage von Driphex zum Thema Exchange Server ...

Hyper-V
HYPER V und USB (16)

Frage von Hendrik2586 zum Thema Hyper-V ...

SAN, NAS, DAS
Backupserver für KMU (14)

Frage von Leo-le zum Thema SAN, NAS, DAS ...