Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

NT4 DHCP: 1 Server, 2 Subnetze

Frage Netzwerke LAN, WAN, Wireless

Mitglied: swi69

swi69 (Level 1) - Jetzt verbinden

01.07.2004, aktualisiert 03.07.2004, 6983 Aufrufe, 6 Kommentare

Hallo,
ich habe folgendes Problem:

Ein LAN ist in 2 Subnetze unterteilt. Auf dem Router sind beide Netze konfiguriert.
Im Netz a steht ein NT4 Server mit DHCP und eingerichtetem Scope für Netz a.
Wenn ich nun einen Scope für Bereich b einrichte, holen sich die Clients, auch wenn ich
Scope a deaktiviere, keine Adresse aus dem Scope b.

Hat von euch jemand eine Idee ?

Noch eine Frage: Wonach richtet sich eigentlich die Vergabe der Adresse, ob aus Scope a oder b ?
Unterstellt wird ein ganz frisch installierter Client, der bisher noch keine Adresse hat.

Danke im voraus
Stephan
Mitglied: Koeber
01.07.2004 um 11:34 Uhr
Du brauchst entweder auf dem Router oder auf einem Server im 2. Subnetzt einen DHCP Relay Agent. Der setzt die Broadcasts die DHCP benutzt auf eine andere Adresse um so das sie von Router weitergeleitet werden können.
Bitte warten ..
Mitglied: swi69
01.07.2004 um 12:14 Uhr
Hallo und Danke für die schnelle Antwort, aber:

Auf dem Router ist DHCP/BOOTP-Relay enabled. Ich dachte, dass müsste doch
ausreichen, oder ?
Muß ich in den Scope-Optionen evtl. noch etwas einstellen ?
Ich habe für Scope a und Scope b die jeweilige Subnetz-Router-Adresse
angegeben....

Danke und Gruß
Stephan
Bitte warten ..
Mitglied: das-omen
01.07.2004 um 18:58 Uhr
Hi!

Also wenn der Router RFC 1542 kompertible ist dürftest du keinen Relay Agent brauchen.
Hast du schon mal einen Ping auf den DHCP proboert aus dem Subnetz b?

Zu deiner anderen Frage. Der Router trägt in das Paket zum DHCP die Adresse der Schnittstelle ein aus dem die Anfrage kommt. Daran erkennt der DHCP aus welchen Bereich er eine Lease vergeben muss.


Tschau

Das Omen
Bitte warten ..
Mitglied: swi69
02.07.2004 um 11:24 Uhr
Hallo,
ich habe gerade "neue" Infos bekommen:
Die beiden Subnetze sind als primary und secondary Adresse
auf dem Router konfiguriert. Also stelle ich mir jetzt vereinfacht
vor, dass der Traffic beider Netze physik. auf ein und dem selben
"Kabel" läuft. Interessiert mich da die Routerkonfig. überhaupt ?

Hilft das bei der Problemlösung ?

Was würde passieren, wenn ich
a) dem Server selbst die Adresse des neuen Subnetzes geben würde
b) evtl. sogar eine 2. NIC in den Server einbauen würde ?

Nochmals Danke

Stephan
Bitte warten ..
Mitglied: Koeber
02.07.2004 um 21:52 Uhr
Was würde passieren, wenn ich
a) dem Server selbst die Adresse des neuen Subnetzes geben würde

Dann würde die Traffic zum ersten Netz über den Router laufen.



b) evtl. sogar eine 2. NIC in den Server einbauen würde ?

Dann hättest du ein Gateway und bräuchtest keinen Router mehr. Dieses müsstest du es bei der DHCP Konfiguration als Bereichsoption angeben damit das geht.
Bitte warten ..
Mitglied: swi69
03.07.2004 um 00:13 Uhr
Hallo Olaf, Hallo "Omen",

vielen Dank für die Hilfe. Es hat endlich funktioniert, u.a. Dank der Infos von euch
Der Betreiber hat auf Drängen ( und mit den Infos ) die Konfig überprüft... angeblich war alles i.O., und plötzlich funktionierts

Vielen Dank und Gruß
Stephan
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung!

(1)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows Server
Dhcp auf Server 2012 R2 zeigt blaues Ausrufezeichen (7)

Frage von 116480 zum Thema Windows Server ...

Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

Batch & Shell
gelöst Powershell + dhcp auf einem 2012 R2 Server (5)

Frage von pixel0815 zum Thema Batch & Shell ...

Netzwerkmanagement
gelöst Ein Gerät, zwei DHCP Server oder mehr (16)

Frage von fuddel18 zum Thema Netzwerkmanagement ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (10)

Frage von 1410640014 zum Thema Backup ...