Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

NTLM über https mit IE 6 und 7 im Intranet funktioniert nicht

Frage Microsoft Windows Netzwerk

Mitglied: gnomito

gnomito (Level 1) - Jetzt verbinden

06.04.2009, aktualisiert 13:02 Uhr, 5102 Aufrufe, 2 Kommentare

Apache mit NTLM_AUTH und funktionierender AD Anbindung authentifiziert Firefox unter http und https. Bei IE 6 und 7 klappt's nur unter http.

Hallo zusammen,

ich wurschtel da jetzt schon seit Tagen dran rum. Vielleicht ist jemandem das Problem schonmal untergekommen und kann helfen:

Ich habe auf einem Apache 2.2.10 unter Suse 10.2 das Modul NTLM_Auth installiert. Die automatische Anmeldung (auch integrierte Windows-Authentifizierung genannt) klappt problemslos mit Internet Explorer 6 und 7 und Firefox im http Protokoll. Da aber der gesamte Verkehr zum Apache per ssl verschlüsselt werden soll, habe ich eben auf https umgeschaltet.

Damit kommt nur der Firefox klar. Bei IE 6 und 7 erscheint eine "Die Webseite kann nicht angezeigt werden." Meldung. Laut Apache log ist es wohl eher eine http 401 (Unauthorized) Meldung. Ansonsten gibt es keine Hinweise in irgendwelchen andern Logfiles. Alle Seiten lassen sich unter SSL ohne NTLM_AUTH aufrufen aber im IE eben nicht mit NTLM_AUTH.

Kann mir da jemand weiterhelfen? Ich komme jetzt leider nicht mehr alleine weiter.

Liebe Grüße
Gerd
Mitglied: filippg
07.04.2009 um 00:55 Uhr
Hallo,

bist du dir sicher, dass es nicht einfach ein Zertifikatsfehler ist? Wo hast du das Zertifikat her? Eigene CA? Dann füge doch mal deren CA der Liste der vertrauenswürdigen Stammzertifizierungsstellen hinzu.

Gruß

Filipp
Bitte warten ..
Mitglied: gnomito
07.04.2009 um 11:19 Uhr
Hallo Filipp,

vielen Dank für den Hinweis. Ich habe die gesamte SSL Konfiguration noch mal neu gemacht. Wie gesagt funktioniert der Aufruf von Seiten ohne NTLM einwandfrei. Das Zertifikat ist selbst erstellt und im Browser installiert. Sobald ich NTLM einschalte ist Schluss damit. Ich sehe ausser einem Fehler 401 im Apache error.log keinen Hinweis. Das Debug Log zeigt folgenden Output:

01.
[Tue Apr 07 11:06:28 2009] [info] 12835 - SMB_Connect_Server: server - srv03.meyer.com, domain - meyer.com 
02.
[Tue Apr 07 11:06:28 2009] [info] 12835 - SMB_Connect_Server: my name - INTRASRV 
03.
[Tue Apr 07 11:06:28 2009] [debug] mod_ntlm.c(95): 12835 - SMB_Connect_Server: address - srv03.meyer.com 
04.
[Tue Apr 07 11:06:28 2009] [debug] mod_ntlm.c(95): 12835 - RFCNB_Call: start 
05.
[Tue Apr 07 11:06:28 2009] [debug] mod_ntlm.c(95): 12835 - RFCNB_Call: Called_Name: SRV03 Service_Address: srv03.meyer.com 
06.
[Tue Apr 07 11:06:28 2009] [debug] mod_ntlm.c(95): 12835 - RFCNB_Call: Dest IP - 192.168.1.111, Port - 139 
07.
[Tue Apr 07 11:06:28 2009] [debug] mod_ntlm.c(95): 12835 - RFCNB_Call: After RFCNB_IP_Connect 15 
08.
[Tue Apr 07 11:06:28 2009] [debug] mod_ntlm.c(95): 12835 - SMB_Connect_Server: after RFCNB_Call con->Trans_Connect = 1 
09.
[Tue Apr 07 11:06:28 2009] [info] 12835 - NTLMXX-Clearing NTLM connection: 1669361152 id: 3 
10.
[Tue Apr 07 11:06:28 2009] [info] 12835 - SMB_Discon
Der Apache baut also schon eine Verbindung zum DC auf. Aber danach scheint nicht mehr viel zu passieren. Der Suse Rechner mit Apache ist Mitglied des AD, wird erkannt und über DNS korrekt aufgelöst.

Ich bin ohne Ideen.
Bitte warten ..
Ähnliche Inhalte
Microsoft
gelöst Lokale Intranet Site im IE wird nicht über GPO hinzugefügt (1)

Frage von Hanuta zum Thema Microsoft ...

Exchange Server
gelöst OWA funktioniert nur im IE (18)

Frage von ketanest112 zum Thema Exchange Server ...

SEO
Wie funktioniert eine HTTPS Verschlüsselung? (5)

Frage von Yanmai zum Thema SEO ...

Netzwerke
Wie erstelle ich ein Intranet (19)

Frage von Leonardnet zum Thema Netzwerke ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (33)

Frage von sabines zum Thema Internet ...

Netzwerke
Wie erstelle ich ein Intranet (19)

Frage von Leonardnet zum Thema Netzwerke ...

LAN, WAN, Wireless
gelöst Eintägige Netzwerkunterbrechung trotz Backupleitung (15)

Frage von iAmbricksta zum Thema LAN, WAN, Wireless ...

Netzwerke
VPN-Server einrichten PPTPD-Einrichtung gescheitert (14)

Frage von MIlexx zum Thema Netzwerke ...