Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

NVidia RAID Rebuild für S-ATA Platten

Frage Hardware Festplatten, SSD, Raid

Mitglied: bobo511

bobo511 (Level 1) - Jetzt verbinden

15.05.2008, aktualisiert 21.05.2008, 13099 Aufrufe, 4 Kommentare

Hallo Leute,

ich hab folgendes Problem mit einem Windows 2003 SBS Server.

Das System hat ein Mainboard von ASUS mit einem integrierten Nvidia RAID Controller (430).
und 2 Festplatten S-ATA (gleiches Modell) mit jeweils 250GB.

Nach einem Stromausfall hat das Bios scheinbar die Raid-Funktion auf "disabled" gestellt. Der Kunde
ist nur zufällig darauf gekommen, als er auf dem Server auf einmal 2 zusätzliche Partitionen F und G entdeckt hat.
Normalerweise hat die Array 2 Partitionen C (System) + D für die Daten.
Gebooted hat er also ganz normal von der 1. S-ATA Platte.

Erstmal hab ich im Bios die Raid-Funktion wieder auf enabled gestellt. Raid-Funktion war nach dem Bios (F10) auch wieder
sichtbar und hatte Status "Healthy". Nur startet dann das Betriebssystem nicht mehr, er findet keinen Boot-Sektor.
Im Raid-Tool (F10, Media-Shield) zeigt er an, dass das Array booted. (Boot - YES).

Also Raid im Bios wieder deaktiviert, das System booted normal, nur hab ich natürlich wieder 4 statt 2 Partitionen und nichts
ist gespiegelt.

Hab in einem anderen Beitrag gelesen, dass man vorsichtshalber die Partitionen der 2. Platte löschen sollte, falls es zu
Problemen kommt. Hab ich gemacht, auch keine neuen Partitionen auf der 2. Platte erstellt. Danach RAID wieder aktiviert,
rein ins Raid Tool, Rebuild gemacht. mit STRG+X beendet, Kiste startet neu, und findet wieder kein Betriebssystem.
Fehlermeldung "Insert Proper Boot Device etc.......", ich denke ihr wisst was ich meine.
Im Raid-Tool stand nach über einer Stunde immer noch der Status REBUILD (in dem Tool, was man nach dem BIOS mit F10 startet).
Hab das dann abgebrochen und RAID wieder deaktiviert, weil der Kunde ja seinen Server braucht, und das mitten in der Woche ziemlich
ärgerlich ist. Ist wieder normal hochgefahren und läuft problemlos, nur mein RAID funktioniert halt immer noch nicht.

Ich hatte das Problem vor einem halben Jahr schon mal, da hab ich dann übers WE per Acronis ein Image gezogen, das Array komplett gelöscht (Clear Disk Data) neu angelegt und per Acronis das Image zurückgesichert. Hat funktioniert, aber ich habe keine Lust das nochmal
zu machen, da dies sehr viel Zeit in Anspruch nimmt. Ausserdem kann doch das nicht Sinn einer Spiegelung sein. Die Platten sind einwandfrei, haben keine Fehler etc., habe ich überprüft.

Hat von Euch einer eine Idee, wie ich das lösen kann ? Es muss doch möglich sein einen Rebuild zu machen, und danach sofort das BS wieder zu starten oder ?

Ich sag schon mal danke für Euer schnellen Antworten !
Mitglied: Arch-Stanton
15.05.2008 um 18:08 Uhr
Moin,

normal ist das nicht. Wenn man ein Raid 1 deaktiviert, dürfte das System nicht starten. Du kommst um ein komplettes rebuild nicht herum. Das dauert einige Stunden. Wenn Du Dir und Deinem Kunden einen Gefallen tun möchtest, dann besorgst Du einen anständigen Raidcontroller (3Ware oder Intel) und deaktivierst den onboard Raidcontroller.

Gruß,
Arch Stanton

p.s. wenn man den rebuild-Vorgang nicht durchführt, dann startet man mit einer der Platen aus dem Raidverbund.
Bitte warten ..
Mitglied: bobo511
16.05.2008 um 09:42 Uhr
Hi Arch-Stanton,

das ist mir schon klar, dass ich einen kompletten Rebuild machen muss.
Nur ich hab das Problem, dass er eben diesen nicht macht.

Ich gehe wie folgt vor (aus der Datenträgerverwaltung weiss ich, dass die Stammplatte die S-ATA Platte mit der ID 0 ist).

Ich starte den Rechner gehe mit F10 ins RAID Tool, gehe auf REBUILD. Danach steht der Status des Arrays auf REBUILD. Danach raus aus dem Tool mit STRG+X, Rechner startet neu, und es kommt die Fehlermeldung "INSERT PROPER BOOT Device ....". Das heisst, er findet keine bootfähige Platte. Normalerweise müsste er doch starten und den Rebuild dann im Hintergrund machen wärend Server 2003 normal läuft oder ?

Sobald ich im Bios Raid wieder deaktiviere startet er ganz normal.
Hab auch schon probiert eine Platte auszustecken, danach kommt per RAID-Tool nach dem Bios die Meldung ARRAY DEGRATED und er findet ebenso die Bootsektoren nicht. Ich kann den Rechner nur booten wenn ich RAID deaktiviere. Wie um Himmels willen kann ich jetzt die Spiegelung wieder neu aufsetzen ohne eine komplette Installation bzw. Rücksicherung zu machen ?

Das ist mein eigentliches Problem.
Bitte warten ..
Mitglied: Arch-Stanton
16.05.2008 um 10:01 Uhr
Moin,

da kann ich Dir nicht weiter helfen. Dieses ist auch der Grund, weshalb ich nie! wieder onboard Raid verwenden werde. Hatte ähnliche Probleme und Stunden mit Rekonfiguration verbracht.

Gruß,
Arch Stanton
Bitte warten ..
Mitglied: bobo511
21.05.2008 um 11:27 Uhr
Hi,

trotzdem danke.
Ich werde jetzt an dem Server einen zusätzliche PCI-Ex Raid-Controller installieren (Hersteller Promise Fasttrak) + eine USV, dann ist hoffentlich Ruhe.

Das war mein letzter onboard-Controller.
Bitte warten ..
Ähnliche Inhalte
Festplatten, SSD, Raid
RAID Controller mit Festplatten in anderen Server verschieben (7)

Frage von vBurak zum Thema Festplatten, SSD, Raid ...

Festplatten, SSD, Raid
RAID 10 Systemfestplatte vom Board Controller oder vom Perc h310 Controller? (8)

Frage von babylon05 zum Thema Festplatten, SSD, Raid ...

Festplatten, SSD, Raid
gelöst Zusätzlicher Raid Controller, Server bootet nicht mehr (5)

Frage von thorti26 zum Thema Festplatten, SSD, Raid ...

Festplatten, SSD, Raid
gelöst RAID auf 8 Festplattten spiegeln (24)

Frage von akaEcki zum Thema Festplatten, SSD, Raid ...

Neue Wissensbeiträge
Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(2)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(5)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Viren und Trojaner

Neue Magazin Ausgabe: Malware und Angriffe abwehren

Information von Frank zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
Windows Systemdateien
Warum System auf "C:" (29)

Frage von DzumoPRO zum Thema Windows Systemdateien ...

LAN, WAN, Wireless
Cisco SG200: Auf bestimmtem vLAN bestimmte TCP-Ports sperren (19)

Frage von SarekHL zum Thema LAN, WAN, Wireless ...

Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Cloud-Dienste
gelöst Bitcoins minen über Nacht? (16)

Frage von 1410640014 zum Thema Cloud-Dienste ...