Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

OpenVPN - Kein Internet an Client

Frage Netzwerke Router & Routing

Mitglied: Piffelpoffel

Piffelpoffel (Level 1) - Jetzt verbinden

09.01.2008, aktualisiert 16.11.2008, 13614 Aufrufe, 2 Kommentare

VPN mit IMAP und Datenzugriff funtioniert - Internet am Client nicht

Hallo zusammen,

folgende Situation:
Ein bestehendes System OpenVPN 2.1-RC4 mit Zertifikaten.
Der OpenVPN-Server läuft auf Windows 2003 Server R2 und der OpenVPN-Client auf einer XP-Maschine.
Auf dem gleichen Windows-Server läuft ein E-Mail-Server der per IMAP seine Dienste bereitstellt.
Sowohl der Server als auch der Client haben feste IPs und den gleichen Gateway sowie den gleichen DNS-Server-Eintrag (192.168.1.1) da bei in der Regel im gleichen Netz arbeiten.

Für den Fall, dass der Client (Laptop) von außerhalb auf den Server zugreifen muß wurde OpenVPN installiert. Direkt hat der Zugriff auf die einzelnen Dateien auf dem Server funktioniert. Mit der Funktion <route INTERNE IP DES E-MAIL-SERVERS> funktioniert nun auch der Zugriff auf IMAP.

Einziges Problem, wenn sich der Client mit OpenVPN verbindet hat er kein Internet mehr.
Meine Versuche auf der Serverseite (server.ovpn) mit:
<push "redirect-gateway">
oder
<push "dhcp-option [DNS des ISP]">
oder
<push "dhcp-option [DNS des Internet-Routers]">

haben nicht gebracht. Was mache ich falsch? Muß ich irgendwie die OpenVPN-Server-IP (10.8.0.1) auf den Gateway biegen? Ich bin echt am verzeifeln.

Danke und herzliche Grüße aus Chile
Piffelpoffel
Mitglied: cssoft
16.11.2008 um 12:48 Uhr
Hi,

hab genau das gleiche Problem, als ich es endlich mit den Zertifikaten gebacken bekommen habe, ist jetzt kein Internet mehr möglich wenn VPN läuft (auf Clientseite).

Auf dem Server geht alles einwandfrei.
Bitte warten ..
Mitglied: cssoft
22.12.2008 um 00:47 Uhr
Hi

falls es euch interessiert ich habs zum laufen bekommen, hab OpenVPN jetzt schon Wochen in Betrieb mit ca. 5 Clients.

push redirect gateway aus der Serverconfig auskommentieren (oder weglassen),
ebenso push dhcp und dns

und beim Client die Router zum Heimatnetz (Server physikalisches Netz) auskommentieren... voilá

Bsp bei mir:

Server:
#push "dhcp-option DNS 192.168.1.1"
#push "redirect-gateway def1"

Client:
#route 192.168.1.0 255.255.255.0 vpn_gateway 3
Bitte warten ..
Ähnliche Inhalte
Router & Routing
gelöst PFsense - Netzverbindung steht, aber kein Internet vorhanden (45)

Frage von aschmid zum Thema Router & Routing ...

Notebook & Zubehör
gelöst Notebook Verbindung zum Router geht, aber kein Internet (7)

Frage von Headhunter4711 zum Thema Notebook & Zubehör ...

Router & Routing
gelöst Speedport 5501 kein Internet verfügbar (2)

Frage von supertux zum Thema Router & Routing ...

Switche und Hubs
HP 2530 24 Switch J9782A kein Internet an den VLANs (11)

Frage von kasimir82 zum Thema Switche und Hubs ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Windows Systemdateien
NTFS und die Defragmentierung (26)

Frage von WinLiCLI zum Thema Windows Systemdateien ...

LAN, WAN, Wireless
Zwei Subnetze mit je eigenem Router und Internetzugang verbinden (18)

Frage von hannsgmaulwurf zum Thema LAN, WAN, Wireless ...

Windows Server
WIndows Server 2016 core auf dem Intel NUC NUC5i5RYK i5 5250U (17)

Frage von IxxZett zum Thema Windows Server ...