Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

OpenVPN Server auf Debian und Windows 7 Clienten

Frage Linux Debian

Mitglied: AKillerInHell

AKillerInHell (Level 1) - Jetzt verbinden

01.06.2011, aktualisiert 18.10.2012, 7695 Aufrufe, 5 Kommentare

Mitarbeiter sollen per OpenVPN mit dem Netzwerk verbunden werden. Mitarbeiter benutzen Windows 7 als Client-OS und sollten wenn möglich über ein pre-shared-passwort sich anmelden.

Hallo leute,
wie bereits in dem Vorwort erwähnt, möchte ich gerne das sich die Mitarbeiter per OpenVPN auf das Netzwerk anmeldet. Ich benutze Debian 6 in einer Virtuellen Umgebung und habe OpenVPN soweit eingerichtet.

Da ich absoluter Linux neuling bin und mich per OpenVPN Tutorials und Google über die konfiguration schlau gemacht habe, bin ich zwar bis zum (eigentlichen) Ende der config gekommen, kann mich auch per interner und externer IP verbinden, jedoch fehlen mir noch einige Sachen.

Ich stoße auf folgende Probleme:
- Sobald ich mich verbinde (Windows Client) fragt er mich nach einer Authentifizierung. Eigentlich habe ich ein Pre-Shared-Key konfiguriert, er fragt mich allerdings nicht nach. Wie kann ich den Server in die Windows Domäne einfügen oder eine Datei mit den erforderlichen Informationen erstellen, damit der Client diese OVPN Datei einfügen kann?

- Ich habe bisher keine Netzwerkdaten bzw. keinen DHCP Server bei der Konfiguration angegeben. Ich habe nur die normalen Interface Daten aktualisiert, reicht das?

- Kann man den bei der VPN Verbindung die Computer in der Netzwerkumgebung/Netzwerkerkennung sehen?


Das wars erstmal, ich bedanke mich schon mal für alle helfenden Antworten ;)

Gruß AKIH
Mitglied: Clijsters
02.06.2011 um 00:00 Uhr
Hallo,

Die Abfrage der Daten hängt, wenn ich mich nicht irre mit der Zeile auth-user-pass zusammen.

- Ich habe bisher keine Netzwerkdaten bzw. keinen DHCP Server bei der Konfiguration angegeben. Ich habe nur die normalen Interface Daten aktualisiert, reicht das?
Ja, die IPs bestimmen die VPN-Configs.

Wenn das Routing stimmt, sollte auch das gehen.

Hoffe, das kann man als helfende Antwort zählen

Bitte und Gruß
Dominique
Bitte warten ..
Mitglied: aqui
02.06.2011, aktualisiert 18.10.2012
Einen wasserdichen Leitfaden für OpenVPN Laien findest du hier:
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Die Konfiguration ist vollkommen identisch auf einem Linix Server, da OpenVPn überall gleich ist. Du kannst also eins zu eins abschreiben.
Mit dem Leitfaden solltest du es also problemlos hinbekommen. Beachte bitte auch die Hinweise zur IP Adressierung am Schluss damit du nicht mit falscher IP Wahl Schiffbruch erleidest im VPN.
Zudem kann man dir nur zwingend raten mit Zertifikaten zu arbeiten wie auch im Tutorial empfohlen. Preshared Passwörter haben einen entscheidenden Nachteil. Wenn jemand das verrät oder aus der Firma ausscheidet musst du alles neu machen. Bei Zertifikaten löschst du nur das des Mitarbeiters und gut iss. Zudem sind sie Plattform bezogen und können nicht einfach getauscht werden.
Solltest du drüber nachdenken, denn der Aufwand diese zu erzeugen ist nicht größer wohl aber der Sicherheitsgewinn !

Generell macht es Sinn einmal drüber nachzudenken das VPN statt auf dem Server auf einem Router zu betreiben, da du damit dann komplett unabhängig vom Server und dessen Verfügbarkeit bist mit dem VPN.
Zudem steht der Server meist immer hinter einem NAT (Network Adress Translation) Router was dann ein Port Forwarding erzwingt. OK für OpenVPN als SSL VPN kein Problem, da es nur um Port UDP 1194 (Default) geht aber oft Quell von Fehlern.
All das entfällt wenn man es Router basierend installiert. Vom komfortablen GUI zur Konfiguration mal ganz abgesehen.
Auch die Domain Integration behandelt das Tutorial ausführlich:
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Der Rest mit der Windows Client Client Konfig von:
http://openvpn.se/
Ist dann eher simpler Standard und ist auch im o.a. Tutorial beschrieben.
Bitte warten ..
Mitglied: AKillerInHell
02.06.2011 um 23:26 Uhr
Hallo ihr beiden, also danke erstmal. Beide antworten haben mir geholfen.

Jetzt noch zu Aqui einiges:

Ich benutze folgenden Clienten http://openvpn.net/index.php?option=com_content&id=357
Ich habe die Anleitung bis zum erstellen der Zertifikate befolgt wobei ich jetzt ein Problem mit der Verbindung habe. Habe die Zertifikate auf dem Client kopiert und habe diese in die Clienten Software eingefügt. Jetzt meldet er mir immer folgende Fehlermeldung:

OpenVPNClient start openvpn_ca_p7418: process started and then immediately exited: []

Ich denke mal weil das CA keine IP kennt. Oder habe ich das falsche Zertifikat eingebaut.
Ich möchte am liebsten meinen OpenVPN Server in die Windows Domäne einfügen, damit die Anmeldung darüber verläuft.
Wobei mich die verwendung von Zertifikaten schon etwas reizt ;)
Bitte warten ..
Mitglied: aqui
03.06.2011 um 11:42 Uhr
Eigentlich kann man ja nix falsch machen wenn man obiges Tutorial Schritt für Schritt befolgt. Auch die folgenden Threads sollte man lesen, da sie auch das Transferieren der Zertifikate auf Server und Client beinhaltet.
Worauf du achten musst ist das die Verzeichnisse in den Konfig Dateien sauber auf die Zertifikatsverzeichnisse zeigen müssen.
Falls du die Zertifikate unter Windows erzeugst verwende immer WinSCP um sie zwischen den Maschinen zu transferieren ebenso wenn du sie unter Linux erzeugst und die Client Zertifikate kopieren musst.
Damit klappt das kinderleicht. Starte OpenVPN manuell erstmal dann kannst du anhand der Fehler sehen wo es kneift. In der Regel sind das zu 95% fehlende oder falsche Verzeichniseintrage in der Konfig datei und/oder fehlerhaft erzeugte Zertifikate !
Für das CA ist eine IP Adresse vollkommen irrelevant. Die Tunnel IP Adresse des Servers steht nur in der Client config Datei..mehr nicht !
Kontrolliere das also nochmal ganz genau !!

Dein erster Schritt ist eine saubere und fehlerfreie VPN Umgebung hinzubekommen. Wenn das der Fall ist und du alle remoten Geräte erreichen kannst per Ping, dann machst du dich an die Domain Integration, die ist auch recht einfach unter OpenVPN wie dir das o.a. Tutorial ja auch beschreibt !
Bitte warten ..
Mitglied: AKillerInHell
08.06.2011 um 23:10 Uhr
Danke, habs jetzt dank der Anleitung von Aqui hinbekommen, musste nur noch mal alles von Anfang an machen.

Die Domain Integration ist gar nicht mehr notwendig. Funktioniert auch so super.


Danke noch mal ;)

Liebe Grüße
AKIH
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Router & Routing
Routing Windows OpenVPN Server mit Teltonika RUT500 als Client (1)

Frage von ahenngee zum Thema Router & Routing ...

Firewall
gelöst Proxy Server für Windows (4)

Frage von It-ogut zum Thema Firewall ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (13)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...