Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

OWA - Javascript Fehler

Frage Microsoft Exchange Server

Mitglied: corecode

corecode (Level 1) - Jetzt verbinden

10.08.2006, aktualisiert 07.09.2006, 7337 Aufrufe, 2 Kommentare

Javascript fehler beim Versenden von Nachrichten

Hallo Forum!

Ich habe ein massives Problem mit OWA und hoffe hier meine Antworten zu finden.

Szenario:
Internet -> Reverse Proxy -> MS Exchange 2003 SP2 (OWA) -> Active Directory

Exchange und Outlook funktionieren soweit 1a! Basic Modus funktioniert auch.


Allerdings beim Connect via Premium-Mode bekomme ich bei manchen Seiten javascript errors.

Einen kaputten IE kann ich ausschließen, da das Problem bei allen getesteten Rechnern auftritt. Beim Erstellen einer neuen Nachricht bekomme ich beim "Senden" sofort ein Popup mit dem Inhalt "Unknown". Klick ich 3-4 mal auf "Senden" wird die e-Mail gesendet.

OWA verwendet offensichtlich ActiveX elemente. Brauchen diese eigene ports? Welche ports müssen sonst geroutet werden?

Das System befindet sich auf dem aktuellsten Stand per Dato.


Wie hier im Forum beschrieben, habe ich auch den Bug mit den komprimierten IIS Temp Files ausschließen können.


Hoffe um baldige, weiterführende Tipps und bedanke mich schon vorab.


Liebe Grüße,
2C/AW
Mitglied: Yoshi-GP
17.08.2006 um 07:45 Uhr
Hallo corecode,

ich habe seit einer Woche an einer Maschine ein ähnliches Problem. Der Basic-Modus des OWA funktioniert problemlos. Im Premium-Modus erfolgen JavaScript-Fehler beim Abmelden, beim Antworten auf Mails sowie beim Löschen. Beim Öffnen von Mails durch Doppelklick wird im neuen Fenster das komplette Frameset des OWA neu geladen.

Gibt`s eventuell schon Lösungsansätze?

Gruss Jan
Bitte warten ..
Mitglied: shub
07.09.2006 um 16:33 Uhr
Hi Gruppe,

habe exakt das gleiche Problem:
Client per ssl -> suse linux 10.0 ssl reverse proxy -> Exchange 2003 Std+SP1

OWA funktioniert einwandfrei, bis auf das Versenden von Mails.
Beim ersten Klick auf "Senden" geht eine IE6.0 Fehlermeldung auf: "Unknown"
Nach klick auf OK und erneutem Versenden der Mail geht diese raus und wird verschickt.
Mit dem Opera Browser 9.0 kommt diese Fehlermeldung NICHT.
OWA Versendet für den Versand http Protokol1.1.
Im Script des OWAs werden im http Protokoll folgende Befehle wärend der Arbeit mit OWA benötigt:

General Maximum headers length is 32768.
Allow any payload length is selected.
Maximum URL length is 260.
Maximum query length is 4096.
Verify normalization is selected.
Block high bit characters is not selected.
Methods Select Allow only specified methods, and specify:
GET
POST
PROPFIND
PROPPATCH
BPROPPATCH
MKCOL
DELETE
BDELETE
BCOPY
MOVE
SUBSCRIBE
BMOVE
POLL
SEARCH
Extensions Select Block specified extensions (allow all others), and specify:
.exe
.bat
.cmd
.com
.htw
.ida
.idq
.htr
.idc
.shtm
.shtml
.stm
.printer
.ini
.log
.pol
.dat
Headers No changes from the default.
Signatures
(Request URL) Select Block content containing these signatures, and specify:
./
\
%
&


Der IE6.0 hat da so seine Probleme, wenn alle SSL Anfragen über ein Linux Derivat weitergeleitet werden.

Mit einem ISA Server 2004 funktioniert übrigens alles fehlerfrei egal mit welchem Browser.

client per ssl -> isa server 2004 per ssl Witerleitung-> exchange 2003 per ssl

Es ist wie immer, MS hält sich NICHT an die definierten RFC´s und packt wieder alles in den Header was geht

Wo genau das Problem liegt habe ich bis jetzt auch noch nicht gefunden.
Ist in meinem Fall aber eindeutig ein Kommunikationsproblem zw. Windowswelt SSL und Linuxwelt SSL.

Workaround: Nutze den Opera Browser!

mfg

shub
Bitte warten ..
Ähnliche Inhalte
JavaScript
Javascript sendet jede Sekunde einen Fehler
gelöst Frage von vServerJavaScript9 Kommentare

Hallo, warum sendet mir der Javascript jede Sekunde einen Fehler, was ist daran falsch?

Firewall
OWA Fehler 412 bei der Skripterstellung
Frage von xbast1xFirewall4 Kommentare

Hallo zusammen, unsere SOPHOS UTM hat im OWA die o.g. Meldung verursacht wenn man in die Optionen bzw. den ...

Exchange Server
Exchange 2010 OWA - Adressbuch fehler
gelöst Frage von lupoloExchange Server3 Kommentare

Hallo, habe auf meinem Exchange Server 2010. Des Öfteren geht unser Adressbuch im Outlook und auf dem OWA nicht. ...

Apache Server
JavaScript wird nicht ausgeführt
Frage von schneerunzelApache Server

Hallo zusammen ich wollte gerade das Tool open3A installieren. Dabei bekomme ich einen Fehler die Dateien sind alle mit ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 19 StundenWindows 102 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 21 StundenSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 1 TagInternet3 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 1 TagDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
TK-Netze & Geräte
VPN-fähige IP-Telefone
Frage von the-buccaneerTK-Netze & Geräte16 Kommentare

Hi! Weiss noch jemand ein VPN-fähiges IP-Telefon mit dem man z.B. einen Heimarbeitsplatz gesichert anbinden könnte? Habe nur einen ...

Windows Server
GPO nur für bestimmte Computer
Frage von Leo-leWindows Server13 Kommentare

Hallo Forum, gern würde ich ein Robocopy script per Bat an eine GPO hängen. Wichtig wäre aber dort der ...

Windows Server
KMS Facts for Client configuration
Frage von winlinWindows Server13 Kommentare

Hey Leute, wir haben in unserem Netz nun einen neuen KMS Server. Haben Bestands-VMs die noch nicht aktiviert sind. ...

Windows Tools
Software-Tool zum Entfernen von bösartigem Windows
Frage von emeriksWindows Tools11 Kommentare

Hi, siehe Betreff hat das jemals irgendjemand schonmal sinnvoll eingesetzt? (MRT) E.