Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Owncloud unter Server 2008 - iis 7 installieren

Frage Microsoft Windows Server

Mitglied: Xaero1982

Xaero1982 (Level 4) - Jetzt verbinden

26.02.2014 um 19:38 Uhr, 3269 Aufrufe, 9 Kommentare

Hallo Zusammen,

ich versuche gerade owncloud auf einem W2k8 Server mit ii7 zu installieren.

Mysql ist installiert und läuft
php ist ebenfalls installiert und läuft

Beim Aufruf bekomme ich:
01.
HTTP-Fehler 500.0 - Internal Server Error 
02.
Die Seite kann aufgrund eines internen Serverfehlers nicht angezeigt werden. 
03.
 
04.
Ausführliche FehlerinformationenModul	FastCgiModule 
05.
Benachrichtigung ExecuteRequestHandler 
06.
Handler	PHP_via_FastCGI 
07.
Fehlercode	0x00000000 
08.
Angeforderte URL	http://192.168.xxx.xxx:8000/index.php 
09.
Physikalischer Pfad	C:\inetpub\xxxxx\index.php 
10.
Anmeldemethode	 Negotiate 
11.
Angemeldeter Benutzer	servername\administrator
Nun hab ich schon diverse Seiten durchforstet und versucht, aber nichts hilft.

  • Berechtigungen stimmen
  • FastCGI ist installiert
  • CGI und ISAPI sind installiert
  • config.php von Owncloud ist angepasst mit dbname,pw,user - installed ist true
usw.

Noch jemand eine Idee wie ich das beheben kann?

Gruß
Mitglied: wiesi200
26.02.2014 um 19:43 Uhr
Hallo,
Teste mal bitte ob php überhaupt verarbeitet wird.
Ich sag das etwas mit FastCGI nicht stimmt nach der fehlermeldung
Bitte warten ..
Mitglied: Xaero1982
26.02.2014, aktualisiert um 19:58 Uhr
Hi wiesi,

deswegen schrieb ich ja:

01.
php ist ebenfalls installiert und läuft
Es läuft bereits joomla auf dem Server und das ohne Probleme.

Gruß
edit:

01.
System 	Windows NT XXXXXXX 6.0 build 6002 (Windows Server 2008 Enterprise Edition Service Pack 2) i586  
02.
Build Date 	Dec 10 2013 22:04:40  
03.
Compiler 	MSVC9 (Visual C++ 2008)  
04.
Architecture 	x86  
05.
Configure Command 	cscript /nologo configure.js "--enable-snapshot-build" "--enable-debug-pack" "--disable-zts" "--disable-isapi" "--disable-nsapi" "--without-mssql" "--without-pdo-mssql" "--without-pi3web" "--with-pdo-oci=C:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8=C:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8-11g=C:\php-sdk\oracle\instantclient11\sdk,shared" "--with-enchant=shared" "--enable-object-out-dir=../obj/" "--enable-com-dotnet=shared" "--with-mcrypt=static" "--disable-static-analyze"  
06.
Server API 	CGI/FastCGI  
07.
Virtual Directory Support 	disabled  
08.
Configuration File (php.ini) Path 	C:\Windows  
09.
Loaded Configuration File 	C:\Program Files\PHP\php.ini  
10.
Scan this dir for additional .ini files 	(none)  
11.
Additional .ini files parsed 	(none)  
12.
PHP API 	20090626  
13.
PHP Extension 	20090626  
14.
Zend Extension 	220090626  
15.
Zend Extension Build 	API220090626,NTS,VC9  
16.
PHP Extension Build 	API20090626,NTS,VC9  
17.
Debug Build 	no  
18.
Thread Safety 	disabled  
19.
Zend Memory Manager 	enabled  
20.
Zend Multibyte Support 	disabled  
21.
IPv6 Support 	enabled  
22.
Registered PHP Streams 	php, file, glob, data, http, ftp, zip, compress.zlib, https, ftps, phar  
23.
Registered Stream Socket Transports 	tcp, udp, ssl, sslv3, sslv2, tls  
24.
Registered Stream Filters 	convert.iconv.*, mcrypt.*, mdecrypt.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, zlib.*
edit2: php läuft auch in dem virtuellen Verzeichnis in dem owncloud läuft.
Bitte warten ..
Mitglied: aqui
26.02.2014, aktualisiert um 20:18 Uhr
Setze eine Textdatei in das Verzeichnis mit dem Inhalt
<?php 
phpinfo(); 
?> 
und ruf die im Browser auf dann weisst du ob PHP dort sicher rennt.
"interner Serverfehler" hört sich nicht wirklich gesund an....
Bitte warten ..
Mitglied: Xaero1982
26.02.2014 um 20:36 Uhr
*hust*

was meinste denn woher ich diese infos habe aus dem Post davor?

PHP rennt zu 1000%. Wie bereits gesagt: joomla läuft. Auch im virtuellen Verzeichnis läuft PHP.

Also weitere Ideen?

Gruß
Bitte warten ..
Mitglied: sk-it83
27.02.2014 um 08:17 Uhr
Ich betreibe owncloud unter Linux kann dir da leider nicht weiterhelfen.

Ich gehe zwar von aus das du ne Anleitung verwendet hast, aber vllt. hilft dir ja dieses Tutorial
bei der Fehlersuche:


http://forum.owncloud.org/viewtopic.php?t=2370
Bitte warten ..
Mitglied: Xaero1982
27.02.2014 um 08:52 Uhr
Inzwischen hab ich es über den Webinstaller zum Laufen bekommen.


Danke

Gruß
Bitte warten ..
Mitglied: aqui
27.02.2014 um 09:59 Uhr
Mit Linux als OS und dem Apachen wär das auch gar nicht nicht erst passiert.....
"Linux is like a Wigwam: No Windows, no Gates, Apache inside..."
Bitte warten ..
Mitglied: Xaero1982
27.02.2014 um 12:25 Uhr
Nu ja ich hab hier nen windows server laufen über den dann auch die ad nutzeranbindung läuft. ..also von daher nix linux...

Gruß
Bitte warten ..
Mitglied: sk-it83
27.02.2014 um 13:11 Uhr
Naja ob das ein Argument ist sei mal dahingestellt. Die Nutzeranbindung unter Linux klappt auch wunderbar mit LDAP.
Bitte warten ..
Ähnliche Inhalte
SAN, NAS, DAS
OwnCloud auf Synology DS415+ installieren
gelöst Frage von konstantin90SAN, NAS, DAS5 Kommentare

Hallo zusammen, ich habe ein Problem und zwar ownCloud auf meiner DS415+ zu installieren. Ich habe es schon versucht ...

Tipps & Tricks
Windows Server 2008 R2 IIS 7 härten
Frage von pencilTipps & Tricks4 Kommentare

Guten Tag Ich möchte zwei IIS Server härten. Anbei habe ich eine kleine Liste mit Möglichkeiten. Da diese Liste ...

Apache Server
Raspberry Pi 3 Owncloud installieren
gelöst Frage von bestelittApache Server4 Kommentare

Hallo zusammen! Ich habe vor mir einen Dropboxersatz zusammenzustellen, also habe ich mir ein RPi3 und eine WD PiDrive ...

Hosting & Housing
Owncloud 7 externer FTP Storage
Frage von fisi90Hosting & Housing

Hallo Miteinander, habe ein kleines Problem mit Owncloud. Bei verschienenen Benutzern wurde ein externer FTP Speicher eingerichtet, was soweit ...

Neue Wissensbeiträge
Linux

Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde

Information von Frank vor 5 StundenLinux12 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 1 TagBatch & Shell9 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Humor (lol)

"gimme gimme gimme": Automatischer Test stolpert über Easter Egg im man-Tool

Information von Penny.Cilin vor 1 TagHumor (lol)6 Kommentare

Interessant, was man so alles als Easter Egg implementiert. Ist schon wieder Ostern? "gimme gimme gimme": Automatischer Test stolpert ...

MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 2 TagenMikroTik RouterOS8 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Heiß diskutierte Inhalte
Router & Routing
Zwei Netzwerke erstellen
Frage von bunteblumeRouter & Routing14 Kommentare

Hallo Zusammen, Ich möchte gerne ein backup von einem bestimmten Folder welcher auf dem Server regelmässig synchronisiert wird auf ...

Off Topic
Fachkräftemangel in Deutschland? - Talentschmiede schreibt alle 2 Tage die gleichen Stellen aus
Frage von Penny.CilinOff Topic12 Kommentare

Hallo, haben wir in Deutschland Fachkräftemangel? Die Talentschmiede schreibt gefühlt alle zwei Tage dieselben Stellen aus. Und das schon ...

Linux
Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde
Information von FrankLinux12 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Windows 10
Alle Programme mit bestimmtem Namen automatisch (per GPO) deinstallieren
gelöst Frage von lordofremixesWindows 1012 Kommentare

Hallo zusammen, gibt es eine Möglichkeit, alle Programme beginnend mit z.B. "Dell" im Namen per Script und somit per ...