Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Permanente hohe Auslastung Windows Server 2003 R2

Frage Microsoft Windows Server

Mitglied: digisec

digisec (Level 1) - Jetzt verbinden

29.04.2010 um 15:16 Uhr, 3828 Aufrufe, 4 Kommentare

Hallo,

unser Windows 2003 R2 Server ist unter Xen virtualisiert. Über den TS arbeiten etwa 6 Leute gleichzeitig.
Und nun nach etwa 1Jahr Laufzeit haben wir ein Problem.
Seit etwa 2 Monaten ist der Load der Maschine immer mal wieder sehr hoch.
Mit dem Tool von sysinternals - processExplorer konnte ich sehen dass es die HArdware-Interrupts sind.
Diese lassen dann auch das gesamte System immer mal wieder fast zum Stillstand kommen. Nichts geht mehr und viele
Ich hatte mit kernrate geschaut welche Events dort am häufigsten auftauchen, aber auch die Deaktivierung von "intelppm.sys"brachte keinen Erfolg.

Virus haben wir nicht auf dem Rechner <- geprüft.
Treiber sind geprüft und alles unnötige hab ich gelöscht.
Alle nutzlosen Geräte sind deaktiviert oder gelöscht.

Eines habe ich allerdfings festgestellt. Wenn sich der Administrator via RDC anmeldet, steigt der Load nach 5min. auf unerträgliche 40-50% Das gibt sich auch erst wieder, wenn sich der Benutzer abmeldet.

Die Benutzer die Citrix nutzen verursachen das Problem nicht.
Hat jemand eine Idee was man da noch in der RDC Verbindung abschalten kann oder einstellen, dass das nicht mehr vorkommt.

Gruß
digisec
Mitglied: SamvanRatt
29.04.2010 um 16:34 Uhr
Hi
ich kenne das Problem aus anderen Fällen, aber nicht virtualisiert. Es ist ein Treiber (VGA, IDE, SCSI, SYSCALL, PORTCALL, ...) der massenweise IRQ's (keine INT's) produziert und dann verrückt spielt. Schön zu sehen ist das genau ein Kern auf Volllast steht (bzw dank Loadbalancing sich auf mehrere verteilt). Der Intelppm ist der Intel Proz Treiber; sofern du Intels VT nutzt passt der schon. Eine Reparaturinst hat da nichts geholfen. Ich würde die Virtualisierung testweise (Image und dann auf reale Hardware) asuflösen um den Fehler detailierter suchen zu können. Im ESX gäbe es als Hilfe die einzelnen Subtasks zu sehen was sie gerade machen; da müsste man den Übeltäter schneller haben.
Gruß
Sam
Bitte warten ..
Mitglied: digisec
17.11.2010 um 11:48 Uhr
Also das folgende hatte ich nach Monaten Suchererei gefunden!

http://southbrain.com/south/2009/08/xen-drivers-for-windows-2003-m.html

Das hat meine Probleme entlich behoben. Alle anderen Lösungsvorschläge waren nutzlos.
Wir haben das erfolgreich bei 3 Windows2003 Servern eingesetzt.

Danke an den Programmierer.

Gruß
digiSec
Bitte warten ..
Mitglied: SamvanRatt
17.11.2010 um 11:57 Uhr
Hi
dann hätte doch das Problem mit meinem Vorschlag sie testweise auf eine echte Hardware rüber zu bringen vorbei sein müssen; das es an den Treibern lag war ja schon meine Analyse...
Gruß
Sam
Bitte warten ..
Mitglied: digisec
17.11.2010 um 12:15 Uhr
Hallo Sam,
ja das was du wolltest mit dem Ausproblieren am Live-System auf echter Hardware ging leider nicht. Das System wurde produktiv genutzt.
Aber danke trotzdem der Hinweise. Es funktionieren eben leider nur diese Treiber. Alle anderen Treiber anderer Hersteller oder Programmierer gehen einfach nicht.
Echt alles probiert.
Gruß
digiSec
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...