Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

PIX 506 Und Port-Forwarding

Frage Netzwerke Router & Routing

Mitglied: Fschwab

Fschwab (Level 1) - Jetzt verbinden

09.05.2007, aktualisiert 10.05.2007, 3683 Aufrufe, 1 Kommentar

Hallo zusammen,


habe die letzten stunden mit der Konfiguration der PIX 506 verbracht! Internetzugang und VPN-Zugriff von aussen funktionieren auch.

Ich will jedoch nen Web-Server und nen Mail-Server auf 2 interne Server durchschleifen. Beim Versuch das mim Web-Server hinzukriegen scheitert es jedoch! Der Webserver ist nicht über die öffentliche IP erreichbar (von einem anderen Anschluss aus). Vielleicht entdeckt ja einer einen Fehler in meiner Konfig. Habe schon diverse tut's durch und weiss einfach nicht mehr weiter!

Ahja: Es ist ja nicht möglich sich per VPN einzuloggen über das outside interface und den restlichen Internetverkehr wieder über das outside-interface zu routen! ISt es aber möglich sich per vpn über das inside interface einzuloggen und dann den rest per outside zu routen?! Gibts da tut's!? Ich will nämlich die internen WLAN-Client's sich noch authentifizieren lassen....


Hier meine Config:

pix# show config
Saved
Written by enable_15 at 02:32:11.197 UTC Wed May 9 2007
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxxxxxxxxxxxxxxxx
passwd xxxxxxxxxxxxxxxxxxxxxxxx
hostname pix
domain-name heisenberg.local
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list tuegvpn_splitTunnelAcl permit ip 192.168.1.0 255.255.255.0 any
access-list inside_outbound_nat0_acl permit ip any 192.168.1.192 255.255.255.192
access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.192 255.255.255.192
access-list outside_inbound_nat0_acl permit ip any 192.168.1.192 255.255.255.192
access-list inside_cryptomap_dyn_20 permit ip any 192.168.1.192 255.255.255.192
access-list outside_access_in permit tcp any any eq www
pager lines 24
mtu outside 1456
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.1.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN 192.168.1.200-192.168.1.230
pdm location 217.86.169.39 255.255.255.255 outside
pdm location 192.168.1.14 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (outside) 0 access-list outside_inbound_nat0_acl outside
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface www 192.168.1.14 www netmask 255.255.255.255 0 0
static (outside,inside) 192.168.1.14 217.86.169.39 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 65534 set peer 192.168.1.254
crypto dynamic-map outside_dyn_map 65534 set transform-set ESP-3DES-MD5
crypto dynamic-map inside_dyn_map 20 match address inside_cryptomap_dyn_20
crypto dynamic-map inside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic inside_dyn_map
crypto map inside_map interface inside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup tuegvpn address-pool VPN
vpngroup tuegvpn dns-server 192.168.1.14
vpngroup tuegvpn default-domain heisenberg.local
vpngroup tuegvpn split-tunnel tuegvpn_splitTunnelAcl
vpngroup tuegvpn pfs
vpngroup tuegvpn idle-time 1800
vpngroup tuegvpn password
vpngroup test address-pool VPN
vpngroup test dns-server 192.168.1.14
vpngroup test default-domain heisenberg.local
vpngroup test idle-time 1800
vpngroup test password
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname xxxxxxxxxxxxxxx
vpdn group pppoe_group ppp authentication pap
vpdn username xxxxxxxxxxxxxxx password
dhcpd address 192.168.1.100-192.168.1.102 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
username xxxxxxxx password xxxxxxxxxxxxxxx encrypted privilege 15
terminal width 80
Cryptochecksum:c7efc870c74da88e3e64351e5b3c2f24
Mitglied: Rafiki
10.05.2007 um 11:38 Uhr
http://www.administrator.de/PIX_506_Und_Port-Forwarding.html

Cisco sagt im config guide, Abschnitt: Enabling Server Access with Static NAT
http://www.cisco.com/en/US/docs/security/pix/pix63/configuration/guide/ ...

static (inside, outside) 209.165.201.12 10.1.1.3 netmask 255.255.255.255 0 0
access-list acl_out permit tcp any host 209.165.201.12 eq www
access-group acl_out in interface outside

Deine Konfig: (Auszug)

static (outside,inside) 192.168.1.14 217.86.169.39 netmask 255.255.255.255 0 0
access-list outside_access_in permit tcp any any eq www
access-group outside_access_in in interface outside
Ich persönlich schreibe static Anweisungen immer inside,outside sonst bekomme ich später einen Drehwurm, funktionieren solle es aber. Deine access-list outside_access_in erlaubt von jedem (any) zu jedem PC in deinem Netzwerk die Verbindung, aber wie sollte das NAT dazu passen?
Vergleiche das mit dem Beispiel von Cisco und berichtige:
access-list acl_out permit tcp any host 217.86.169.39 eq www

access-list outside_inbound_nat0_acl permit ip any 192.168.1.192 255.255.255.192
nat (outside) 0 access-list outside_inbound_nat0_acl outside
Denn Sinn der outside_inbound_nat0_acl verstehe ich nicht, kann auch an mir liegen. Wenn du dir nicht sicher bist warum diese Zeilen da sind, lösche sie bitte.

Gruß Rafiki
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Router & Routing
Routing und Port Forwarding für FTP-Transfer (2)

Frage von steff911 zum Thema Router & Routing ...

Firewall
gelöst Wie richte ich Port Forwarding auf der Sonicwall ein? (7)

Frage von Azubine zum Thema Firewall ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...