Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Postfix mit Dovecot - IMAP - IMAPS - Probleme mit SSL 993, keine bei TLS 143

Frage Linux Linux Netzwerk

Mitglied: matibaer

matibaer (Level 1) - Jetzt verbinden

01.06.2011 um 10:05 Uhr, 8394 Aufrufe, 1 Kommentar

Dovecot ist ein prima Mailserver. Starttls ist ein super Protokoll. Viele Clients können aber noch nicht SSL via STARTTLS auf Port 143. Klassisches SSL über Port 993 ist gefragt. Gut wäre es, wenn es genauso perfekt funktionieren würde.

In der Firma habe ich einen neuen Mailserver aufgesetzt.
So nach und nach ziehe ich die User dort hinüber.

Diesen Vorgang habe ich arg verlangsamt, weil ich auf Probleme gestoßen bin.

Die Leute, die Outlook 2010, Thunderbird und/oder iPhones einsetzen, die kann ich problemlos umziehen lassen.
Alle diese Clients bieten TLS bzw. STARTTLS über Port 143 an.

Outlook 2007 ohne Patches oder noch ältere Versionen bieten nur SSL über Port 993 an (bei IMAP mit Verschlüsselung).

OK, habe ich POP3S und IMAP3S halt auch aktiviert.

Erst viel mir nichts besonderes auf.
Die Clients, die mit 100-1000 MBit/s angebunden sind und noch nichts besonderes in der neuen Mailstruktur hatten, täglich mehrmals synchronisieren usw, die liefen ausreichend gut.
Erste Auffälligkeiten waren, dass häufiger die Verbindung unterbrochen wurde - Outlook neu gestartet werden musste.
Sehr große Unterschiede, die bei einer Synchronisation ausgeglichen werden mussten, funktionierten nicht immer. Time-Outs waren möglich.
Aber wie gesagt, fast verkraftbar bei sehr schnellen und stabilen Verbindungen.

Je langsamer oder schlechter die Verbindung, desto mehr häuft sich das, bis hin zu nicht-Verwendbarkeit.
Da fängt Outlook an, die IMAP-Ordner (und somit auch den Eingang) zu synchronisieren und irgendwann zwischen 10 und 90% bricht er ab (keine Verbindung zum Server).
Es bleibt spontan stehen und dann rührt sich nichts mehr - mal sehr früh, mal recht spät.

Manchmal empfangen die Clients dann ein paar E-Mails, oder nur die Kopfzeilen, selten vielleicht alle, manchmal auch nichts.

Ist das ein Client, der auch STARTTLS auf 143 sprechen kann, stelle ich ihn um und spontan sind alle Probleme weg!
Schnell, wirklich zügig und stabil wird alles synchronisiert.
Nur leider kann das die Mehrzahl der Clients hier nicht.

Das gleiche auf dem iPhone. Dieses erkennt automatisch SSL auf Port 993 und aktiviert es.
Dann gibt es massive Probleme. Ich ändere dann dort den Port auf 143 (gibt ja sonst nur SSL AN/AUS) und alles ist perfekt!

Nur selten finde ich was brauchbares in den Logs.

In ein paar Fällen, wo es besonders schwierig ist, finde ich folgende Logs (manuell Teile mit x ausgetauscht) :
May 31 15:54:32 mailx dovecot: imap-login: Login: user=<michaelx>, method=PLAIN, rip=87.183.96.x, lip=10.16.3.x, mpid=16247, TLS
May 31 15:54:33 mailx dovecot: imap-login: Disconnected (no auth attempts): rip=92.72.111.x, lip=10.16.3.x, TLS handshaking: SSL_accept() syscall failed: Connection reset by peer
May 31 15:54:33 mailx dovecot: imap-login: Login: user=<michaelx>, method=PLAIN, rip=87.183.96.x, lip=10.16.3.x, mpid=16250, TLS
May 31 15:54:39 mailx dovecot: imap(michaelx): Disconnected: Logged out bytes=927/1761
May 31 15:54:39 mailx dovecot: imap(michaelx): Disconnected: Logged out bytes=81/729
May 31 15:54:39 mailx dovecot: imap(michaelx): Disconnected: Logged out bytes=641/8476
May 31 15:54:39 mailx dovecot: imap(michaelx): Disconnected: Logged out bytes=90/792
May 31 15:54:39 mailx dovecot: imap(michaelx): Disconnected: Logged out bytes=66/631
May 31 15:54:44 mailx dovecot: imap(qax): Disconnected: Logged out bytes=336/1132
May 31 15:54:44 mailx dovecot: imap(qax): Disconnected: Logged out bytes=203/1698
May 31 15:54:46 mailx dovecot: imap(christianx): Disconnected: Disconnected in IDLE bytes=11/316
May 31 15:54:52 mailx dovecot: imap-login: Disconnected (no auth attempts): rip=92.72.111.x, lip=10.16.3.x, TLS handshaking: SSL_accept() syscall failed: Connection reset by peer


Mail-AV ist auch bereits ausgeschaltet.
Mitglied: matibaer
01.06.2011 um 17:36 Uhr
Ich habe die Lösung gefunden.

Schuld war die Firewall.
Ich habe IMAP und IMAPS in einer Regel zusammengefasst und in dieser Regel auch das Sicherheitsfeature "Application" (Application-Layer) aktiviert und IMAP als Anwendung ausgewählt.
Während IMAP mit STARTTLS anfänglich ja noch als normales IMAP auftritt, wird beim klassischen IMAPS (SSL) von vorne herein verschlüsselt.
So wird die Firewall davon nichts mitbekommen und es passt einfach nicht.
Ich habe dann einfach die Regel in zwei (IMAP + IMAPS) gesplittet und für IMAPS dieses Feature weggelassen.

Alle Test verliefen seither erfolgreich.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
E-Mail
Postfix + Dovecot mehrere Domains erhalten keine Mail

Frage von redShanks zum Thema E-Mail ...

Vmware
SSL TLS Fehler Veeam VMware (3)

Information von hagerino zum Thema Vmware ...

Apache Server
gelöst Probleme mit Apache2 und SSL bzw getssl (1)

Frage von Henere zum Thema Apache Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...