Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit AVM C4

Frage Netzwerke ISDN & Analoganschlüsse

Mitglied: mschulz

mschulz (Level 1) - Jetzt verbinden

26.09.2007, aktualisiert 12:43 Uhr, 8079 Aufrufe, 2 Kommentare

Wir bauen in unserer Firma gerade einen Asterisk-Server auf. Der wird gerade aber immer uninteressanter - während nämlich die Software selbst wunderbar läuft und intern ihre Gespräche vermittelt, gibt uns die Verbindung zur Außenwelt Rätsel auf...

Es handelt sich, der Titel sagt's, um eine AVM C4, die direkt am Anlagenanschluss hängt. Sobald eine Verbindung aufgebaut werden soll bekommen wir einen "protocol error layer 2"

Laut AVM Support ist die Karte korrekt für den Anschluss konfiguriert - was bei der doch recht übersichtlichen conf-File nicht wirklich schwer ist. ;)

Wir haben schon allmöglichen Kram probiert. Vom Wechseln der Kabel bis hin zum Wechsel des Betriebssystems - bis jetzt ohne sichtbaren Erfolg.

Hat jemand eine Idee, woran das liegen könnte? Idealer Weise direkt mit Lösungsansatz?

Der Vollständigkeit halber noch die capi.conf und der Output einer Testverbindung per pppd:

/etc/capi.conf
card file proto io irq mem cardnr options
c4 c4.bin DSS1 - - - - P2P
c4 - DSS1 - - - - P2P
c4 - DSS1 - - - - P2P
c4 - DSS1 - - - - P2P

Output von pppd
ast-pbx:/etc/asterisk # pppd call isdn/avm usepeerdns
Plugin userpass.so loaded.
userpass: $Revision: 1.5 $
Plugin capiplugin.so loaded.
capiplugin: $Revision: 1.36 $
capiconn: 1.13
capiplugin: phase serialconn.
capiplugin: contr=1
capiplugin: contr=1
capiplugin: contr=1
capiplugin: contr=1
controller 1: listen_change_state 0 -> 1
controller 1: listen_change_state state=1 event=1 ????
controller 1: listen_change_state state=1 event=1 ????
controller 1: listen_change_state state=1 event=1 ????
contr 1: listenconf Info=0x0000 (No additional information) infomask=0x144 cipmask=0x0 capimask2=0x0
controller 1: listen_change_state 1 -> 0
plci_change_state:0x0 0 -> 1 event=1
capiplugin: dialing 03039984330 (hdlc)
contr 1: listenconf Info=0x0000 (No additional information) infomask=0x144 cipmask=0x0 capimask2=0x0
controller 1: listen_change_state state=0 event=3 ????
contr 1: listenconf Info=0x0000 (No additional information) infomask=0x144 cipmask=0x0 capimask2=0x0
controller 1: listen_change_state state=0 event=3 ????
contr 1: listenconf Info=0x0000 (No additional information) infomask=0x144 cipmask=0x0 capimask2=0x0
controller 1: listen_change_state state=0 event=3 ????
plci_change_state:0x101 1 -> 2 event=3
DISCONNECT_IND reason 0x3302 (Protocol error layer 2) for plci 0x101
plci_change_state:0x101 2 -> 8 event=9
plci_change_state:0x101 8 -> 0 event=11
capiplugin: disconnect(remote): "" -> "03039984330" outgoing (pcli=0x101/ncci=0x0) 0x3302 (0x0000) - Protocol error layer 2
plci_change_state:0x0 0 -> 1 event=1
capiplugin: dialing 03039984330 (hdlc)
plci_change_state:0x101 1 -> 2 event=3
DISCONNECT_IND reason 0x3302 (Protocol error layer 2) for plci 0x101
plci_change_state:0x101 2 -> 8 event=9
plci_change_state:0x101 8 -> 0 event=11
capiplugin: disconnect(remote): "" -> "03039984330" outgoing (pcli=0x101/ncci=0x0) 0x3302 (0x0000) - Protocol error layer 2
plci_change_state:0x0 0 -> 1 event=1
capiplugin: dialing 03039984330 (hdlc)
plci_change_state:0x101 1 -> 2 event=3
DISCONNECT_IND reason 0x3302 (Protocol error layer 2) for plci 0x101
plci_change_state:0x101 2 -> 8 event=9
plci_change_state:0x101 8 -> 0 event=11
capiplugin: disconnect(remote): "" -> "03039984330" outgoing (pcli=0x101/ncci=0x0) 0x3302 (0x0000) - Protocol error layer 2
plci_change_state:0x0 0 -> 1 event=1
capiplugin: dialing 03039984330 (hdlc)
plci_change_state:0x101 1 -> 2 event=3
DISCONNECT_IND reason 0x3302 (Protocol error layer 2) for plci 0x101
plci_change_state:0x101 2 -> 8 event=9
plci_change_state:0x101 8 -> 0 event=11
capiplugin: disconnect(remote): "" -> "03039984330" outgoing (pcli=0x101/ncci=0x0) 0x3302 (0x0000) - Protocol error layer 2
capiplugin: couldn't make connection after 4 retries
controller 1: listen_change_state 0 -> 1
controller 1: listen_change_state state=1 event=1 ????
controller 1: listen_change_state state=1 event=1 ????
controller 1: listen_change_state state=1 event=1 ????
contr 1: listenconf Info=0x0000 (No additional information) infomask=0x144 cipmask=0x0 capimask2=0x0
controller 1: listen_change_state 1 -> 0
capiplugin: exit
Mitglied: simsons
26.09.2007 um 11:34 Uhr
Abschlusswiderstände in der ISDN Leitung sollen manchmal Wunder wirken.

test it
Bitte warten ..
Mitglied: mschulz
26.09.2007 um 12:43 Uhr
Danke für die Antwort. Leider ist das aber eindeutig nicht der Fehler.

Edit am 01.10.2007:
Das Problem wurde erkannt. Nur eine Kleinigkeit, die außer Acht gelassen wurde...
Unser Anschluss verteilt sich auf 3 NTBAs. Und natürlich sollte man, alle 3 von der alten Telefonanlage abklemmen, um die neue zu testen...
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows 10
Problem: einzige Konto gesperrt + Bitlocker aktiv (11)

Frage von Windows11 zum Thema Windows 10 ...

Exchange Server
Problem mit POP3-Abruf eines Exchange-2013-Postfachs

Frage von YotYot zum Thema Exchange Server ...

Sicherheitsgrundlagen
Reicht die Firewall des AVM 7390? (8)

Frage von Biriel zum Thema Sicherheitsgrundlagen ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...