Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem beim Einbinden einer crypto-LUKS-Partition am Cubietruck (Arch Linux, aes-xts-plain64 cipher)

Frage Hardware SAN, NAS, DAS

Mitglied: Rookie-Doo

Rookie-Doo (Level 1) - Jetzt verbinden

15.10.2014 um 17:43 Uhr, 1615 Aufrufe

Hallo zusammen,

ich möchte eine 3TB-Festplatte an einem Cubietruck betreiben, welcher unter ArkOS läuft (ein Derivat von Arch Linux). Die Festplatte wurde mittels dm-crypt unter einem 64Bit-System mit Linux Mint partitioniert (in (1TB/1TB/Rest) und verschlüsselt.

Die Aufruf von lsblk zeigt mir am Cubietruck die Partitionen:

sda 8:0 0 2.7T 0 disk
├─sda1 8:1 0 953.7G 0 part
├─sda2 8:2 0 953.7G 0 part
└─sda3 8:3 0 887.2G 0 part


Beim versuch, zB sda3 einzubinden mittels...

cryptsetup open /dev/sda3 <NamePartition3>

...erhalte ich folgenden Fehler:

Enter passphrase for /dev/sda3:
device-mapper: reload ioctl on failed: No such file or directory
Failed to setup dm-crypt key mapping for device /dev/sda3.
Check that kernel supports aes-xts-plain64 cipher (check syslog for more info).

Hatjemand irgendeine Idee, woran das liegen könnte? Der Cubie ist ja kein 64Bit-System, könnte das zu Probleme führen, da ich die 3TB-HDD ursprünglich unter einem 64Bit-System formatiert und verschlüsselt hatte?

uname -a liefter auf dem Cubie:

Linux Cubietruck 3.4.90-4-ARCH #1 SMP PREEMPT Sat Jun 14 14:27:01 MDT 2014 armv7l GNU/Linux

Vielen Dank im Voraus
rkd

PS: Ich habe schon in verschiedenen Linux-Foren gefragt, bisher keine oder keine wirklich weiterführenden Antworten erhalten.
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows 10
Windows 10 Anniversary Update zerstört Linux Partition (6)

Frage von klaraF zum Thema Windows 10 ...

Ubuntu
gelöst Linux neu erstellte vhd einbinden (2)

Frage von ClepToManix zum Thema Ubuntu ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...