Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit geplantem Task auf Windows 2000 server

Frage Microsoft Windows Server

Mitglied: kerfte

kerfte (Level 1) - Jetzt verbinden

10.11.2010 um 07:54 Uhr, 2443 Aufrufe, 6 Kommentare

Task wird ausgeführt, allerdings keine Daten kopiert

Hallo liebe Admins,
ich versuche auf Windows 2000 server per task nachts Daten zu kopieren. Ich habe eine batch Datei geschrieben welche ansagt von wo nach wo kopiert werden soll. Diese lasse ich dann per task ausführen.
Die Datei wird auch gestartet alledings kopiert er die Daten nicht. Führe ich die batch Datei aber manuell aus funktioniert alles prima.
In der batch Datei lasse ich auch ein logfile anlegen um zu sehen was er kopiert hat etc.. Dort steht bloß 0 File(s) copied.

Warum will er nicht kopieren? Ich hoffe jemand weiss Rat :P

VG
Mitglied: user132
10.11.2010 um 08:59 Uhr
Versuch mal die Batch-Datei in .cmd umzubennen und natürlich auch im task die angaben ändern..
Gruß
Bitte warten ..
Mitglied: kerfte
10.11.2010 um 09:05 Uhr
Danke erstmal für die Antwort!
Die Datei ist schon mit .cmd benannt. Die Datei wird auch per task angesprochen! Sonst würde ich ja keine logfile bekommen. Er will das nur nicht kopieren...
Bitte warten ..
Mitglied: Jochem
10.11.2010 um 09:13 Uhr
Moin,
schau Dir mal die Berechtigungen der Batch-Datei an. Ich vermute, daß der Batch-Job keine Rechte für den Zugriff auf die Verzeichnisse bzw. die darin enthaltenen Dateien hat. Unter welchem Konto läßt Du die Batch-Datei laufen?

Gruß J chem
Bitte warten ..
Mitglied: kerfte
10.11.2010 um 12:40 Uhr
Hi Jochem,
daran hat es zum Teil auch gelegen! Danke für den input

Was ich anschliessend noch verändern musste war ein Teil des scripts. Ich hatte den Zielordner einfach per Netzlaufwerk angebunden und im Script einfach \"G:\" angegeben. Das wollte der task wohl nicht. Hab dann "\\servername\verzeichnis\" eingetragen und schon ging es.
Komischerweise hat das Script, wenn ich es direkt ausgeführt habe, auch funktioniert! Auch mit "G:\".

Da soll mal jemand draus Schlau werden! Naja, Hauptsache es läuft!


Vielen Dank an alle hier!

VG
Bitte warten ..
Mitglied: BigWim
10.11.2010 um 13:02 Uhr
Komischerweise hat das Script, wenn ich es direkt ausgeführt habe, auch funktioniert! Auch mit "G:\".

Das kann nur laufen, wenn das Laufwerk zuvor gemappt wurde. Über den Explorer gibt es die Einstellung "Wiederherstellung bei Anmeldung". Dann passiert das automatisch und Dir steht immer das G: zur Verfügung.

Markus
Bitte warten ..
Mitglied: kerfte
10.11.2010 um 13:22 Uhr
Hey Markus,
ich habe das Laufwerk ja gemappt. Zwar nicht mit der Einstellung "Wiederherstellung bei Anmeldung" aber ich habe es direkt vor dem Test erst angebunden also hatte er normalen Zugriff.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Server
gelöst Etwas schräges Problem im TCPIP (Windows Server) (8)

Frage von emeriks zum Thema Windows Server ...

Windows Server
Windows Nano Server 2016 Domain Join

Link von Mvinogradac zum Thema Windows Server ...

Windows Server
Installation Windows Nano Server für Hyper-V

Link von Mvinogradac zum Thema Windows Server ...

Heiß diskutierte Inhalte
Linux
gelöst Boot failed: not a bootable disk (10)

Frage von Fleckmen zum Thema Linux ...

Multimedia & Zubehör
gelöst Iphone 6 prob (8)

Frage von jensgebken zum Thema Multimedia & Zubehör ...

Windows Installation
Eine etwas (wirklich) speziellere Frage: Windows 10-Installation über (8)

Frage von DerFurrer zum Thema Windows Installation ...

Windows Server
Probleme mit Client Software Zugriff auf Windows Server 2012 (8)

Frage von it-kolli zum Thema Windows Server ...