Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit Joomla Template - Darstellung Kategorie Blog

Frage Entwicklung PHP

Mitglied: killtec

killtec (Level 3) - Jetzt verbinden

07.11.2013 um 20:53 Uhr, 1934 Aufrufe

Guten Abend zusammen,
ich habe ein Problem mti der Darstellung eines Kategorieblogs in einem Joomlatemplate.
Es sieht so aus (Bildausschnitt):
2d255fcfcfbfce7c54d7eef1b05464b6 - Klicke auf das Bild, um es zu vergrößern

Und es sollte so aussehen (Bildausschnitt, so sollte es aussehen, jedoch als Blog und nicht als Liste):
6c9375a1edae02f3eb7dfbcd4130ce35 - Klicke auf das Bild, um es zu vergrößern

Es geht hierbei um den Footer bereich. der geht als leer über die ganze Seite, soll aber mit in dem Rahmen bleiben.

Habe die block_item.php schon angepasst, da ein Fehler aufgetreten ist. (Error on Line 6...)
Hier der angepasste Code (line 6 ist auskommentiert):
01.
<?php 
02.
defined('_JEXEC') or die; 
03.
 
04.
JHtml::addIncludePath(JPATH_COMPONENT . '/helpers'); 
05.
JHtml::_('behavior.tooltip'); 
06.
// JHtml::core(); 
07.
if (method_exists('JHtml','core')) 
08.
JHtml::core(); 
09.
else 
10.
JHtmlBehavior::framework();  
11.
 
12.
Artx::load("Artx_Content"); 
13.
 
14.
$component = new ArtxContent($this, $this->params); 
15.
$article = $component->article('category', $this->item, $this->item->params); 
16.
 
17.
$params = $article->getArticleViewParameters(); 
18.
if (strlen($article->title)) { 
19.
    $params['header-text'] = $this->escape($article->title); 
20.
    if (strlen($article->titleLink)) 
21.
        $params['header-link'] = $article->titleLink; 
22.
23.
// Change the order of ""if"" statements to change the order of article metadata header items. 
24.
if (strlen($article->created)) 
25.
    $params['metadata-header-icons'][] = "<span class=\"art-postdateicon\">" . $article->createdDateInfo($article->created) . "</span>"; 
26.
if (strlen($article->modified)) 
27.
    $params['metadata-header-icons'][] = "<span class=\"art-postdateicon\">" . $article->modifiedDateInfo($article->modified) . "</span>"; 
28.
if (strlen($article->published)) 
29.
    $params['metadata-header-icons'][] = "<span class=\"art-postdateicon\">" . $article->publishedDateInfo($article->published) . "</span>"; 
30.
if (strlen($article->author)) 
31.
    $params['metadata-header-icons'][] = "<span class=\"art-postauthoricon\">" . $article->authorInfo($article->author, $article->authorLink) . "</span>"; 
32.
if ($article->printIconVisible) 
33.
    $params['metadata-header-icons'][] = $article->printIcon(); 
34.
if ($article->emailIconVisible) 
35.
    $params['metadata-header-icons'][] = $article->emailIcon(); 
36.
if ($article->editIconVisible) 
37.
    $params['metadata-header-icons'][] = $article->editIcon(); 
38.
if (strlen($article->hits)) 
39.
    $params['metadata-header-icons'][] = $article->hitsInfo($article->hits); 
40.
// Build article content 
41.
$content = ''; 
42.
if (!$article->introVisible) 
43.
    $content .= $article->event('afterDisplayTitle'); 
44.
$content .= $article->event('beforeDisplayContent'); 
45.
if (strlen($article->images['intro']['image'])) 
46.
    $content .= $article->image($article->images['intro']); 
47.
$content .= $article->intro($article->intro); 
48.
if (strlen($article->readmore)) 
49.
    $content .= $article->readmore($article->readmore, $article->readmoreLink); 
50.
$content .= $article->event('afterDisplayContent'); 
51.
$params['content'] = $content; 
52.
// Change the order of ""if"" statements to change the order of article metadata footer items. 
53.
if (strlen($article->category)) 
54.
    $params['metadata-footer-icons'][] = "<span class=\"art-postcategoryicon\">" 
55.
        . $article->categories($article->parentCategory, $article->parentCategoryLink, $article->category, $article->categoryLink) 
56.
        . "</span>"; 
57.
 
58.
// Render article 
59.
echo $article->article($params);
Ich hoffe mir kann jemand helfen.
P.S.: In der Listendarstellung ist es ok.
Ähnliche Inhalte
Netzwerkgrundlagen
Multi NAT Problem (1)

Frage von Gr33n93 zum Thema Netzwerkgrundlagen ...

Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Drucker und Scanner
Problem mit Konica Minolta bizhub C754e mit EFI - Wegen Fehlern gelöscht (4)

Frage von StefanKittel zum Thema Drucker und Scanner ...

Neue Wissensbeiträge
Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(6)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(6)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Heiß diskutierte Inhalte
Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Batch & Shell
gelöst Batch um Benutzer aus Sitzung abzumelden (15)

Frage von zeroblue2005 zum Thema Batch & Shell ...

Linux
gelöst Google Chrome startet nicht (12)

Frage von Thomas91 zum Thema Linux ...