Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Netzwerke Router & Routing

GELÖST

Problem mit Lancom - Cisco Switchen

Mitglied: alkuhn

alkuhn (Level 1) - Jetzt verbinden

19.12.2008, aktualisiert 13:24 Uhr, 10522 Aufrufe, 9 Kommentare

Nur in einem VLAN funktioniert DHCP

Hallo,

wir haben ca. 20 Lancom Switch und 3 Cisco Switche im Einsatz. Nun haben wir insgesamt 3 VLANs definiert. Auf den Lancom Switchen funktioniert alles ohne Probleme. In VLAN10 werden auch alle DHCP Anfragen beantwortet, egal wo ein Mitarbeiter angeschlossen ist. In den VLANs 99 und 98 werden keine DHCP Anfragen beantwortet, sobald die Anfrage über einen Cisco Switch geht, der zwischen Client und DHCP-Server liegt. Kommt die Anfrage von einem Client, der nur über die Lancom Switche auf den DHCP-Server kommt, funktioniert es. Daher gehe ich davon aus, dass das Problem auf den Cisco Switchen ist, die auch von Softwarestand sehr alt sind. Das nächste Problem, ich habe keine Ahnung von der Cisco Konfiguration ... ;-(

Anbei die aktuelle Konfig auf den Ciscos:


Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname U05-2
!
enable secret 5 $1$u1k$oD6WM8CHV.9wFSCWCP/TP0
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface GigabitEthernet0/1
switchport access vlan 10
!
interface GigabitEthernet0/2
switchport access vlan 10
!
interface GigabitEthernet0/3
switchport access vlan 10
!
interface GigabitEthernet0/4
switchport access vlan 10
!
interface GigabitEthernet0/5
switchport access vlan 10
!
interface GigabitEthernet0/6
switchport access vlan 10
!
interface GigabitEthernet0/7
switchport access vlan 10
!
interface GigabitEthernet0/8
description Uplinkport
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface VLAN1
no ip address
no ip directed-broadcast
no ip route-cache
shutdown
!
interface VLAN10
ip address 10.168.12.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
interface VLAN98
no ip directed-broadcast
no ip route-cache
shutdown
!
interface VLAN99
no ip directed-broadcast
no ip route-cache
shutdown
!
ip default-gateway 10.168.12.254
snmp-server engineID local 000000090200000532AC2400
snmp-server community private RW
snmp-server community public RO
!
line con 0
transport input none
stopbits 1
line vty 0 4
password
login
line vty 5 15
password

login
!
end


Bin für jeden Tipp dankbar!!!
Mitglied: aqui
19.12.2008 um 13:33 Uhr
Das ist auch ein völlig normales Verhalten in einem IP Netzwerk, den DHCP Requests sind UDP Broadcasts die normalerweise von einem Layer 3 (Routing) Switch nicht weitergeleitet werden.
Mit dem SW Stand hat das gar nichts zu tun !!

Alles arbeitet also wie es soll !!
Deine o.a. Switch Konfig ist unvollständig, denn wie du sehen kannst fehlen die IP Adressen in den VLANs 98 und 99 ausserdem sind diese Interfaces auch noch im Shutdown state also inaktiv !!
Kann aber auch gewollt sein wenn dieser Switch nur ein VLAN bedient aber dann solltest du diese Leichen in der Konfig besser entfernen !

Damit die UDP Broadcasts weitergeleitet werden auf dem Cisco musst du einen IP Helper konfigurieren.
Das geht mit dem Kommando ip-helper address <ip_adr_dhcp-server> auf dem Layer 3 Interface

Wie gesagt das gilt NUR wenn diese DHCP Requests VLAN übergreifend auf einen zentralen DHCP Server geforwardet werden sollen.
Alle DHCP Server innerhalb eines VLANs arbeiten vollkommen transparent und da ist es egal welchen Switch man hat...

Also am Beispiel deiner Konfig oben wo alle Ports ja nur im VLAN 10 sind gehen auch alle DHCP Requests an alle Ports im VLAN 10 und natürlich auch auf den getaggten Uplink Port GigabitEthernet0/8 auf dem alle VLANs tagged übertragen werden..
Bei dieser Banalkonfig wäre kein IP Helper nötig, denn du hast ja nur ein einziges VLAN auf dem Switch ! Der helper ist nur da nötig wo zwischen den VLANs geroutet wird und das wird es nicht auf der o.a. Konfig (Nur 1 VLAN !)
Bitte warten ..
Mitglied: alkuhn
19.12.2008 um 13:42 Uhr
Hey, vielen Dank für Deine schnelle Antwort. Leider stehe ich noch etwas im Regen.
Bei der Cisco Konfig ist es so, dass an den Ports 1 - 7 Geräte im VLAN 10 sind, die auch funktionieren. Das Problem ist jetzt so:

Ein Client hängt z.B. am Lancom Port 1 im VLAN 99. Der "Trunk" Port 25 vom Lancom hängt dann am Trunk Port der Cisco. Dieser ist quasi so konfiguriert:

interface GigabitEthernet0/8
description Uplinkport
switchport trunk encapsulation dot1q
switchport mode trunk
!

Ein zweiter Trunk Port (auch wie hier konfiguriert) hängt dann wieder am Trunk von einem Lancom und an einem beliebigen Port mit VLAN 99 hängt ein DHCP Server.

Clients, die an einem beliebigen Port hängen, der auf VLAN 10 konfiguriert ist, bekommen von einem weiteren DHCP Server sauber die IP-Adressen - unabhängig vom Switch.
Bitte warten ..
Mitglied: aqui
19.12.2008 um 13:59 Uhr
Das kann ja niemals funktionieren, denn dann sind beide Geräte ja in unterschiedlichen VLANs !!!

VLANs sind ja wie du weisst komplett voneinander getrennt. Wenn du die DHCP Requests von VLAN 99 auf einen zentralen DHCP Server in VLAN 10 bringen will, dann muss einer der Switches (vermutlich der Cisco weil die Lancoms es nicht können) ja routen zwischen den VLANs.

Sieht dein Szenario so aus ??

a98d79051e12896aa80ceb5f500b7cb1-vlan_allg3 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: alkuhn
19.12.2008 um 14:02 Uhr
Nein, da habe ich mich undeutlich ausgedrückt. Es gibt in VLAN 10 einen DHCP Server und in VLAN 99 einen DHCP Server. Auf den Port, die im VLAN 10 sind, funktioniert es ohne Probleme. Sie bekommen vom DHCP Server 1 ihre IP-Adressen. Alles was im VLAN 99 ist und der Traffic "über" eine Cisco läuft, bekommt keine IP-Adresse vom DHCP Server 2.
Bitte warten ..
Mitglied: aqui
19.12.2008 um 14:20 Uhr
OK, verstanden.
Vermutlich hast du dann schlicht und einfach vergessen das VLAN 99 auf dem Cisco einzurichten ??

enable
vlan database
vlan 99 name <dein_vlan_name>
exit


Ein Ping zwischen den Geräten innerhalb des VLAN 99 muss klappen zwischen beiden Lancoms und über den Cisco, damit ist das VLAN 99 dann transparent. DHCP Requests und Broadcasts werden dann auch übertragen.
Zur Not hilft ein Sniffer wie der Wireshark oder MS NetMonitor2 um zu sehen ob Client DHCP Broadcasts via UDP an alle Ports kommen, denn die muss ein Switch zwangsweise forwarden auf alle Ports im VLAN (Broadcasts) !
In der Konfig kannst du die VLAN IP Interfaces int vlan 99 und in vlan 98 dann entfernen wenn du nicht routest. Das geht in der Konfig einfach mit no int vlan 99.

Es ist übrigens unsinnig in jedem VLAN einen DHCP Server zu haben, denn das kann einfach ein zentraler DHCP Server für alle VLANs erledigen.
Einfach einen weiteren Bereich eintragen und auf dem L3 Switch die ip-helper Adresse konfigurieren und gut ist.
Damit ersparst du dir das Pflegen von zig DHCP Servern im Netz und hast alles zentral...
Aber vielleicht müssen deine VLANs ja getrennt sein, dann macht es wieder Sinn ??!!
Bitte warten ..
Mitglied: alkuhn
19.12.2008 um 14:38 Uhr
Hab die VLANs auf den Ciscos halt mit

interface VLAN99
no ip directed-broadcast
no ip route-cache
shutdown

auf allen Ciscos angelegt und die jeweiligen Trunk-Ports mit

switchport trunk encapsulation dot1q
switchport mode trunk

Muss ich zusätzlich das mit Deinen Befehlen "vlan database ..." usw. einrichten?
Auf VLAN 10 funktioniert es ja ...

Ich habe deshalb einen zweiten DHCP Server, da dieser über einen Wlan-Controller erfolgt, der Clients im VLAN 99 IP-Adressen vergeben soll. Die Clients im VLAN 99 sollten 100%-tig vom VLAN 10 getrennt sein. Daher bin ich diesen Lösungsweg gegangen - aber ohne Erfolg

Und vielen Dank für Deine Bemühungen !!!!!
Bitte warten ..
Mitglied: alkuhn
19.12.2008 um 14:50 Uhr
ICH DANKE DIR.

"Vermutlich hast du dann schlicht und einfach vergessen das VLAN 99 auf dem Cisco einzurichten ??
enable
vlan database
vlan 99 name <dein_vlan_name>
exit"


GENAU DAS WAR MEIN FEHLER )

VIELEN DANK!
Bitte warten ..
Mitglied: aqui
19.12.2008 um 17:47 Uhr
Keine Ursache, dafür ist ein Forum wie dieses ja da....
Übrigens: die beiden vlan interfaces 98 und 99 solltest du dann besser schnell wieder entfernen von der Konfig wie oben beschrieben, denn das sind ja nur die Layer 3 (Routing) IP Interfaces in diesen VLANs. Wenns getrennt sein soll ists besser die verschwinden. Sicher ist Sicher...
Für dich ist immer relvant was in der vlan database steht, denn da werden die VLANs eingerichtet, NICHT mit dem Interface, das ist L3 only !!!
Ein show vlan auf dem Swicth zeigt dir immer die konfigurierten VLANs an !

Bitte dann auch
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Mitglied: alkuhn
19.12.2008 um 18:06 Uhr
Werde ich gleich entfernen!! Und trotzdem - nochmals vielen Dank
Setzte das "Ticket" auf beendet!!

Viele Grüße
Bitte warten ..
Ähnliche Inhalte
Router & Routing
VPN Router Cisco Lancom?
gelöst Frage von geforce28Router & Routing42 Kommentare

Hallo Leute, ich bin seit ein paar Tagen stolzer Besitzer einen 200/20 Leitung von meinem Kabelanbieter. Der hat mir ...

LAN, WAN, Wireless
LANCOM VLAN mit HP Switch?
Frage von TBTuR0kLAN, WAN, Wireless1 Kommentar

Guten Abend liebe Admins, ich habe ein kleines Problem mit meinem aktuellen Projekt und weiß nach 3 Tagen rumprobieren ...

Router & Routing
CISCO CCNP-SWITCH Prüfung
gelöst Frage von edvmaedchenfuerallesRouter & Routing3 Kommentare

Hallo. Heute hat es bei meiner Prüfung leider knapp nicht gereicht und ich darf es nochmal versuchen. Eine generelle ...

Netzwerkmanagement
2 Cisco Switche verbinden
gelöst Frage von twicefaceNetzwerkmanagement8 Kommentare

Hallo allerseits, ich beschäftige mich seit kurzem mit Cisco Switchen (wie man sicher an meinen letzten Fragen merkt). ich ...

Neue Wissensbeiträge
Datenschutz

Teamviewer kommt für IoT-Geräte wie den Raspberry Pi

Information von magicteddy vor 4 StundenDatenschutz

Moin, jetzt werden IoT Geräte endgültig zur Wanze? Anscheinend kann man auf einem Dashboard seine Geräte visualisieren Ich stelle ...

Microsoft

Letzte Updates für Win10 und Server2016 müssen bei Bedarf über den Update catalogue in den WSUS importiert werden!

Tipp von DerWoWusste vor 9 StundenMicrosoft1 Kommentar

automatisch kommt da nichts an im WSUS und auch nicht im SCCM. Siehe Hinweise zum Bezug der jeweils neuesten ...

Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 3 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 4 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Preis für Wartungsvertrag ok?
gelöst Frage von a-za-zNetzwerkmanagement22 Kommentare

Hallo! Mal ne Frage, weil ich mich mit dem akzeptablen Preis für einen Reaktionszeitvertrag nicht auskenne. Meine Firma hat ...

Windows Netzwerk
Ist ein Portforwarding auf einen PC ohne lauschendes Programm ein (großes) Sicherheitsproblem?
Frage von PluwimWindows Netzwerk13 Kommentare

Hallo zusammen, zur Fernwartung eines Rechners an einem anderen Ort nutze ich VNC. Da dieser Rechner einfach nur eine ...

SAN, NAS, DAS
Wer kennt sich mit QNAP und CISCO aus ?
gelöst Frage von MachelloSAN, NAS, DAS10 Kommentare

Hallo Zusammen hier im Forum, Ich habe ein QNas 451+ und dieses NAS hat zwei GBit Lan Adapter die ...

Windows Server
Terminal Server 2016 erkennt Berechtigungen nicht
gelöst Frage von Thomas2Windows Server10 Kommentare

Hallo Administratoren, folgendes Problem stellt sich dar: Es gibt zwei Windows Server 2016, die als Terminal Server fungieren. Jetzt ...