Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
Kommentar vom Moderator Biber am 19.01.2012 um 16:38:37 Uhr
Leider kann ich den Ordner nicht unbenennen
Set /a rgc +=1
#791

Und den Beitrag verschoben von "Betriebssysteme" nach "Batch & Shell"
GELÖST

Problem mit Pfadangabe

Frage Entwicklung Batch & Shell

Mitglied: michifox

michifox (Level 1) - Jetzt verbinden

18.01.2012, aktualisiert 19.01.2012, 2307 Aufrufe, 7 Kommentare

Hallo,

möchte ein Programm starten, aber dieser findet den Pfad nicht

Hallo,

starte über eine kleine Batchdatei mehrere Programme, dies funktionierte bisher auch einwandfrei, doch jetzt habe ich ein Problem.
Die exe-Datei ist in einem Ordner, der z.b. aaa´báaa heißt. Durch den Aphostroph (so glaube ich wie die Striche heißen), findet er
den Pfad nicht.
Leider kann ich den Ordner nicht unbenennen, da dann das Programm nicht mehr läuft.

Gibts da einen Trick?

Mfg

michifox
Mitglied: Alchemy
19.01.2012 um 00:13 Uhr
hallo,

"pfadangabe"

Gänsefüßchen setzen sollte dein Problem lösen.
Bitte warten ..
Mitglied: michifox
19.01.2012 um 00:51 Uhr
Hi,

also alles in Gänsefüßchen setzen geht auch nicht, das System findet den Pfad nicht, egal ob mit oder ohne GF.
Das mach ich sowieso, da bei manchen Programmen Leerzeichen beinhaltet sind.

Gruß
michifox
Bitte warten ..
Mitglied: Seperion
19.01.2012 um 08:46 Uhr
Ich habe das mal durchgetestet und auch eine Lösung gefunden, oder zumindest funktioniert es bei mir so (Windows 7).

Beispielbatch:
01.
mode con cp select=1252 
02.
C:\ 
03.
"Tést´Test\Test.txt" 
04.
pause
die Codepage 1252 ist ANSI.
ANSI wird beim "Speichern unter.." Dialog des Notepad automatisch vorausgewählt, achte also darauf das auch deine Batchdatei die ANSI Codierung hat.

Gruß Seperion
Bitte warten ..
Mitglied: Logan000
19.01.2012 um 15:00 Uhr
Moin Moin

Versuch mal deine exe direkt in der Kommandozeile zu Starten (mit Pfadangabe in "Tütelchen").
Funktioniert das?
Falls ja. Lass dir die bat aus der cmd erstellen, Etwa so:

01.
Echo "[ExePfad]" >> c:\temp\WasAuchImmer.txt
Darin solte dann ein funktionierender Aufruf sein.

Gruß L.
Bitte warten ..
Mitglied: michifox
19.01.2012 um 20:03 Uhr
Hallo,

danke an alle für die schnelle Hilfe.
Der Vorschlag von Seperion funktioniert auf Anhieb, zeigt zwar kurz vor dem Start und nach dem Beendigung des Programms die folgende Statusmeldung an:

Status von Gerät Con:
Zeilen: 300
Spalten: 105
Wiederholungsraten: 31
Verzögerungszeit: 1
Codepage: 1252

aber das stört nicht!!!

Vielen Dank

michifox
Bitte warten ..
Mitglied: Biber
19.01.2012 um 20:10 Uhr
Moin michifox,

Zitat von michifox:
Hallo,

danke an alle für die schnelle Hilfe.
Der Vorschlag von Seperion funktioniert auf Anhieb, zeigt zwar kurz vor dem Start und nach dem Beendigung des Programms die
folgende Statusmeldung an:

Status von Gerät Con:
Zeilen: 300
Spalten: 105
Wiederholungsraten: 31
Verzögerungszeit: 1
Codepage: 1252

aber das stört nicht!!!
Falls es doch irgendwann stören sollte, dann einfach ändern in
mode con cp select=1252>nul
-> dann wird alles nach dahin umgeleitet, wo wir alle mal hingehen. Aber halt sofort.

Grüße
Biber
Bitte warten ..
Mitglied: michifox
19.01.2012 um 22:48 Uhr
Ja, funktioniert
Super, vielenvielen Dank!!!!!!!!!!!!!!!!!1

michifox
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Dateinamen mit Batch-Datei ändern - Problem (9)

Frage von fffffuuuuuuuhhhh zum Thema Batch & Shell ...

Debian
Squid Proxyserver - HTTPS Problem (1)

Frage von Cartman zum Thema Debian ...

Windows Server
Problem mit Webdav und Webserver IIS (3)

Frage von JUJUS31 zum Thema Windows Server ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(5)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...

Outlook & Mail
Outlook 2010 mit Exchange 2016 (15)

Frage von slansky zum Thema Outlook & Mail ...