Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem beim versenden einer Mail aus PHP, mit Exchange 2000

Frage Entwicklung PHP

Mitglied: Bayano

Bayano (Level 1) - Jetzt verbinden

24.05.2007, aktualisiert 29.05.2007, 5360 Aufrufe, 5 Kommentare

Hallo,

ich möchte mit PHP eine Mail versenden. Der MailServer(Exchange2000) hat die IP 192.168.1.40.
Kennt sich jemand damit aus, bei mir kommt immer eine Fehlermeldung das der server nicht erreichbar ist. Weiss jemand von euch ob es ein generelles Problem zwischen PHP und Exchange gibt?

Mein Script sieht folgendermaßen aus:

01.
<?php 
02.
  ini_set('SMTP', "192.168.1.40"); 
03.
  ini_set('smtp_port', "25"); 
04.
  ini_set('sendmail_from', 'versender@meinedomaine.de'); 
05.
 
06.
  $Empfaenger = "empfanger@meinedomaine.de"; 
07.
  $Betreff = "Betreff kommt hier hin"; 
08.
  $Nachricht = "Hier steht dann der Text.........."; 
09.
   
10.
  mail($Empfaenger,$Betreff,$Nachricht); 
11.
?>
Allerdings kommt bei mir der Fehler:

Warning: mail() [function.mail]: Failed to connect to mailserver at "192.168.1.40" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\xampp\htdocs\mail_senden.php on line 11

Ich hoffe jemand von euch kann mir da weiter helfen.

MFG
Sascha
Mitglied: Mitchell
25.05.2007 um 08:57 Uhr
Was steht denn in der Zeile 11 deiner "mail_senden.php"?

Mfg

Mitchell
Bitte warten ..
Mitglied: Bayano
25.05.2007 um 11:03 Uhr
In zeile 11 steht:

mail($Empfaenger,$Betreff,$Nachricht);
Bitte warten ..
Mitglied: Mitchell
26.05.2007 um 00:23 Uhr
ach so, das ist zeile 11^^.

Dann sieh doch mal in deine php.ini (\xampp\apache\bin\php.ini), dort darf kein Localhost mehr stehen. Nur der Exchange. Danach musst du auf jedenfall den Apache neustarten, sonst läufts nicht.

Mfg

Mitchell
Bitte warten ..
Mitglied: Bayano
29.05.2007 um 07:57 Uhr
Ja, das habe ich schon überprüft, da steht schon der Exchange und außerdem stetze ich den ja auch vorher noch mit dem Befehl "ini_set('SMTP', "192.168.1.40");". Also daran kann es eigendlich nicht liegen.
Bitte warten ..
Mitglied: Mitchell
29.05.2007 um 10:48 Uhr
außerdem stetze ich den ja auch vorher
noch mit dem Befehl
"ini_set('SMTP',
"192.168.1.40");".

Ja, schon. Manche haben aber immernoch den Localhost irgendwo stehen. Sorry, kann dich momentan nur auf folgenden Link verweisen:

http://www.administrator.de/PHP__mail%28%29_Funktion_kann_nicht_%C3%BCb ...

Mfg

Mitchell
Bitte warten ..
Neuester Wissensbeitrag
Microsoft Office

MS Office Excel - Formel wird angezeigt, aber nicht berechneter Wert!

Tipp von holli.zimmi zum Thema Microsoft Office ...

Ähnliche Inhalte
Windows Server
E-Mail Konto Exchange einrichten (12)

Frage von jhaustein zum Thema Windows Server ...

Exchange Server
gelöst MS Exchange-Problem: Servername und Name im Zertifikat stimmen nicht überein (1)

Frage von KLeinstein.tm zum Thema Exchange Server ...

Exchange Server
Problem mit Exchange 2010 und Cache Modus (1)

Frage von Leo-le zum Thema Exchange Server ...

Microsoft
gelöst Exchange Server SAN Zertifikat Problem (2)

Frage von brooks zum Thema Microsoft ...

Heiß diskutierte Inhalte
Hyper-V
gelöst Reiner Hyper- V Server oder lieber Rolle (21)

Frage von Winuser zum Thema Hyper-V ...

Exchange Server
Bestehende eMails autoamatisch weiterleiten (21)

Frage von metal-shot zum Thema Exchange Server ...

SAN, NAS, DAS
gelöst Synology Version 6.1 Probleme (18)

Frage von Hendrik2586 zum Thema SAN, NAS, DAS ...

Router & Routing
gelöst IP Kamera für drei unabhängige Netzwerke (16)

Frage von ProfessorZ zum Thema Router & Routing ...