Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit WinZip Command Line Support-Script

Frage Microsoft Windows Server

Mitglied: jyvo00

jyvo00 (Level 1) - Jetzt verbinden

29.09.2008, aktualisiert 19:32 Uhr, 4844 Aufrufe, 5 Kommentare

Hallo zusammen!
Ich hab ein Problem mit dem WinZip Command Line Support

Ich habe ein Script geschrieben, welches für jeden Wochentag (von Mo. bis Fr) eine Sicherung erstellt. Ich habe insgesamt 5 Festplatten verbaut. Für jeden Wochentag 1 Festplatte.
Mein Problem ist jetzt, dass wenn ich Montags bei meinem Backup-Server nachschauen möchte, ob alles geklappt hat, ist der PC runtergefahren. Dies passiert immer nach dem Freitags-Script. Ich weiß echt nicht woran es liegt, da die Wochentags-Scripte nahezu identisch sind, nur halt das sie jeden Tag auf einer anderen Platte gesichert werden.

Hier mal ein kleiner Ausschnitt des Scripts:

01.
@echo on 
02.
del *.zip 
03.
copy Y:\listen\listen.xls N:\liste08 /Y 
04.
copy Z:\*.* E:\ /Y 
05.
copy U:\*.* J:\Andere /Y 
06.
xcopy Y:\Angebote\2008\*.* N:\Angebote\2008 /E/V/Y/C 
07.
 
08.
wzzip org.zip -r -p Q:\*.* 
09.
wzzip net.zip -r -p S:\*.* 
10.
wzzip outlook.zip -r -p T:\*.* 
11.
 
12.
pause 
13.
exit
Das hier ist das Script für Freitag
Die Scripte für die anderen Wochentage sehen halt genau so aus, nur das sie auf anderen FP gesichert werden.

Vielleicht weiß jemand von euch wie man das Problem lösen kann, ohne das der Rechner jedesmal am Wochenende runterfährt.

Vielen Dank im Voraus

MfG
Mitglied: 60730
29.09.2008 um 12:08 Uhr
Servus,

an deiner Stelle würde ich "woanders" suchen....

Schau im Eventlog, wann der Server herunterfährt - bzw. ob er beim neustarten einen "unangemeldeten Neustart" entdeckt.

Am Xcopy / zippen kanns nicht liegen - Sind denn die Freitagszips komplett - oder stürzt er dabei ab?
Ist "Neustarten" nach Fehler auf dem Server aktiv?
Der Shutdown - kommt zu 99.9999 & von einem anderen "Problem"


Ps:
01.
set "WTag=%date:~-13,2%" 
02.
net use n: /delete 
03.
if %WTag%=Mo net use n: montagsplatte 
04.
if %WTag%=Di net use n: dienstagsplatte 
05.
rem usw...
So kannst du ein und dasselbe Script für jeden Wochentag benutzen und hast trotzdem immer eine andere Platte - auf die gesichert wird.

Gruß
Bitte warten ..
Mitglied: jyvo00
29.09.2008 um 17:05 Uhr
Hallo,

danke erstmal für die schnelle Antwort!

bin ja erstmal erleichtert, dass es nicht am script liegt, darüber hab ich mir schon stundenlang nen Kopf gemacht...

Ich hab im Eventlog geschaut aber nix auffälliges gefunden. Es stehen nur halt ein paar Infos da, aber keine Fehler oder irgendwas von Restarts...hm.

Ach ja... die Freitagszips sind immer komplett.

Vielleicht habt ihr ja noch nen Tipp

Danke im Voraus
Bitte warten ..
Mitglied: 60730
29.09.2008 um 18:21 Uhr
Servus,

dann mach es auf die "harte" Tour...
  1. Stelle das freitag Backup aus - bzw. verschiebe es auf Samstag.
  2. und geh Samstags in die Firma.

läuft der Server?
läuft er dann am Sonntag / wenn das freitagscript - das einmalig am Samstag gelaufen ist - noch?

  1. Kommt Freitags die Putzfrau und braucht evtl. einen Stromanschluß für den staubsauger?

Gruß
Bitte warten ..
Mitglied: jyvo00
29.09.2008 um 18:58 Uhr
Hey!

Hm...ja daran hab ich auch schon gedacht. Hatte es als letzt Möglichkeit in Betracht gezogen...Ich werd mal mein Glück am Samstag versuchen!

Danke nochmal

(Der Raum, in dem der Server steht, ist eigentlich immer verschlossen, es sei denn ich muss mal an den Server ran, die Putzfrau hat für die Tür keinen Schlüssel;)


Ach...da fällt mir noch was ein, was vielleicht noch wichtig sein könnte...
Also die Platten von Mo. bis Do. sind ganz normal im Gehäuse per S-ATA Kabel angeschlossen. Die Freitagsplatte ist in einem HD-Wechselrahmen(auch über S-ATA)
Hab da auch schon einiges probiert, sprich neue Treiber etc.
Bitte warten ..
Mitglied: 60730
29.09.2008 um 19:32 Uhr
aha

dann schu mal nach - ob der Haken "Automatisch neu starten" unter
Arbeitsplatz/Eigenschaften/Erweitert/Starten und Wiederherstellen
gesetzt ist - ich tippe auf nein....

Und wenn ich richtig liege, solltest du den Haken anklicken und die für Freitag etwas anderes ausdenken - nur - warum das Freitagsscript trotzdem "komplett" ist - wie du schreibst - verstehe ich dann auch nicht....

Gruß
Bitte warten ..
Ähnliche Inhalte
Erkennung und -Abwehr
Command Line Scanner für Softwarebuild (8)

Frage von KMUlife zum Thema Erkennung und -Abwehr ...

Netzwerkprotokolle
gelöst Telnet Verbindung mit Drucker über Port 9100 - Schwarzes Fenster keine command line ! (9)

Frage von Hainoon zum Thema Netzwerkprotokolle ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(2)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Netzwerkprotokolle
Leiten "dumme" Switches VLAN-Tags mit durch? (23)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

Windows Server
gelöst Neues KB für W10 1607 und W2K16 wieder mal nicht im WSUS 3.0, hat das noch jemand? (15)

Frage von departure69 zum Thema Windows Server ...

Batch & Shell
Batch zum suchen und verschieben von Verknüpfungen (12)

Frage von zeroblue2005 zum Thema Batch & Shell ...

Router & Routing
FTTH bzw FTTB Router (11)

Frage von ukulele-7 zum Thema Router & Routing ...