Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Habe ein Problem mit XAMPP

Frage Entwicklung Webentwicklung

Mitglied: 98432

98432 (Level 1)

11.03.2011 um 16:28 Uhr, 3883 Aufrufe, 12 Kommentare

Bin noch neu auf dem Gebiet deswegen =)

Also ich hab mir XAMPP für Win7 heruntergeladen (Installer Verison).
Alles ist installiert . Mit der Anleitung von Apache komme ich mässig zurecht.
In den Ordner mach ich Apache_start und MySQL_start.
Eben bin noch neu. Wenn ich das Control pannel öffne steht da auch Apache running und MySQL running.
Sollte also funktionieren. Aber unter http://localhost/ und http://127.0.0.1/ mit dem jeweiligen Dateinamen kommt nichts bzw. kommt Datei wurde nicht gefunden.
Wieso geht das nicht? Ich möchte meine PHP scripts testen können.
Bitte schnelle Hilfe!

LG.
Mitglied: Obererpel
11.03.2011 um 16:30 Uhr
Starte mal über das Panel. Es meldet, wenn etwa der Apache nicht gestartet werden kann oder Probleme bereitet.

Ein beliebter Grund für das nicht-Funktionieren ist zum Beispiel ein laufendes Skype, welches Port 80 blockiert.
Bitte warten ..
Mitglied: 98432
11.03.2011 um 16:40 Uhr
Meine "test datei" habe ich über das panel geöffnet aber es zeigt nicht das ergebnis sondern den PHP quelltext
ah ja, es steht nicht localhost oder 127.0.0.1 sondern der ort also file:///C:/.......
Bitte warten ..
Mitglied: Arano
11.03.2011 um 16:55 Uhr
Hallo,

aber wenn du NUR localhost aufrufst bekommst du schon eine Seite oder ?
Liegen deine PHP-Dateien und die Standard-Startseite in dem gleichem Verzeichnis ?

~Arano
(Hab nix XAMPP)
Bitte warten ..
Mitglied: 98432
11.03.2011 um 16:59 Uhr
ja wenn ich nur localhost aufrufe kommt die xampp seite
gleiches verzeichnis, das sollte bei xampp eigentlich htdocs heissen und das ist es auch
Logisch wenn ich xampp testen will mach ich alles ins gleiche verzeichnis, aber im moment will ich nur eine PHP datei testen um zu sehen ob xampp funktioniert
Bitte warten ..
Mitglied: Arano
11.03.2011 um 17:23 Uhr
Hi !

Nun ja, bei den Schlafmützen die es immer wieder gibt kann man nicht auf Logik setzen. Selbst bei Nachgefragten Detail passt es manchmal nicht.
Davon mal abgesehen ist doch jeder mal etwas Tollpatschig

Am Dateinamen kann es nicht liegen, wie lautet er, wie lautet die gesamte getestete URL ?
Möglicherweise keine Leserechte des Webservers auf die Datei !?
Doppelte Dateinamenserweiterung ?
Was steht in dem Log-File des Apaches ?

Mehr fällt mir nicht ein...
~Arano
Bitte warten ..
Mitglied: Froxy-HN
11.03.2011 um 20:18 Uhr
Hallo,

wenn du im xampp-Verzeichnis, also im Ordner htdocs einen neuen anlegst z.B test und in diesen dann dein PHP-Script ablegst, sollte das dann auch unter http://localhost/test aufrufbar sein.

Gruss
Bitte warten ..
Mitglied: 98432
11.03.2011 um 21:38 Uhr
Danke jetzt funktionierts. Aber mit XAMPP lässt sich doch auch Javascript testen oder ist das nicht nötig?
Bitte warten ..
Mitglied: nxclass
12.03.2011 um 00:02 Uhr
Javascript wird im Browser des Clients ausgeführt - dazu brauchst du keinen Server.
Bitte warten ..
Mitglied: Arano
12.03.2011 um 01:49 Uhr
Moin moin,

Und woran hat es gelegen ?
Finde es immer schade wenn Fragen ohne (geschriebene) Lösungen beendet werden

~Arano
Bitte warten ..
Mitglied: 98432
12.03.2011 um 14:28 Uhr
also ich weiss es nicht nur wenn ich den ratschlag mit dem ordner mache funktionierts??
Bitte warten ..
Mitglied: 98432
12.03.2011 um 14:31 Uhr
komisch
wenn ich die datei jetzt nicht in den ordner mache und dann http://localhost/name.php aufrufe geht es
Bitte warten ..
Mitglied: Arano
12.03.2011 um 14:44 Uhr
Guten Tag,

das ist wirklich komisch !?
Na wenn es denn jetzt funktioniert, warum auch immer, kannst du die Frage ja als gelöst markieren.

Viel Spaß und ein schönes Wochenende noch
~Arano
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Dateinamen mit Batch-Datei ändern - Problem (9)

Frage von fffffuuuuuuuhhhh zum Thema Batch & Shell ...

Debian
Squid Proxyserver - HTTPS Problem (1)

Frage von Cartman zum Thema Debian ...

Windows Server
Problem mit Webdav und Webserver IIS (3)

Frage von JUJUS31 zum Thema Windows Server ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(2)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...