Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme bei der Migration eines Switches

Frage Netzwerke

Mitglied: eddyedfred

eddyedfred (Level 1) - Jetzt verbinden

21.04.2007, aktualisiert 30.04.2007, 3759 Aufrufe, 8 Kommentare

Hallo,

das System, das ich hier administriere besteht aus einem suse standard 8 server. die clients sind laufen unter windows 2000.
das teil, das gerade das netzwerk noch verbindet ist ein 16 port hub.

dieser soll nun durch einen 24 port switch ersetzt werden.
eigentlich kein Problem dachte ich mir. Hub raus, Switch rein.

Geht aber nur begrenzt. Sobald sich der Switch im Netzwerk befindet, wird alles extrem langsam. bzw. nicht alles. Eigentlich nur die Kommunikatiuon zum Server. Die Clients können untereinander noch wunderbar schnell kommunizieren.

Ein defekt des Switches ist ausgeschlossen, da ich schon verschiede getestet habe. Die NEtzwerkkarte im Server hab ich auch schon getauscht. Erfolg: 0.

Wäre wunderbar, wenn mir jemand noch einen Hinweis geben könnte, was noch möglich wäre.

DAnke Euch schon mal!

Gruß, Marco
Mitglied: eddyedfred
21.04.2007 um 17:34 Uhr
Ich gleich nochmal:

Ich hätte bitte gerne eine Erklärung, wenn sie mir jemand geben könnte.

Hab den Server mal aus dem Swizsch genommen und ihn in einen Port des Routers gesteckt, der auch noch am Netz hängt --> Alles geht wunderbar.

ICh verstehs nicht...

Der Marco
Bitte warten ..
Mitglied: t3r0x
21.04.2007 um 17:37 Uhr
Moin Marco

Um Welche Kommunikation geht es zwischen Srv-Client? SMB?
Ist es ein Layer 2 (non-managed) Switch?
Wieviele Netzwerkkarten sind im Server eingebaut?
Ist der Server an einem Uplink Port angeschlossen?
Läuft der Server mit 100mbit Anbindung?
Hatte auch schon das Problem, dass Switch und NIC nicht die richtige Geschwindigkeit aushandeln konnten.

Was sicher auch nicht schaden würde, wenn du mal einen Netzwerkmonitor auf dem Server installierst und den Record auswerten könntest.
Bitte warten ..
Mitglied: cykes
21.04.2007 um 18:18 Uhr
Hi,

hast Du vielleicht mal nach einem neuen Treiber für die Netzwerkkarte bzw. einen neuen Kernel
für den Server geschaut? Was sind das für Netzwerkkarten (Hersteller, Typ) und welcher Switch ist
es (hersteller, Typ)?

Gruß

cykes
Bitte warten ..
Mitglied: aqui
21.04.2007 um 18:56 Uhr
Sehr wahrscheinlich ein Autonegotiation Problem zwischen Switch und Karte. D.h. die Übertragungsparamter (Full/Half Dup, 10/100) werden nicht richtig ausgehandelt. Oft ist es eine Problematik des Duplexverfahrens. Eine Seite sendet in Halfdup und die andere in Fulldup und dann kommt es zu heftigen Kollisionen auf dem Link und nichts geht mehr !

Ist der Switch managebar ?? Dann den Port fest auf z.B. 100 Mbit, fulldup setzen (Leider schreibst du ja nur recht oberflächlich was für Karten und Switch HW du einsetzt
Wenn nicht, dann den Port auf einen festen Wert am Server setzen, das geht auch unter Linux problemlos.

Normalerweise sollte der Server eine GiG Karte haben, die dann meist solche Autoneg Probleme nicht mehr hat wie 10/100er Systeme. Es macht immer mehr Sinn den Server mit einer höheren Geschwindigkeit anzubinden als die Clients. Warum, das liegt auf der Hand....alle Clients treffen sich am Serverport wieder was den Traffic anbetrifft...
Sinnvoll ist also in so einem Fall ein klassischer Standardswitch mit 24 mal 10/100 und 2 mal GiG.
Bitte warten ..
Mitglied: spacyfreak
21.04.2007 um 18:59 Uhr
Yo - riecht streng nach duplex missmatch! (wie aqui sagt).
Ich würde den Switchport an dem der "problem-server" hängt auf duplex full und speed 100 oder 1000 setzen (je nachdem ob der server 100mbit oder Gigabit-netzkarte hat).

Auf jeden Fall gratuliere ich Dir zur Entscheidung, anno 2007 einen Hub mit einem Switch auszutauschen!
Bitte warten ..
Mitglied: MagicM
22.04.2007 um 13:21 Uhr
Auf jeden Fall gratuliere ich Dir zur
Entscheidung, anno 2007 einen Hub mit einem
Switch auszutauschen!

LOL

Wenn der Switch managebar ist, könnte man nachsehen, ob es irgendwelche Fehler (s. oben: Duplex CRC) gibt!? Ich hoffe, Du hast nicht nur die Mühen sondern auch die Kosten nicht gescheut, gleich von einem Hub auf einen managebaren Switch umzusteigen...
Bitte warten ..
Mitglied: eddyedfred
30.04.2007 um 10:52 Uhr
danke euch allen!

ich hab jetzt ein bisschen mehr verstanden, an was es liegen konnte und leider ist es natürlich kein managebarer switch. das war im budget der einrichtung nicht drin. vorallem lag der andere noch einfach so rum.

wie gesagt, vielen dank!

der marco
Bitte warten ..
Mitglied: aqui
30.04.2007 um 16:46 Uhr
Wenns das war bitte Thread oben als gelöst markieren !
Bitte warten ..
Ähnliche Inhalte
Switche und Hubs
Welcher Switch (10)

Frage von KellogsFR zum Thema Switche und Hubs ...

Exchange Server
Probleme bei der Migration von Notes in Exchange (9)

Frage von DrCox zum Thema Exchange Server ...

Vmware
Veeam Quick Migration sehr langsam (5)

Frage von Leo-le zum Thema Vmware ...

Peripheriegeräte
gelöst QLOGIC SANbox Switch 5600 (4)

Frage von jarimlim zum Thema Peripheriegeräte ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(14)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Server
Bilder aus dem Web mit CSV runterladen (30)

Frage von Yannosch zum Thema Server ...

Server-Hardware
Bestehendes Raid erweitern um 4 gleiche Platten! (Verständnis Fragen) (12)

Frage von Hendrik2586 zum Thema Server-Hardware ...

Windows Update
WSUS 4 (Server 2012 R2) - Windows 10 Updates nicht möglich (12)

Frage von c0d3.r3d zum Thema Windows Update ...