Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit OpenVPN

Frage Linux Linux Netzwerk

Mitglied: zenotornado

zenotornado (Level 1) - Jetzt verbinden

13.01.2011, aktualisiert 18.10.2012, 3398 Aufrufe, 3 Kommentare

Guten Morgen,

leider muss ich euch mit dieser Frage belästigen. Im Internet habe ich keine passende Antwort zu meinem Problem gefunden und leider bin ich in dem Bereich VPN ein blutiger Anfänger.

Ich betreibe ein kleines Netzwerk mit 5 Rechnern, einen Server und der dazu gehörigen Technik. Der ClearOS Server (welcher per OpenVPN Client mit einem IP Tunnel verbunden ist) hostet mein OpenVPN. Der Server hat Zwei Netzwerkkarten. Die Karte eth0 ist für den externen Verkehr und die eth1 ist für den Internen Verkehr. Ich kann über den IP Tunnel mein VPN Verbinden und auf die Ordner auf dem Server zugreifen. Leider jedoch nicht auf die Ordner und Konfigurationsseiten der anderen Clients. Momentan habe ich das Routing übernommen, welches mir der Server vorgeschlagen hat und auch der Versuch, das routing auf 192.168.178.0/24 255.255.255.0 zu übertragen war erfolglos. Liegt es vlielleicht daran, dass der Server ein einzelner Client ist und die Verteilung im Switch stattfindet. sollte ich vllt auf den Switch Routen?

Unten findet ihr die Konfigurationen so wie die Netzwerkstruktur.
http://www.ibmne.de/struktur.jpg

Die vergebenen IP Adressen:
IP	        Name	DNS	        Group	AccesP	System	Notes 
192.168.178.1	fritz	fritz.ibmne		LAN	UNIX	DSL 
192.168.178.2	server	servere.ibmne	IBMNE	LAN	LINUX	Extern 
192.168.178.3	server	server.ibmne	IBMNE	LAN	LINUX	 
192.168.178.4	switch	switch.ibmne		LAN	UNIX		 
192.168.178.10	deskjon	deskjon.ibmne	IBMNE	LAN	LINUX	 
192.168.178.11	lapjon	lapjon.ibmne	IBMNE	WLAN	LINUX	 
192.168.178.12	deskkse	deskkse.ibmne	IBMNE	LAN	WIN	 
192.168.178.13	gamekse	gamekse.ibmne	IBMNE	LAN	WIN	
Die Konfigurationsdatei auf dem Server:
port 1194 
proto udp 
dev tun 
ca /etc/ssl/ca-cert.pem 
cert /etc/ssl/sys-0-cert.pem 
key /etc/ssl/private/sys-0-key.pem 
dh /etc/ssl/dh1024.pem 
server 10.8.0.0 255.255.255.0 
keepalive 10 120 
comp-lzo 
user nobody 
group nobody 
persist-key 
persist-tun 
ifconfig-pool-persist /var/lib/openvpn/ipp.txt 
status /var/lib/openvpn/openvpn-status.log 
verb 3 
plugin /usr/share/openvpn/plugin/lib/openvpn-auth-ldap.so /etc/openvpn/auth-ldap 
push "dhcp-option DNS 192.168.1.3" 
push "dhcp-option WINS 192.168.1.3" 
push "dhcp-option DOMAIN 80.xxx.xxx.xxx" 
push "route 192.168.178.0 255.255.255.0" 
push "route 192.168.178.0 255.255.255.0"
Die aktuellen Routingoptionen:
10.8.0.2        *               255.255.255.255 UH    0      0        0 tun0 
80.244.244.248  fritz.ibmne     255.255.255.255 UGH   0      0        0 eth0 
80.244.251.241  *               255.255.255.255 UH    0      0        0 tun1 
192.168.178.0   *               255.255.255.0   U     0      0        0 eth0 
192.168.178.0   *               255.255.255.0   U     0      0        0 eth1 
10.8.0.0        10.8.0.2        255.255.255.0   UG    0      0        0 tun0 
default         80.xxx.xxx.xxx  0.0.0.0         UG    0      0        0 tun1
Server:
ClearOS
OpenVPN Client: IP Tunnel
OpenVPn Server
eth0: 192.168.178.2
eth1: 192.168.178.3

Vielen Dank für eure Hilfe. Ich hoffe, jemand hat eine Idee.
Mitglied: aqui
13.01.2011, aktualisiert 18.10.2012
Du hast vermutlich aus Unkenntnis korrekter IP Adressierung einen ziemlichen Kardinalsfehler bei der IP Adressierung deiner beiden Ethernet Interfaces im Server gemacht !!
Siehe hier:
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
Deine beiden Adapter sind in ein- und demselben IP Netzwerk, was natürlich so niemals geht ! Deshalb auch der Unsinn bei dir das push "route 192.168.178.0 255.255.255.0" Kommando 2mal einzugeben in der Server Konfig. was natürlich Blödsinn ist. Spätestens da hätte die "rote Lampe" angehen müssen bei dir
  • Korrigiere die IP Adressierung ! Beachte dabei VORHER unbedingt DAS HIER.
  • Propagiere mit "push route..." dein lokales LAN und gut ist !
Ein laufendes Beispiel findest du hier:
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Die OpenVPN Konfig ist vollkommen unabhängig von der verwendeten HW und immer gleich !!
Bitte warten ..
Mitglied: zenotornado
13.01.2011 um 19:05 Uhr
Das mit den IP Adressen verstehe ich in dem Moment nicht so ganz. Meinst du damit die eth0 und eth1 ? Diese enden beide im selben Netzwerk. Der Client, der sich verbindet ist in keinem Netzwerk eingebunden. oder würde es etwas bringen, wenn ich eine der Beiden Karten vorerst deaktiviere. Im Moment nutze ich eh keine DMZ?

Ich werd die IP Struktur jetzt ersteinmal umbasteln zu 175.118.129.0/24. Wie muss der Push dann aussehen, um den VPN Client weiterzuleiten? einfach 10.8.0.0 175.118.129.0 ?
Bitte warten ..
Mitglied: aqui
22.01.2011, aktualisiert 18.10.2012
Beide Karten müssen zwingend in unterschiedliche IP Netze !!!
Lies dir bitte den Abschnitt dazu im Tutorial nochmal genau durch !!
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...

Beide in ein IP Netz funktioniert de facto NICHT !!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Router & Routing
OpenVpn Verbindung Synology NAS hinter Zywall USG 40 (2)

Frage von Tirgel zum Thema Router & Routing ...

Windows Server
Windows Firewall Einstellungen für OpenVPN Tunnel (4)

Frage von Aubanan zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...