Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit OpenVPN Server

Frage Netzwerke LAN, WAN, Wireless

Mitglied: 7068

7068 (Level 1)

14.06.2005, aktualisiert 15.06.2005, 8634 Aufrufe, 1 Kommentar

Hy Leute

Ich habe ein Problem mit einer OpenVPN-Umgebung.
Im server mode läuft alles einwandfrei! Jedoch will ich den Server in der bridged-mode betreiben. Der OpenVPN Server läuft auf einem autonomen Rechner im LAN. (Firewall seperat)

LAN: 192.168.0.0/24

LAN-IP Server: 192.168.0.8

Die Zeile mit den Bridge-Parametern sieht so aus:

Zitat:
server.conf ...
server-bridge 192.168.0.8 255.255.255.0 192.168.0.200 192.168.0.254
...


(Wenn ich diese Zeile in die Server zeile ändere, funtioniert alles, der Client erhält sogar eine IP)

Ich habe auch einen Script erstellt um das bridge device zu initialisieren.

wie hier beschrieben: http://openvpn.net/bridge.html

Beim Verbinden mit einem Windows-XP-Client wird einfach die IP aus dem Pool nicht zugewiesen! (OpenVPN internes DHCP, Pool 200 - 254)

Hier der Output des Clients:

Zitat:

Tue Jun 14 16:11:22 2005 us=536126 LZO compression initialized
Tue Jun 14 16:11:22 2005 us=536267 Control Channel MTU parms [ L:1574 D:138 EF:38 EB:0 ET:0 EL:0 ]
Tue Jun 14 16:11:22 2005 us=539813 Data Channel MTU parms [ L:1574 D:1450 EF:42 EB:23 ET:32 EL:0 AF:3/1 ]
Tue Jun 14 16:11:22 2005 us=539870 Local Options String: 'V4,dev-type tap,link-mtu 1574,tun-mtu 1532,proto UDPv4,comp-lzo,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-client'
Tue Jun 14 16:11:22 2005 us=539884 Expected Remote Options String: 'V4,dev-type tap,link-mtu 1574,tun-mtu 1532,proto UDPv4,comp-lzo,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-server'
Tue Jun 14 16:11:22 2005 us=539912 Local Options hash (VER=V4): 'd79ca330'
Tue Jun 14 16:11:22 2005 us=539932 Expected Remote Options hash (VER=V4): 'f7df56b8'
Tue Jun 14 16:11:22 2005 us=539971 Socket Buffers: R=[8192->8192] S=[8192->8192]
Tue Jun 14 16:11:22 2005 us=544434 UDPv4 link local: [undef]
Tue Jun 14 16:11:22 2005 us=544463 UDPv4 link remote: 192.168.0.8:10815
Tue Jun 14 16:11:22 2005 us=558839 TLS: Initial packet from 192.168.0.8:10815, sid=90dcd6b4 46870b1d
Tue Jun 14 16:11:22 2005 us=656198 VXXXXXXX
Tue Jun 14 16:11:22 2005 us=658151 VERIFY OK: dXXXXX
Tue Jun 14 16:11:22 2005 us=888861 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
Tue Jun 14 16:11:22 2005 us=888895 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Tue Jun 14 16:11:22 2005 us=888946 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
Tue Jun 14 16:11:22 2005 us=888963 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Tue Jun 14 16:11:22 2005 us=892094 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
Tue Jun 14 16:11:22 2005 us=892140 [XXXXXX] Peer Connection Initiated with 192.168.0.8:10815
Tue Jun 14 16:11:24 2005 us=647574 SENT CONTROL XXXXXX: 'PUSH_REQUEST' (status=1)
Tue Jun 14 16:11:24 2005 us=650987 PUSH: Received control message: 'PUSH_REPLY,route-gateway 192.168.0.0,ping 10,ping-restart 60,ifconfig 192.168.0.200 255.255.255.0'
Tue Jun 14 16:11:24 2005 us=651045 OPTIONS IMPORT: timers and/or timeouts modified
Tue Jun 14 16:11:24 2005 us=651057 OPTIONS IMPORT: --ifconfig/up options modified
Tue Jun 14 16:11:24 2005 us=651068 OPTIONS IMPORT: route options modified
Tue Jun 14 16:11:24 2005 us=651095 WARNING: --remote address [192.168.0.8] conflicts with --ifconfig subnet [192.168.0.200, 255.255.255.0] -- local and remote addresses cannot be inside of the --ifconfig subnet. (silence this warning with --ifconfig-nowarn)
Tue Jun 14 16:11:24 2005 us=676198 TAP-WIN32 device [OpenVPN] opened: \\.\Global\{9D344E5D-2AD0-4F3B-94B0-50A11942EB8B}.tap
Tue Jun 14 16:11:24 2005 us=677338 TAP-Win32 Driver Version 8.1
Tue Jun 14 16:11:24 2005 us=678098 TAP-Win32 MTU=1300
Tue Jun 14 16:11:24 2005 us=679140 Notified TAP-Win32 driver to set a DHCP IP/netmask of 192.168.0.200/255.255.255.0 on interface {9D344E5D-2AD0-4F3B-94B0-50A11942EB8B} [DHCP-serv: 192.168.0.0, lease-time: 31536000]
Tue Jun 14 16:11:24 2005 us=681646 Successful ARP Flush on interface [4] {9D344E5D-2AD0-4F3B-94B0-50A11942EB8B}
Tue Jun 14 16:11:24 2005 us=787383 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Tue Jun 14 16:11:24 2005 us=787410 Route: Waiting for TUN/TAP interface to come up...

und dann gehts immer so weiter ....


Ganz seltsam finde ich die Zeile:

Tue Jun 14 16:11:24 2005 us=651095 WARNING: --remote address [192.168.0.8] conflicts with --ifconfig subnet [192.168.0.200, 255.255.255.0] -- local and remote addresses cannot be inside of the --ifconfig subnet. (silence this warning with --ifconfig-nowarn)


Danke für eure Hilfe.

Gruss

mInCEr

P.S. Auf dem Server läuft Debian Sarge
Mitglied: 7068
15.06.2005 um 09:45 Uhr
....

ich habe den Fehler gefunden!
Um die VPN-Verbindung zu testen habe ich eine Analoge 56k Verbindung ab dem Rechner welcher im selben LAN-Subnetz ist wie der VPN-Server gemacht. Die Netzwerkverbindung habe ich dann einfach deaktiviert, was anscheinend nicht aussreichend war! erst als ich das Netzwerkkabel ausgezogen habe, hat das Ganze funktioniert!

...

Gruss

mInCEr
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Router & Routing
gelöst OpenVPN Server - Kein Zugriff auf Server LAN (2)

Frage von PeterH96 zum Thema Router & Routing ...

Netzwerkgrundlagen
OpenVPN-Server über br0 ins Netzwerk routen klappt nicht (7)

Frage von Aileron zum Thema Netzwerkgrundlagen ...

Router & Routing
Routing Windows OpenVPN Server mit Teltonika RUT500 als Client (1)

Frage von ahenngee zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...