Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme beim Routing von Windows 7 zwischen 2 NICs

Frage Microsoft Windows Netzwerk

Mitglied: Evilmachine

Evilmachine (Level 1) - Jetzt verbinden

29.07.2013, aktualisiert 11:30 Uhr, 2668 Aufrufe, 14 Kommentare, 3 Danke

Guten Morgen Liebe Administratoren,

Ich habe ein Problem beim Routing zwischen unserem Firmennetz und einem kleinen Testnetz welches hinter meinem Rechner sitzt.

Es will einfach nicht klappen. Ich habe schon in der Registry das IPFowarding aktiviert und den Routing und Ras Dienst gestartet.

Auch ein route ADD 172.74.100.100 MASK 255.255.255.0 172.16.100.238 hat nicht geklappt.

Vielleicht kann mir jemand helfen.

Hier die aktuelle Konfiguration der 2 Netzwerkkarten:

Windows-IP-Konfiguration

Hostname . . . . . . . . . . . . : pc-sascha
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Hybrid
IP-Routing aktiviert . . . . . . : Ja
WINS-Proxy aktiviert . . . . . . : Nein
DNS-Suffixsuchliste . . . . . . . : py.meinberg.de

Ethernet-Adapter LAN-Verbindung:

Verbindungsspezifisches DNS-Suffix: py.meinberg.de
Beschreibung. . . . . . . . . . . : Intel(R) 82579V Gigabit Network
Physikalische Adresse . . . . . . : 38-60-77-2E-E3-E8
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
IPv4-Adresse . . . . . . . . . . : 172.16.100.238(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.0.0
Lease erhalten. . . . . . . . . . : Montag, 29. Juli 2013 07:56:
Lease läuft ab. . . . . . . . . . : Montag, 26. August 2013 07:5
Standardgateway . . . . . . . . . : 172.16.3.3
DHCP-Server . . . . . . . . . . . : 172.16.3.1
DNS-Server . . . . . . . . . . . : 172.16.3.120
208.67.222.222
NetBIOS über TCP/IP . . . . . . . : Aktiviert

Ethernet-Adapter LAN-Verbindung 2:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Realtek PCIe GBE Family Cont
Physikalische Adresse . . . . . . : 00-E0-4C-68-00-32
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja
Verbindungslokale IPv6-Adresse . : fe80::5cd7:2616:b389:fb14%15
IPv4-Adresse . . . . . . . . . . : 172.74.100.100(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
IPv4-Adresse . . . . . . . . . . : 172.74.201.10(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
IPv4-Adresse . . . . . . . . . . : 172.74.202.10(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
IPv4-Adresse . . . . . . . . . . : 172.74.203.10(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
IPv4-Adresse . . . . . . . . . . : 172.74.204.10(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
IPv4-Adresse . . . . . . . . . . : 172.74.205.10(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
IPv4-Adresse . . . . . . . . . . : 172.74.206.10(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
IPv4-Adresse . . . . . . . . . . : 172.74.207.10(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
IPv4-Adresse . . . . . . . . . . : 172.74.208.10(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
IPv4-Adresse . . . . . . . . . . : 172.74.209.10(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : 0.0.0.0
DHCPv6-IAID . . . . . . . . . . . : 234938444
DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-18-E2-FC-83-00-E

DNS-Server . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS über TCP/IP . . . . . . . : Aktiviert

Danke schon einmal für die Antworten.
Mitglied: Dani
29.07.2013 um 11:38 Uhr
Moin,
deinen Threadbetreff 1:1 in die Forensuche eingeben und der erste Treffer hilft dir weiter:
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...


Grüße,
Dani
Bitte warten ..
Mitglied: Evilmachine
29.07.2013 um 11:44 Uhr
Moin,

ne leider nicht.
Den habe ich auch schon gesehen.

Das Problem ist das mein Rechner quasi der Router ist. Es geht nur um den internen Zugriff.

Also das die Mitarbeiter aus dem Firmennetz in mein Testnetz können.

Unter Linux hab ich das mit quagga und ripd und dem Befehl

iptables -t nat -A POSTROUTING -j MASQUERADE

gemacht. Klappt super.

Nur unter Windows will es nicht.
Bitte warten ..
Mitglied: Dani
29.07.2013 um 11:51 Uhr
Moin,
Auch ein route ADD 172.74.100.100 MASK 255.255.255.0 172.16.100.238 hat nicht geklappt.
Die Route brauchst du auch nicht. Denn sobald die beiden Netzwerk "direct connected" sind erkennt das Windows automatisch.

Ich habe schon in der Registry das IPFowarding aktiviert
Den genauen Key bitte posten. Danach den Rechner neugestartet?
Was ist mit der Windows-Firewall? Zum Test mal komplett deaktiviert?


Grüße,
Dani
Bitte warten ..
Mitglied: Chonta
29.07.2013 um 11:53 Uhr
Hallo,

weil du bei Linux auch NAT eingerichtet hast und bei der Windowsversion nur Routest. Und beim nur rooten müssen alle beteiligten Router eine Route zum Netz kennen.
Wenn dein Windows "Router" seine Netze kennt ist das ja fein, aber wenn die anderen Rechner keine Route haben bzw dergen Defaultgateway auch nix weiß, wirds auch nix.

Gruß

Chonta
Bitte warten ..
Mitglied: Evilmachine
29.07.2013, aktualisiert um 11:56 Uhr
Die Windows Firewall ist bei uns intern sowieso durch Eset Endpoint Security deaktiviert.

Das War der Schlüssel HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\IpEnableRouter

Und klar. Rebootet hab ich auch.


Mit anderen Worten unser Router nach außen muss das Testnetz als statische Router verpasst bekommen??
Bitte warten ..
Mitglied: Chonta
29.07.2013, aktualisiert um 11:59 Uhr
Zitat von Evilmachine:
Die Windows Firewall ist bei uns intern sowieso durch Eset Endpoint Security deaktiviert.

Und das Tool bietet keine Firewallfunktionalität? Gute Idee.....

>Mit anderen Worten unser Router nach außen muss das Testnetz als statische Router verpasst bekommen??

Oder die Clients bekommen per Script eine Route in dein Testnetz verpasst, oder du bringst dem Windowsrouter NAT bei. Wobei NAT komplizierter wird, wenn dein Hauptnetz Dienste im Testnetz verwenden soll.
Also reines Rooting wäre besser und dann müssen die Testlanrechner den Windowsrouter als Default haben und die Rechner aus dem Hauptlan die ins Testlan dürfen brauchen eine Route.

Gruß

Chonta
Bitte warten ..
Mitglied: Evilmachine
29.07.2013 um 12:01 Uhr
Selbstverständlich bietet das eine Firewall.

Allerdings ist das der interne Traffic nicht geblockt.


Ok dann probiere ich das mal.ich melde mich wieder wenn es nicht klappt.
Bitte warten ..
Mitglied: chiefteddy
29.07.2013 um 12:05 Uhr
Hallo,

soweit ich weiß, enthalten die Desktop-Betriebssysteme von MS (WinXP, Vista, Win7+8) keine vollständige Implementierung der Layer 3- Funktionalität, dh. des Routings. Dies ist den Server-Versionen der Windows-Betriebssysteme vorbehalten. In den Desktop-BS ist nur ein rudimentäres Routing in Form der "Internet Verbindungsfreigabe" vorhanden. Von einem Win-PC über einen anderen Win-PC mit "Internet Verbindungsfreigabe" und angeschlossenem Modem kommst Du ins Internet. Mehr nicht. Erwarte also nicht, dass ein Win7- PC sich wie ein "richtiger" Router verhält.

Im Linux- Kernel ist eine vollständige Implementierung der Netzwerkschicht 3 (Routing) vorhanden. Deshalb funktionierte Deine Lösung auch unter Linux.

In dem von Dani geneanten Beitrag ist auch von Windows-Servern die Rede:

"IP Netzwerkkopplung (Routing) über einen Server oder PC mit 2 oder mehr LAN oder WLAN Netzwerkkarten oder mit einem dedizierten Router mit mehreren LAN Ports."

Mit freundlichen Grüßen

Jürgen
Bitte warten ..
Mitglied: Chonta
29.07.2013 um 12:10 Uhr
Hallo,

das mit windows und Routing stimmt teilweise.
Vom System her selber geht kein Routing bis auf die nternetfreigabe, aber mit Regestyumstelung geht auch rooting.
Zwar nicht so umfangreich wie bei Linux aber für den genannten Zweck ausreichend.

Die Linuxversion hatte gleich funktioniert, weil er keinen LinuxRouter eingerichtet hatte, sondern einen LinuxNAT-Router konfiguriert hat, und damit können die Rechner aus dem Testlan unter ter IP des NAT-Ruters im Hauptlan spielen.
Problematisch wird es dann, wenn man auf einen Rechner im Testlan zugreifen will, weil dann kennt man auch keine Route bzw muss mit der IP des Routers und Portweiterleitungen arbeiten.

Gruß

Chonta
Bitte warten ..
Mitglied: brammer
29.07.2013 um 12:24 Uhr
Hallo,

um dein system sauber zu konifgurieren solltest du vor allen mal auf RFC1918 IP Adressen umstellen!!

172.74

ist ein öffentlicher IP Address Bereich!
Nicht das dein Trqaffic bereits korrekt läuft...nämlich Richtung Internet ....

brammer
Bitte warten ..
Mitglied: Evilmachine
29.07.2013, aktualisiert um 12:28 Uhr
Mit anderen Worten es sollte gehen, tut es aber nicht??

So ich hab anscheinend nen Fortschritt gemacht.

Habe jetzt auf einem Linux Rechner im Firmennetz route add -net 172.74.100.0 netmask 255.255.255.0 gw 172.16.100.238 gemacht und die Anfragen scheinen auch am Rechner anzukommen.

Jetzt poppen hier bloß lauter Eset Meldungen auf Covert Channel Exploit in ICMP Paket von 172.74.100.4

Da werd ich mal unseren Admin antickern.

@brammer

Nee keine Angst. Das wird nicht raus geschickt^^
Bitte warten ..
Mitglied: chiefteddy
29.07.2013 um 12:31 Uhr
Hallo Chonta,

das Problem und die Lösung sind in den obigen Beiträgen ja schon angedeutet. Das Problem ist bei dem Desktop-Win, das die Routing-Protokolle (RIP oder OSPF) nicht implementiert werden. Damit kann der Desktop-PC ("Router") sicht keinen Überblick über die Struktur des Netzes verschaffen und damit keine Routing-Tabelle aufbauen. Umgekehrt "wissen" die anderen Router im Netz nichts von der Routing-Funktion des Win7-PC´s und der über ihn erreichbaren Sub-Netze. Man muß diese Informationen überall von Hand als statische Route eintragen.

Routing ist mehr als nur IP-Forwarding. Und in sofern hängt es von den Diensten ab, die Sascha.Urbansky in seinem Testnetz bereitstellt, ob alles geht oder nicht.

Mit freundlichen Grüßen

Jürgen
Bitte warten ..
Mitglied: Evilmachine
29.07.2013 um 12:34 Uhr
Ok.

Das hilft mir auf jeden Fall erstmal weiter.

Ich danke allen für die Antowrten hier.

Wünsche dann allen noch einen schönen Montag ;)
Bitte warten ..
Mitglied: aqui
29.07.2013, aktualisiert um 14:10 Uhr
Da es eine RIPv2 Implementation (ala Quagga) für Winblows 7 nicht gibt heisst die Devise also alles statisch routen !
Sinnvoller ist es dann 35 Euro in einen kleinen Raspberry Pi zu investieren und den mit Quagga als RIPv2 Router laufen zu lassen und die Winblows 7 Gurke wieder als PC was sie auch besser kann !
Wie man es macht...siehe hier im Kapitel "Quagga":
http://www.administrator.de/wissen/netzwerk-management-server-mit-raspb ...
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows 7
gelöst Sind euch verstärkte Probleme bei Windows 7 Updates aufgefallen? (4)

Frage von RadioHam zum Thema Windows 7 ...

Windows 7
Probleme bei Windows 7 Updates (12)

Frage von TechnoX zum Thema Windows 7 ...

Router & Routing
gelöst Routing - Netzwerk Problem - zwischen Filiale und Zentrale (12)

Frage von clonex zum Thema Router & Routing ...

Exchange Server
gelöst Probleme nach Windows Updates von Exchange 2010 SP3 Rollup 14 (6)

Frage von danieluk15 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...